summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Thomson <wltjr@gentoo.org>2006-11-15 18:29:31 +0000
committerWilliam Thomson <wltjr@gentoo.org>2006-11-15 18:29:31 +0000
commit7fcff087e31734b0f34f0edc2af8b154a39acb47 (patch)
treea581df15ef02d12434cf4f1241dac0b6f713d532 /dev-java/commons-httpclient
parentBug 155269: Forgot to check in xcf USE for magickthumbnail (diff)
downloadgentoo-2-7fcff087e31734b0f34f0edc2af8b154a39acb47.tar.gz
gentoo-2-7fcff087e31734b0f34f0edc2af8b154a39acb47.tar.bz2
gentoo-2-7fcff087e31734b0f34f0edc2af8b154a39acb47.zip
Fixed invalid iuse per bug #155268, changed from junit to test. However tests don't seem to be compiled or run :(, still needs luv there
(Portage version: 2.1.2_rc1-r6)
Diffstat (limited to 'dev-java/commons-httpclient')
-rw-r--r--dev-java/commons-httpclient/ChangeLog7
-rw-r--r--dev-java/commons-httpclient/commons-httpclient-3.0.1.ebuild16
2 files changed, 17 insertions, 6 deletions
diff --git a/dev-java/commons-httpclient/ChangeLog b/dev-java/commons-httpclient/ChangeLog
index 4e18651c4a55..138639bf7d8a 100644
--- a/dev-java/commons-httpclient/ChangeLog
+++ b/dev-java/commons-httpclient/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/commons-httpclient
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-httpclient/ChangeLog,v 1.32 2006/11/15 04:18:29 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-httpclient/ChangeLog,v 1.33 2006/11/15 18:29:31 wltjr Exp $
+
+ 15 Nov 2006; William L. Thomson Jr. <wltjr@gentoo.org>
+ commons-httpclient-3.0.1.ebuild:
+ Fixed invalid iuse per bug #155268, changed from junit to test. However
+ tests don't seem to be compiled or run :(, still needs luv there
15 Nov 2006; William L. Thomson Jr. <wltjr@gentoo.org>
+files/commons-httpclient-3.0.1-gentoo.patch:
diff --git a/dev-java/commons-httpclient/commons-httpclient-3.0.1.ebuild b/dev-java/commons-httpclient/commons-httpclient-3.0.1.ebuild
index 6aa277ea81e1..eebcdc8c23cd 100644
--- a/dev-java/commons-httpclient/commons-httpclient-3.0.1.ebuild
+++ b/dev-java/commons-httpclient/commons-httpclient-3.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-httpclient/commons-httpclient-3.0.1.ebuild,v 1.1 2006/11/15 04:10:15 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-httpclient/commons-httpclient-3.0.1.ebuild,v 1.2 2006/11/15 18:29:31 wltjr Exp $
inherit java-pkg-2 java-ant-2 eutils
@@ -12,7 +12,7 @@ SRC_URI="mirror://apache/jakarta/commons/httpclient/source/${MY_P}-src.tar.gz"
LICENSE="Apache-2.0"
SLOT="3"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="doc examples source"
+IUSE="doc examples source test"
RDEPEND=">=virtual/jre-1.3
dev-java/commons-logging
@@ -20,8 +20,11 @@ RDEPEND=">=virtual/jre-1.3
DEPEND=">=virtual/jdk-1.3
sys-apps/sed
- >=dev-java/ant-core-1.4
- junit? ( dev-java/junit )
+ test? (
+ dev-java/junit
+ dev-java/ant
+ )
+ !test? ( >=dev-java/ant-core-1.4 )
source? ( app-arch/zip )
${RDEPEND}"
@@ -37,7 +40,7 @@ src_unpack() {
}
src_compile() {
- eant dist $(use_doc)
+ eant dist $(use_doc) $(use test && echo "-Dtest.entry=true")
}
src_install() {
@@ -50,3 +53,6 @@ src_install() {
cp -r src/examples/* ${D}/usr/share/doc/${PF}/examples
fi
}
+src_test() {
+ eant test
+}