summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-07-16 21:46:02 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-07-16 21:46:02 +0000
commit8899a6480fc82235ee929b6aa9101838109ea785 (patch)
treea866e7ae5a54e546400781cd003a3c583b208b0e /dev-java/aspectj
parentmask jedit plugins (diff)
downloadgentoo-2-8899a6480fc82235ee929b6aa9101838109ea785.tar.gz
gentoo-2-8899a6480fc82235ee929b6aa9101838109ea785.tar.bz2
gentoo-2-8899a6480fc82235ee929b6aa9101838109ea785.zip
wecome back 1.1.1, dep of aspectj4emacs
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-java/aspectj')
-rw-r--r--dev-java/aspectj/Manifest12
-rw-r--r--dev-java/aspectj/aspectj-1.1.1.ebuild66
-rw-r--r--dev-java/aspectj/files/digest-aspectj-1.1.11
3 files changed, 69 insertions, 10 deletions
diff --git a/dev-java/aspectj/Manifest b/dev-java/aspectj/Manifest
index cf8502480493..5f2599893816 100644
--- a/dev-java/aspectj/Manifest
+++ b/dev-java/aspectj/Manifest
@@ -1,6 +1,4 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 aa871d8f4824d2e40e8e52063636b9b6 aspectj-1.1.1.ebuild 2267
MD5 7f5bd38c2ae560637a56f349976b6c9f aspectj-1.2.ebuild 2381
MD5 b6310194a4ffced57b4ae7533c94d161 ChangeLog 1364
MD5 72ba0dd87abe126d73774a74b1b4cbb1 metadata.xml 663
@@ -8,13 +6,7 @@ MD5 c46c31665f413547763e5b2c860e1782 files/ajc 143
MD5 d8e6e955badeb042ec37383717e5ca0c files/aspectj-1.2-version-gentoo.patch 964
MD5 a28d4390d35f00659399d020dceaa71c files/aspectj-1.2-fix-javadoc.patch 939
MD5 46d9b1155eb3ab559158a93afe23b36c files/ajbrowser 149
+MD5 4038bffac6102552f95eac41c4239b94 files/digest-aspectj-1.1.1 73
MD5 6f9b4aef0d744f489b6f506b3b83a542 files/aspectj-1.1.1-version-gentoo.patch 1263
MD5 15d8886f1eb56232e7d76c4e71c34763 files/aspectj-1.2-fix-examples-build.xml.patch 649
MD5 941140894bda896b874057612f14b88c files/digest-aspectj-1.2 73
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFC2UGA/rLF9B432nYRAthPAJ9teijUqhJ4JNsm8Urz7fx8taC8iQCfeU7t
-AocXEeCETw5VeFeca9VmuaM=
-=91A+
------END PGP SIGNATURE-----
diff --git a/dev-java/aspectj/aspectj-1.1.1.ebuild b/dev-java/aspectj/aspectj-1.1.1.ebuild
new file mode 100644
index 000000000000..474c387af9cf
--- /dev/null
+++ b/dev-java/aspectj/aspectj-1.1.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/aspectj/aspectj-1.1.1.ebuild,v 1.11 2005/07/16 21:46:02 axxo Exp $
+
+inherit java-pkg eutils
+
+DESCRIPTION="AspectJ is a seemless extension to the Java programming language for Aspect Oriented Programming (AOP)"
+SRC_URI="mirror://gentoo/aspectj-CVS-V1_1_1.tar.bz2"
+HOMEPAGE="http://www.eclipse.org/aspectj/"
+DEPEND=">=virtual/jdk-1.3
+ dev-java/ant"
+RDEPEND=">=virtual/jre-1.3"
+SLOT="0"
+LICENSE="CPL-1.0 Apache-1.1"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="doc"
+
+# Welcome to the AspectJ ebuild. An upstream source archive is not
+# available directly. The AspectJ source .tar.bz2 snapshot is taken
+# from CVS with the following command:
+#
+# cvs -z3 -d:pserver:anonymous@dev.eclipse.org:/home/technology \
+# co -rV1_1_1 org.aspectj/modules
+#
+# The source is then patched so that the installed binaries have
+# version information which reflects the tagged source release. The
+# AspectJ build system does not do this automatically.
+#
+# Useful documentation for this port:
+#
+# http://dev.eclipse.org/viewcvs/index.cgi/~checkout~/org.aspectj/modules/build/readme-build-and-test-aspectj.html?rev=HEAD&content-type=text/html&cvsroot=Technology_Project
+#
+# http://dev.eclipse.org/viewcvs/index.cgi/~checkout~/org.aspectj/modules/build/release-checklist.txt?rev=HEAD&content-type=text/plain&cvsroot=Technology_Project
+#
+
+S=${WORKDIR}/org.aspectj/modules
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/aspectj-${PV}-version-gentoo.patch
+ cd ${S}
+ sed -i "s,DEVELOPMENT,${PV},g" build/build-properties.xml
+ sed -i -e "s,@PV@,${PV},g" -e "s,@PV_LONG@,${PV} (Gentoo Build),g" \
+ org.aspectj.ajdt.core/src/org/aspectj/ajdt/ajc/messages.properties
+}
+
+src_compile() {
+ cd build
+ ant -f build.xml || die
+}
+
+src_install() {
+ mkdir aspectj-unpack
+ java -jar aj-build/dist/aspectj-${PV}.jar -to aspectj-unpack
+ cd aspectj-unpack
+ java-pkg_dojar lib/*.jar
+ dobin ${FILESDIR}/{ajc,ajbrowser}
+
+ dohtml doc/*.html
+ cp *.html ${D}/usr/share/doc/${PF}/
+ if use doc; then
+ cp -R doc/{devguide,api,progguide} ${D}/usr/share/doc/${PF}/html
+ cp -R doc/examples ${D}/usr/share/doc/${PF}
+ cp doc/*.pdf ${D}/usr/share/doc/${PF}
+ fi
+}
diff --git a/dev-java/aspectj/files/digest-aspectj-1.1.1 b/dev-java/aspectj/files/digest-aspectj-1.1.1
new file mode 100644
index 000000000000..b737e2c9a436
--- /dev/null
+++ b/dev-java/aspectj/files/digest-aspectj-1.1.1
@@ -0,0 +1 @@
+MD5 bfe210b3c071e0827b4366c712734096 aspectj-CVS-V1_1_1.tar.bz2 24504831