summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2007-04-25 20:45:54 +0000
committerVlastimil Babka <caster@gentoo.org>2007-04-25 20:45:54 +0000
commitc6049dd1972531a5db3bc5c18cbc0fc43ad447f2 (patch)
treec42096a62930dde0e498b227945ca1f4235b2b6a /dev-java/ant-tasks
parentCorrected LICENSE. (diff)
downloadgentoo-2-c6049dd1972531a5db3bc5c18cbc0fc43ad447f2.tar.gz
gentoo-2-c6049dd1972531a5db3bc5c18cbc0fc43ad447f2.tar.bz2
gentoo-2-c6049dd1972531a5db3bc5c18cbc0fc43ad447f2.zip
Clean unused version.
(Portage version: 2.1.2.4)
Diffstat (limited to 'dev-java/ant-tasks')
-rw-r--r--dev-java/ant-tasks/ChangeLog6
-rw-r--r--dev-java/ant-tasks/ant-tasks-1.7.0-r1.ebuild119
-rw-r--r--dev-java/ant-tasks/ant-tasks-1.7.0.ebuild98
-rw-r--r--dev-java/ant-tasks/files/digest-ant-tasks-1.7.00
-rw-r--r--dev-java/ant-tasks/files/digest-ant-tasks-1.7.0-r10
5 files changed, 5 insertions, 218 deletions
diff --git a/dev-java/ant-tasks/ChangeLog b/dev-java/ant-tasks/ChangeLog
index 9f0d574f6d34..da665a0f5775 100644
--- a/dev-java/ant-tasks/ChangeLog
+++ b/dev-java/ant-tasks/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/ant-tasks
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-tasks/ChangeLog,v 1.59 2007/03/28 09:36:43 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-tasks/ChangeLog,v 1.60 2007/04/25 20:45:54 caster Exp $
+
+ 25 Apr 2007; Vlastimil Babka <caster@gentoo.org> -ant-tasks-1.7.0.ebuild,
+ -ant-tasks-1.7.0-r1.ebuild:
+ Clean unused version.
*ant-tasks-1.7.0-r2 (28 Mar 2007)
diff --git a/dev-java/ant-tasks/ant-tasks-1.7.0-r1.ebuild b/dev-java/ant-tasks/ant-tasks-1.7.0-r1.ebuild
deleted file mode 100644
index 192c0fc5a008..000000000000
--- a/dev-java/ant-tasks/ant-tasks-1.7.0-r1.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-tasks/ant-tasks-1.7.0-r1.ebuild,v 1.1 2007/03/11 00:37:02 caster Exp $
-
-inherit java-pkg-2 eutils
-
-DESCRIPTION="Meta-package for Apache Ant's optional tasks."
-HOMEPAGE="http://ant.apache.org/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
-IUSE="jai javamail noantlr nobcel nobsf nocommonsnet nocommonslogging nojdepend
- nojmf nojsch nolog4j nooro noregexp noresolver noswing noxalan"
-# nobeanutils nobsh nojython norhino noxerces
-
-RDEPEND=">=virtual/jre-1.4
- ~dev-java/ant-core-${PV}
- ~dev-java/ant-nodeps-${PV}
- ~dev-java/ant-junit-${PV}
- !dev-java/ant-optional
- !noantlr? ( ~dev-java/ant-antlr-${PV} )
- !nobcel? ( ~dev-java/ant-apache-bcel-${PV} )
- !nobsf? ( ~dev-java/ant-apache-bsf-${PV} )
- !nolog4j? ( ~dev-java/ant-apache-log4j-${PV} )
- !nooro? ( ~dev-java/ant-apache-oro-${PV} )
- !noregexp? ( ~dev-java/ant-apache-regexp-${PV} )
- !noresolver? ( ~dev-java/ant-apache-resolver-${PV} )
- !nocommonslogging? ( ~dev-java/ant-commons-logging-${PV} )
- !nocommonsnet? ( ~dev-java/ant-commons-net-${PV} )
- jai? ( ~dev-java/ant-jai-${PV} )
- javamail? ( ~dev-java/ant-javamail-${PV} )
- !nojdepend? ( ~dev-java/ant-jdepend-${PV} )
- !nojmf? ( ~dev-java/ant-jmf-${PV} )
- !nojsch? ( ~dev-java/ant-jsch-${PV} )
- !noswing? ( ~dev-java/ant-swing-${PV} )
- !noxalan? ( ~dev-java/ant-trax-${PV} )"
-
-# TODO: consider those
-# !noxerces? ( >=dev-java/xerces-2.6.2-r1 )
-# !nobsh? ( >=dev-java/bsh-1.2-r7 )
-# !nobeanutils? ( =dev-java/commons-beanutils-1.6* )
-# !norhino? ( =dev-java/rhino-1.5* )
-# !nojython? ( >=dev-java/jython-2.1-r5 )
-
-DEPEND=">=virtual/jdk-1.4
- ${RDEPEND}"
-
-S="${WORKDIR}"
-
-src_compile() { :; }
-
-my_reg_jars() {
- # Recording jars to get the same behaviour as before
- local oldifs="${IFS}"
- IFS=":"
- for jar in $(java-pkg_getjars ${1}); do
- # these two are only for tasks, not core
- if [[ "${1}" != ant-core ]]; then
- # this one for package.env, thus java-config -p etc
- java-pkg_regjar "${jar}"
- # this one for broken stuff with hardcoded paths
- dosym ${jar} /usr/share/${PN}/lib/
- fi
- # this one for the non-split $ANT_HOME/lib expected by stuff that
- # doesn't use the launcher (eclipse, ...)
- dosym ${jar} /usr/share/ant/lib/
- done
- IFS="${oldifs}"
-}
-
-src_install() {
- # create the fake ANT_HOME with symlinks to all ant jars
- # starting with ant-core
- dodir /usr/share/ant/lib
- my_reg_jars ant-core
- # just in case
- dosym /usr/share/ant-core/bin /usr/share/ant/bin
-
- # now process the tasks
- use !noantlr && my_reg_jars ant-antlr
- use !nobcel && my_reg_jars ant-apache-bcel
- use !nobsf && my_reg_jars ant-apache-bsf
- use !nolog4j && my_reg_jars ant-apache-log4j
- use !nooro && my_reg_jars ant-apache-oro
- use !noregexp && my_reg_jars ant-apache-regexp
- use !noresolver && my_reg_jars ant-apache-resolver
- use !nocommonslogging && my_reg_jars ant-commons-logging
- use !nocommonsnet && my_reg_jars ant-commons-net
- use jai && my_reg_jars ant-jai
- use javamail && my_reg_jars ant-javamail
- use !nojdepend && my_reg_jars ant-jdepend
- use !nojmf && my_reg_jars ant-jmf
- use !nojsch && my_reg_jars ant-jsch
- my_reg_jars ant-junit
- use !noswing && my_reg_jars ant-swing
- use !noxalan && my_reg_jars ant-trax
-
- # point ANT_HOME to the one with all symlinked jars
- # ant-core startup script will ignore this one anyway
- echo "ANT_HOME=\"/usr/share/ant\"" > ${T}/21ant-tasks
- doenvd ${T}/21ant-tasks || die "failed to install env.d file"
-}
-
-pkg_postinst() {
- local noset=false
- for x in ${IUSE} ; do
- if [ "${x:0:2}" == "no" ] ; then
- use ${x} && noset=true
- fi
- done
- if [ ${noset} == "true" ]; then
- ewarn "You have disabled some of the ant tasks. Be advised that this may"
- ewarn "break building some of the Java packages!!"
- ewarn ""
- ewarn "We can only offer very limited support in cases where dev-java/ant-tasks"
- ewarn "has been build with essential features disabled."
- fi
-}
diff --git a/dev-java/ant-tasks/ant-tasks-1.7.0.ebuild b/dev-java/ant-tasks/ant-tasks-1.7.0.ebuild
deleted file mode 100644
index 4c02c57cf263..000000000000
--- a/dev-java/ant-tasks/ant-tasks-1.7.0.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-tasks/ant-tasks-1.7.0.ebuild,v 1.7 2007/02/09 18:58:58 betelgeuse Exp $
-
-inherit java-pkg-2 eutils
-
-DESCRIPTION="Meta-package for Apache Ant's optional tasks."
-HOMEPAGE="http://ant.apache.org/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
-IUSE="jai javamail noantlr nobcel nobsf nocommonsnet nocommonslogging nojdepend
- nojmf nojsch nolog4j nooro noregexp noresolver noswing noxalan"
-# nobeanutils nobsh nojython norhino noxerces
-
-RDEPEND=">=virtual/jre-1.4
- ~dev-java/ant-core-${PV}
- ~dev-java/ant-nodeps-${PV}
- ~dev-java/ant-junit-${PV}
- !dev-java/ant-optional
- !noantlr? ( ~dev-java/ant-antlr-${PV} )
- !nobcel? ( ~dev-java/ant-apache-bcel-${PV} )
- !nobsf? ( ~dev-java/ant-apache-bsf-${PV} )
- !nolog4j? ( ~dev-java/ant-apache-log4j-${PV} )
- !nooro? ( ~dev-java/ant-apache-oro-${PV} )
- !noregexp? ( ~dev-java/ant-apache-regexp-${PV} )
- !noresolver? ( ~dev-java/ant-apache-resolver-${PV} )
- !nocommonslogging? ( ~dev-java/ant-commons-logging-${PV} )
- !nocommonsnet? ( ~dev-java/ant-commons-net-${PV} )
- jai? ( ~dev-java/ant-jai-${PV} )
- javamail? ( ~dev-java/ant-javamail-${PV} )
- !nojdepend? ( ~dev-java/ant-jdepend-${PV} )
- !nojmf? ( ~dev-java/ant-jmf-${PV} )
- !nojsch? ( ~dev-java/ant-jsch-${PV} )
- !noswing? ( ~dev-java/ant-swing-${PV} )
- !noxalan? ( ~dev-java/ant-trax-${PV} )"
-
-# TODO: consider those
-# !noxerces? ( >=dev-java/xerces-2.6.2-r1 )
-# !nobsh? ( >=dev-java/bsh-1.2-r7 )
-# !nobeanutils? ( =dev-java/commons-beanutils-1.6* )
-# !norhino? ( =dev-java/rhino-1.5* )
-# !nojython? ( >=dev-java/jython-2.1-r5 )
-
-DEPEND=">=virtual/jdk-1.4
- ${RDEPEND}"
-
-S="${WORKDIR}"
-
-src_compile() { :; }
-
-my_reg_jars() {
- # Recording jars to get the same behaviour as before
- local oldifs="${IFS}"
- IFS=":"
- for jar in $(java-pkg_getjars ${1}); do
- java-pkg_regjar "${jar}"
- dosym ${jar} /usr/share/${PN}/lib/
- done
- IFS="${oldifs}"
-}
-
-src_install() {
- use !noantlr && my_reg_jars ant-antlr
- use !nobcel && my_reg_jars ant-apache-bcel
- use !nobsf && my_reg_jars ant-apache-bsf
- use !nolog4j && my_reg_jars ant-apache-log4j
- use !nooro && my_reg_jars ant-apache-oro
- use !noregexp && my_reg_jars ant-apache-regexp
- use !noresolver && my_reg_jars ant-apache-resolver
- use !nocommonslogging && my_reg_jars ant-commons-logging
- use !nocommonsnet && my_reg_jars ant-commons-net
- use jai && my_reg_jars ant-jai
- use javamail && my_reg_jars ant-javamail
- use !nojdepend && my_reg_jars ant-jdepend
- use !nojmf && my_reg_jars ant-jmf
- use !nojsch && my_reg_jars ant-jsch
- my_reg_jars ant-junit
- use !noswing && my_reg_jars ant-swing
- use !noxalan && my_reg_jars ant-trax
-}
-
-pkg_postinst() {
- local noset=false
- for x in ${IUSE} ; do
- if [ "${x:0:2}" == "no" ] ; then
- use ${x} && noset=true
- fi
- done
- if [ ${noset} == "true" ]; then
- ewarn "You have disabled some of the ant tasks. Be advised that this may"
- ewarn "break building some of the Java packages!!"
- ewarn ""
- ewarn "We can only offer very limited support in cases where dev-java/ant-tasks"
- ewarn "has been build with essential features disabled."
- fi
-}
diff --git a/dev-java/ant-tasks/files/digest-ant-tasks-1.7.0 b/dev-java/ant-tasks/files/digest-ant-tasks-1.7.0
deleted file mode 100644
index e69de29bb2d1..000000000000
--- a/dev-java/ant-tasks/files/digest-ant-tasks-1.7.0
+++ /dev/null
diff --git a/dev-java/ant-tasks/files/digest-ant-tasks-1.7.0-r1 b/dev-java/ant-tasks/files/digest-ant-tasks-1.7.0-r1
deleted file mode 100644
index e69de29bb2d1..000000000000
--- a/dev-java/ant-tasks/files/digest-ant-tasks-1.7.0-r1
+++ /dev/null