summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2009-07-30 20:50:29 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2009-07-30 20:50:29 +0000
commitfc8fddcad1c40e229e72cf54b7bd2195cb246be0 (patch)
treebb2dcac32679fd6ac3aecc6952077135579f0bfe /dev-haskell
parent install a few docs. bug 279693 (diff)
downloadgentoo-2-fc8fddcad1c40e229e72cf54b7bd2195cb246be0.tar.gz
gentoo-2-fc8fddcad1c40e229e72cf54b7bd2195cb246be0.tar.bz2
gentoo-2-fc8fddcad1c40e229e72cf54b7bd2195cb246be0.zip
Fix dev-haskell/hunit to compile with >=dev-lang/ghc-6.10
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/hunit/ChangeLog5
-rw-r--r--dev-haskell/hunit/hunit-1.2.0.0.ebuild11
2 files changed, 13 insertions, 3 deletions
diff --git a/dev-haskell/hunit/ChangeLog b/dev-haskell/hunit/ChangeLog
index cf467e59a81d..47ea58f38fb2 100644
--- a/dev-haskell/hunit/ChangeLog
+++ b/dev-haskell/hunit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-haskell/hunit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hunit/ChangeLog,v 1.31 2009/04/19 09:55:59 kolmodin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hunit/ChangeLog,v 1.32 2009/07/30 20:50:29 kolmodin Exp $
+
+ 30 Jul 2009; Lennart Kolmodin <kolmodin@gentoo.org> hunit-1.2.0.0.ebuild:
+ Make 1.2.0.0 compile with >=dev-lang/ghc-6.10.
*hunit-1.2.0.3 (19 Apr 2009)
diff --git a/dev-haskell/hunit/hunit-1.2.0.0.ebuild b/dev-haskell/hunit/hunit-1.2.0.0.ebuild
index 6ce7291cdbfb..2624ea02ff5b 100644
--- a/dev-haskell/hunit/hunit-1.2.0.0.ebuild
+++ b/dev-haskell/hunit/hunit-1.2.0.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hunit/hunit-1.2.0.0.ebuild,v 1.4 2008/10/03 23:46:30 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hunit/hunit-1.2.0.0.ebuild,v 1.5 2009/07/30 20:50:29 kolmodin Exp $
CABAL_FEATURES="lib profile haddock"
inherit base haskell-cabal
@@ -18,9 +18,16 @@ KEYWORDS="~alpha amd64 hppa ~ia64 ~ppc sparc x86"
IUSE=""
DEPEND=">=dev-lang/ghc-6.4"
+RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
+src_unpack() {
+ base_src_unpack
+
+ sed -e 's/base/base<4/' -i "${S}/${MY_PN}.cabal"
+}
+
src_install () {
cabal_src_install
if use doc; then