summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2015-04-05 09:46:22 +0000
committerMark Wright <gienah@gentoo.org>2015-04-05 09:46:22 +0000
commitd88ae896fdc9c48893dcab721473e20862f8d146 (patch)
tree30082dd21efd907aa370688f3eed1ed9c82ed9d8 /dev-haskell
parentMask dev-java/proguard[j2me]. (diff)
downloadgentoo-2-d88ae896fdc9c48893dcab721473e20862f8d146.tar.gz
gentoo-2-d88ae896fdc9c48893dcab721473e20862f8d146.tar.bz2
gentoo-2-d88ae896fdc9c48893dcab721473e20862f8d146.zip
Bump snap-core to 0.9.7.0
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/snap-core/ChangeLog7
-rw-r--r--dev-haskell/snap-core/snap-core-0.9.7.0.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-haskell/snap-core/ChangeLog b/dev-haskell/snap-core/ChangeLog
index 28441be9bf90..583330311ed7 100644
--- a/dev-haskell/snap-core/ChangeLog
+++ b/dev-haskell/snap-core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/snap-core
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/snap-core/ChangeLog,v 1.5 2015/01/01 09:44:01 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/snap-core/ChangeLog,v 1.6 2015/04/05 09:46:22 gienah Exp $
+
+*snap-core-0.9.7.0 (05 Apr 2015)
+
+ 05 Apr 2015; Mark Wright <gienah@gentoo.org> +snap-core-0.9.7.0.ebuild:
+ Bump snap-core to 0.9.7.0
*snap-core-0.9.6.4 (01 Jan 2015)
diff --git a/dev-haskell/snap-core/snap-core-0.9.7.0.ebuild b/dev-haskell/snap-core/snap-core-0.9.7.0.ebuild
new file mode 100644
index 000000000000..fe8216a3b17c
--- /dev/null
+++ b/dev-haskell/snap-core/snap-core-0.9.7.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/snap-core/snap-core-0.9.7.0.ebuild,v 1.1 2015/04/05 09:46:22 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Snap: A Haskell Web Framework (core interfaces and types)"
+HOMEPAGE="http://snapframework.com/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug portable"
+
+RDEPEND=">=dev-haskell/attoparsec-0.10:=[profile?] <dev-haskell/attoparsec-0.13:=[profile?]
+ >=dev-haskell/attoparsec-enumerator-0.3:=[profile?] <dev-haskell/attoparsec-enumerator-0.4:=[profile?]
+ >=dev-haskell/blaze-builder-0.2.1.4:=[profile?] <dev-haskell/blaze-builder-0.5:=[profile?]
+ >=dev-haskell/blaze-builder-enumerator-0.2:=[profile?] <dev-haskell/blaze-builder-enumerator-0.3:=[profile?]
+ >=dev-haskell/case-insensitive-0.3:=[profile?] <dev-haskell/case-insensitive-1.3:=[profile?]
+ >=dev-haskell/enumerator-0.4.15:=[profile?] <dev-haskell/enumerator-0.5:=[profile?]
+ >=dev-haskell/hunit-1.2:=[profile?] <dev-haskell/hunit-2:=[profile?]
+ >=dev-haskell/monadcatchio-transformers-0.2.1:=[profile?] <dev-haskell/monadcatchio-transformers-0.4:=[profile?]
+ >=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/random-1:=[profile?] <dev-haskell/random-2:=[profile?]
+ >=dev-haskell/regex-posix-0.95:=[profile?] <dev-haskell/regex-posix-1:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/unix-compat-0.2:=[profile?] <dev-haskell/unix-compat-0.5:=[profile?]
+ >=dev-haskell/unordered-containers-0.1.4.3:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/vector-0.6:=[profile?] <dev-haskell/vector-0.11:=[profile?]
+ >=dev-haskell/zlib-enum-0.2.1:=[profile?] <dev-haskell/zlib-enum-0.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ || ( ( >=dev-haskell/hashable-1.1:=[profile?] <dev-haskell/hashable-1.2:=[profile?] )
+ ( >=dev-haskell/hashable-1.2.1:=[profile?] <dev-haskell/hashable-1.3:=[profile?] ) )
+ portable? ( >=dev-haskell/old-locale-1:=[profile?] <dev-haskell/old-locale-2:=[profile?] )
+ !portable? ( >=dev-haskell/bytestring-mmap-0.2.2:=[profile?] <dev-haskell/bytestring-mmap-0.3:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag debug debug) \
+ $(cabal_flag portable portable)
+}