summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2006-10-11 18:50:15 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2006-10-11 18:50:15 +0000
commita7e451c36a5481afb6ce00941397f64c36278e47 (patch)
treeaa1131927925f37be2ef88e27315c41fc9f6b9ec /dev-haskell
parentCorrect the license for cpphs (diff)
downloadgentoo-2-a7e451c36a5481afb6ce00941397f64c36278e47.tar.gz
gentoo-2-a7e451c36a5481afb6ce00941397f64c36278e47.tar.bz2
gentoo-2-a7e451c36a5481afb6ce00941397f64c36278e47.zip
Added patch to fix building with ghc-6.6
(Portage version: 2.1.1-r1)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/haskell-src-exts/ChangeLog7
-rw-r--r--dev-haskell/haskell-src-exts/files/haskell-src-exts-0.2-hiding-isSymbol.patch68
-rw-r--r--dev-haskell/haskell-src-exts/haskell-src-exts-0.2.ebuild9
3 files changed, 81 insertions, 3 deletions
diff --git a/dev-haskell/haskell-src-exts/ChangeLog b/dev-haskell/haskell-src-exts/ChangeLog
index 8a3f723e0c9d..76b18c5e8f6c 100644
--- a/dev-haskell/haskell-src-exts/ChangeLog
+++ b/dev-haskell/haskell-src-exts/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/haskell-src-exts
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haskell-src-exts/ChangeLog,v 1.7 2006/03/09 18:33:19 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haskell-src-exts/ChangeLog,v 1.8 2006/10/11 18:50:14 dcoutts Exp $
+
+ 11 Oct 2006; Duncan Coutts <dcoutts@gentoo.org>
+ +files/haskell-src-exts-0.2-hiding-isSymbol.patch,
+ haskell-src-exts-0.2.ebuild:
+ Added patch to fix building with ghc-6.6
09 Mar 2006; Duncan Coutts <dcoutts@gentoo.org>
haskell-src-exts-0.2.ebuild:
diff --git a/dev-haskell/haskell-src-exts/files/haskell-src-exts-0.2-hiding-isSymbol.patch b/dev-haskell/haskell-src-exts/files/haskell-src-exts-0.2-hiding-isSymbol.patch
new file mode 100644
index 000000000000..df83e026fe0e
--- /dev/null
+++ b/dev-haskell/haskell-src-exts/files/haskell-src-exts-0.2-hiding-isSymbol.patch
@@ -0,0 +1,68 @@
+diff -urwpN haskell-src-exts.org/src/haskell-src-exts/Language/Haskell/Hsx/Lexer.hs haskell-src-exts/src/haskell-src-exts/Language/Haskell/Hsx/Lexer.hs
+--- haskell-src-exts.org/src/haskell-src-exts/Language/Haskell/Hsx/Lexer.hs 2005-05-01 22:40:45.000000000 +0100
++++ haskell-src-exts/src/haskell-src-exts/Language/Haskell/Hsx/Lexer.hs 2006-10-11 19:42:53.000000000 +0100
+@@ -207,9 +207,9 @@ special_varids = [
+ ( "hiding", KW_Hiding )
+ ]
+
+-isIdent, isSymbol :: Char -> Bool
++isIdent, isSymbol' :: Char -> Bool
+ isIdent c = isAlpha c || isDigit c || c == '\'' || c == '_'
+-isSymbol c = elem c ":!#$%&*+./<=>?@\\^|-~"
++isSymbol' c = elem c ":!#$%&*+./<=>?@\\^|-~"
+
+ matchChar :: Char -> String -> Lex a ()
+ matchChar c msg = do
+@@ -242,7 +242,7 @@ lexWhiteSpace bol = do
+ bol <- lexNestedComment bol
+ (bol, _) <- lexWhiteSpace bol
+ return (bol, True)
+- '-':'-':s | all (== '-') (takeWhile isSymbol s) -> do
++ '-':'-':s | all (== '-') (takeWhile isSymbol' s) -> do
+ lexWhile (== '-')
+ lexWhile (/= '\n')
+ lexNewline
+@@ -489,8 +489,8 @@ lexStdToken = do
+ Just keyword -> keyword
+ Nothing -> VarId ident
+
+- | isSymbol c -> do
+- sym <- lexWhile isSymbol
++ | isSymbol' c -> do
++ sym <- lexWhile isSymbol'
+ return $ case lookup sym (reserved_ops ++ special_varops) of
+ Just t -> t
+ Nothing -> case c of
+@@ -586,9 +586,9 @@ lexConIdOrQual qual = do
+ discard 1
+ lexConIdOrQual qual'
+
+- | isSymbol c -> do -- qualified symbol?
++ | isSymbol' c -> do -- qualified symbol?
+ discard 1
+- sym <- lexWhile isSymbol
++ sym <- lexWhile isSymbol'
+ case lookup sym reserved_ops of
+ -- cannot qualify a reserved operator
+ Just _ -> just_a_conid
+diff -urwpN haskell-src-exts.org/src/haskell-src-exts/Language/Haskell/Hsx/Transform.hs haskell-src-exts/src/haskell-src-exts/Language/Haskell/Hsx/Transform.hs
+--- haskell-src-exts.org/src/haskell-src-exts/Language/Haskell/Hsx/Transform.hs 2005-04-08 16:17:29.000000000 +0100
++++ haskell-src-exts/src/haskell-src-exts/Language/Haskell/Hsx/Transform.hs 2006-10-11 19:40:49.000000000 +0100
+@@ -1270,7 +1270,7 @@ trRPat s linear rp = case rp of
+ HsIdent n -> fail $ "Attempting to bind variable "++n++
+ " inside the context of a numerable regular pattern"
+ _ -> fail $ "This should never ever ever happen...\
+- \ how the ¤#% did you do it??!?"
++ \ how the #% did you do it??!?"
+
+ where -- | Generate a declaration for a @ binding.
+ mkAsDecl :: SrcLoc -> MFunMetaInfo -> Tr HsName
+@@ -1429,7 +1429,7 @@ trRPat s linear rp = case rp of
+ -- of transformations of optional patterns should be able to call it...)
+ mkOptDecl :: SrcLoc -> Bool -> MFunMetaInfo -> Tr MFunMetaInfo
+ mkOptDecl s greedy nvt@(_, vs, t) = do
+- -- Un nome, s'il vouz plaît.
++ -- Un nome, s'il vouz plaît.
+ n <- genMatchName
+ let -- Generate a generator for matching the subpattern
+ (g, val) = mkGenExp s nvt -- (harp_valX, (foo, bar, ...)) <- harp_matchY
diff --git a/dev-haskell/haskell-src-exts/haskell-src-exts-0.2.ebuild b/dev-haskell/haskell-src-exts/haskell-src-exts-0.2.ebuild
index a87aeb516c9a..e6e74ef99cc5 100644
--- a/dev-haskell/haskell-src-exts/haskell-src-exts-0.2.ebuild
+++ b/dev-haskell/haskell-src-exts/haskell-src-exts-0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haskell-src-exts/haskell-src-exts-0.2.ebuild,v 1.7 2006/03/09 18:33:19 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haskell-src-exts/haskell-src-exts-0.2.ebuild,v 1.8 2006/10/11 18:50:14 dcoutts Exp $
CABAL_FEATURES="lib happy"
inherit base haskell-cabal
@@ -14,13 +14,18 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE=""
-DEPEND="virtual/ghc"
+DEPEND=">=virtual/ghc-6.2
+ dev-haskell/happy"
S=${WORKDIR}/haskell-src-exts/src/haskell-src-exts
src_unpack() {
base_src_unpack
+ # Make it work with ghc 6.6
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-hiding-isSymbol.patch"
+
# Make it work with ghc pre-6.4
sed -i 's/{-# OPTIONS_GHC /{-# OPTIONS /' \
${S}/Language/Haskell/Hsx/Syntax.hs \