summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2006-10-11 23:21:13 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2006-10-11 23:21:13 +0000
commit57ddcd8dc8e486f74fe59235d97a2777b8d7e840 (patch)
tree79443f0420567f5ede7c3ff86c4b991bf4820c68 /dev-haskell
parentVersion bump (diff)
downloadgentoo-2-57ddcd8dc8e486f74fe59235d97a2777b8d7e840.tar.gz
gentoo-2-57ddcd8dc8e486f74fe59235d97a2777b8d7e840.tar.bz2
gentoo-2-57ddcd8dc8e486f74fe59235d97a2777b8d7e840.zip
Added patch to make buddha work with ghc-6.4 and 6.6.
(Portage version: 2.1.1-r1)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/buddha/ChangeLog8
-rw-r--r--dev-haskell/buddha/buddha-1.2-r1.ebuild54
-rw-r--r--dev-haskell/buddha/files/digest-buddha-1.2-r16
3 files changed, 67 insertions, 1 deletions
diff --git a/dev-haskell/buddha/ChangeLog b/dev-haskell/buddha/ChangeLog
index d286304f22a4..9d4f4617ce90 100644
--- a/dev-haskell/buddha/ChangeLog
+++ b/dev-haskell/buddha/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/buddha
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/buddha/ChangeLog,v 1.6 2006/08/24 10:16:12 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/buddha/ChangeLog,v 1.7 2006/10/11 23:21:13 dcoutts Exp $
+
+*buddha-1.2-r1 (11 Oct 2006)
+
+ 11 Oct 2006; Duncan Coutts <dcoutts@gentoo.org>
+ +files/buddha-1.2-ghc66.patch, +buddha-1.2-r1.ebuild:
+ Added patch to make buddha work with ghc-6.4 and 6.6.
24 Aug 2006; Markus Rothe <corsair@gentoo.org> buddha-1.2.ebuild:
Added ~ppc64
diff --git a/dev-haskell/buddha/buddha-1.2-r1.ebuild b/dev-haskell/buddha/buddha-1.2-r1.ebuild
new file mode 100644
index 000000000000..61f8ca352e2a
--- /dev/null
+++ b/dev-haskell/buddha/buddha-1.2-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/buddha/buddha-1.2-r1.ebuild,v 1.1 2006/10/11 23:21:13 dcoutts Exp $
+
+inherit base ghc-package multilib autotools
+
+DESCRIPTION="A declarative debugger for Haskell 98"
+HOMEPAGE="http://www.cs.mu.oz.au/~bjpop/buddha/"
+SRC_URI="http://www.cs.mu.oz.au/~bjpop/buddha/download/${P}.tar.gz
+ mirror://gentoo/${P}-ghc66.patch.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/ghc-6.4"
+
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ base_src_unpack
+
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-ghc66.patch.gz"
+
+ # Get rid of those 100's of pointless one-line 'wise' files:
+ sed -i 's/advice//' "${S}/Makefile.am"
+}
+
+src_compile() {
+ # Since we've patched the build system:
+ eautoreconf
+
+ econf --includedir=/usr/$(get_libdir)/buddha/include || die "Configure failed"
+
+ # Makefile has no parallelism
+ emake -j1 || die "Make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "Make install failed"
+
+ #note that buddha's ghc packages do not need to be registered
+}
+
+pkg_postinst() {
+ echo
+ ewarn "WARNING: buddha-1.2 appears to generate code which is not"
+ ewarn "fully compatible with ghc 6.4 or later. We are working on this"
+ ewarn "issue with the upstream developers. Please do not report this"
+ ewarn "as a bug, as we are already aware of the problem."
+ echo
+}
diff --git a/dev-haskell/buddha/files/digest-buddha-1.2-r1 b/dev-haskell/buddha/files/digest-buddha-1.2-r1
new file mode 100644
index 000000000000..28f8b1696456
--- /dev/null
+++ b/dev-haskell/buddha/files/digest-buddha-1.2-r1
@@ -0,0 +1,6 @@
+MD5 4e65bafed89f92aa22c347a14a6322f1 buddha-1.2-ghc66.patch.gz 15935
+RMD160 c05b821ff26c415046faa1b08bf344ae9578a305 buddha-1.2-ghc66.patch.gz 15935
+SHA256 632f946514f274c1e107aad81ddb355489ca8d60b2c7740c14e846d0fb23b373 buddha-1.2-ghc66.patch.gz 15935
+MD5 e662d5e2891d7d5e203c477723b62aa3 buddha-1.2.tar.gz 548697
+RMD160 ae7c5511ab3bf6436b517fe7c782ed666c906c91 buddha-1.2.tar.gz 548697
+SHA256 7996dca658af5ca4f67f705e1b5391ae1b47055577e73698f1d4cc2672f16cb3 buddha-1.2.tar.gz 548697