summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2015-08-02 22:05:49 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2015-08-02 22:05:49 +0000
commit471fc955e5f342946f818dba75f687172528f62a (patch)
tree361fc886bbc8e8f8b7d7234372ad7b807780f751 /dev-haskell
parentStable for amd64. Retroactively mark the remaining arches stable with ALLARCH... (diff)
downloadgentoo-2-471fc955e5f342946f818dba75f687172528f62a.tar.gz
gentoo-2-471fc955e5f342946f818dba75f687172528f62a.tar.bz2
gentoo-2-471fc955e5f342946f818dba75f687172528f62a.zip
Port to ghc-7.10, bug #556536 by Toralf Förster.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/lvmlib/ChangeLog6
-rw-r--r--dev-haskell/lvmlib/files/lvmlib-1.1-ghc-7.10.patch87
-rw-r--r--dev-haskell/lvmlib/lvmlib-1.1.ebuild8
3 files changed, 98 insertions, 3 deletions
diff --git a/dev-haskell/lvmlib/ChangeLog b/dev-haskell/lvmlib/ChangeLog
index a6575481ed6b..08d549b47724 100644
--- a/dev-haskell/lvmlib/ChangeLog
+++ b/dev-haskell/lvmlib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-haskell/lvmlib
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/lvmlib/ChangeLog,v 1.1 2015/08/01 11:58:27 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/lvmlib/ChangeLog,v 1.2 2015/08/02 22:05:49 slyfox Exp $
+
+ 02 Aug 2015; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/lvmlib-1.1-ghc-7.10.patch, lvmlib-1.1.ebuild:
+ Port to ghc-7.10, bug #556536 by Toralf Förster.
*lvmlib-1.1 (01 Aug 2015)
diff --git a/dev-haskell/lvmlib/files/lvmlib-1.1-ghc-7.10.patch b/dev-haskell/lvmlib/files/lvmlib-1.1-ghc-7.10.patch
new file mode 100644
index 000000000000..ad68d78f56e7
--- /dev/null
+++ b/dev-haskell/lvmlib/files/lvmlib-1.1-ghc-7.10.patch
@@ -0,0 +1,87 @@
+diff --git a/Lvm/Asm/Data.hs b/Lvm/Asm/Data.hs
+index 7939754..f3da0b7 100644
+--- a/Lvm/Asm/Data.hs
++++ b/Lvm/Asm/Data.hs
+@@ -17,2 +17,3 @@ import Lvm.Core.Module
+ import Text.PrettyPrint.Leijen
++import Prelude hiding ((<$>))
+
+diff --git a/Lvm/Common/IdMap.hs b/Lvm/Common/IdMap.hs
+index a50bcb6..10758e6 100644
+--- a/Lvm/Common/IdMap.hs
++++ b/Lvm/Common/IdMap.hs
+@@ -24,2 +24,3 @@ import Lvm.Common.Id
+ import Control.Arrow (first)
++import Prelude hiding (foldMap)
+
+diff --git a/Lvm/Core/Expr.hs b/Lvm/Core/Expr.hs
+index 8bc50d7..935e16a 100644
+--- a/Lvm/Core/Expr.hs
++++ b/Lvm/Core/Expr.hs
+@@ -17,2 +17,3 @@ import Lvm.Core.PrettyId
+ import Text.PrettyPrint.Leijen
++import Prelude hiding ((<$>))
+
+diff --git a/Lvm/Core/Module.hs b/Lvm/Core/Module.hs
+index 923870e..ac52201 100644
+--- a/Lvm/Core/Module.hs
++++ b/Lvm/Core/Module.hs
+@@ -24,2 +24,3 @@ import Lvm.Instr.Data
+ import Text.PrettyPrint.Leijen
++import Prelude hiding ((<$>))
+
+diff --git a/Lvm/Instr/Data.hs b/Lvm/Instr/Data.hs
+index 497a690..959cb5c 100644
+--- a/Lvm/Instr/Data.hs
++++ b/Lvm/Instr/Data.hs
+@@ -19,2 +19,3 @@ import Lvm.Common.Id
+ import Text.PrettyPrint.Leijen
++import Prelude hiding ((<$>))
+
+diff --git a/Lvm/Instr/Resolve.hs b/Lvm/Instr/Resolve.hs
+index 6845f74..4172a74 100644
+--- a/Lvm/Instr/Resolve.hs
++++ b/Lvm/Instr/Resolve.hs
+@@ -10,2 +10,4 @@ module Lvm.Instr.Resolve (instrResolve) where
+ import Control.Exception (assert)
++import Control.Applicative
++import Control.Monad
+ import Data.Maybe
+@@ -32,2 +34,6 @@ instance Functor Resolve where
+
++instance Applicative Resolve where
++ pure = return
++ (<*>) = ap -- defined in Control.Monad
++
+ instance Monad Resolve where
+diff --git a/Lvm/Read.hs b/Lvm/Read.hs
+index 7137331..25797f9 100644
+--- a/Lvm/Read.hs
++++ b/Lvm/Read.hs
+@@ -9,2 +9,3 @@ module Lvm.Read (lvmReadFile, lvmRead) where
+
++import Control.Applicative
+ import Control.Monad
+@@ -390,2 +391,7 @@ instance Functor (Read v) where
+ Result x st2 -> Result (f x) st2)
++
++instance Applicative (Read v) where
++ pure = return
++ (<*>) = ap -- defined in Control.Monad
++
+ instance Monad (Read v) where
+diff --git a/Lvm/Write.hs b/Lvm/Write.hs
+index 48570f8..37469bc 100644
+--- a/Lvm/Write.hs
++++ b/Lvm/Write.hs
+@@ -11,2 +11,3 @@ import qualified Control.Exception as CE (assert, catch, IOException)
+ import Control.Monad
++import Control.Applicative
+ import Data.Maybe
+@@ -465,2 +466,6 @@ instance Functor Emit where
+
++instance Applicative Emit where
++ pure = return
++ (<*>) = ap -- defined in Control.Monad
++
+ instance Monad Emit where
diff --git a/dev-haskell/lvmlib/lvmlib-1.1.ebuild b/dev-haskell/lvmlib/lvmlib-1.1.ebuild
index 9d01c75133a4..a5847670080a 100644
--- a/dev-haskell/lvmlib/lvmlib-1.1.ebuild
+++ b/dev-haskell/lvmlib/lvmlib-1.1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/lvmlib/lvmlib-1.1.ebuild,v 1.1 2015/08/01 11:58:27 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/lvmlib/lvmlib-1.1.ebuild,v 1.2 2015/08/02 22:05:49 slyfox Exp $
EAPI=5
# ebuild generated by hackport 0.4.4.9999
CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
-inherit haskell-cabal
+inherit eutils haskell-cabal
DESCRIPTION="The Lazy Virtual Machine (LVM)"
HOMEPAGE="http://www.cs.uu.nl/wiki/bin/view/Helium/WebHome"
@@ -25,3 +25,7 @@ RDEPEND="dev-haskell/parsec:=[profile?]
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.10.1.0
"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1-ghc-7.10.patch
+}