summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2007-12-13 05:47:02 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2007-12-13 05:47:02 +0000
commita10da797fc9e97f5763614883a8dfdefd24175cc (patch)
treebfa8ffee9963641bb11a8db4443588492da911ec /dev-haskell/mtl
parentUpdates for upward compatability with cabal-1.2 and ghc-6.8 (diff)
downloadgentoo-2-a10da797fc9e97f5763614883a8dfdefd24175cc.tar.gz
gentoo-2-a10da797fc9e97f5763614883a8dfdefd24175cc.tar.bz2
gentoo-2-a10da797fc9e97f5763614883a8dfdefd24175cc.zip
Updates for upward compatability with cabal-1.2 and ghc-6.8
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-haskell/mtl')
-rw-r--r--dev-haskell/mtl/ChangeLog6
-rw-r--r--dev-haskell/mtl/mtl-1.0-r1.ebuild7
-rw-r--r--dev-haskell/mtl/mtl-1.0.1.ebuild5
3 files changed, 13 insertions, 5 deletions
diff --git a/dev-haskell/mtl/ChangeLog b/dev-haskell/mtl/ChangeLog
index e74744e2a7e2..ed3ff3dd4fd7 100644
--- a/dev-haskell/mtl/ChangeLog
+++ b/dev-haskell/mtl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-haskell/mtl
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/mtl/ChangeLog,v 1.23 2007/12/13 00:50:15 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/mtl/ChangeLog,v 1.24 2007/12/13 05:47:02 dcoutts Exp $
+
+ 13 Dec 2007; Duncan Coutts <dcoutts@gentoo.org> mtl-1.0-r1.ebuild,
+ mtl-1.0.1.ebuild:
+ Updates for upward compatability with cabal-1.2 and ghc-6.8
13 Dec 2007; Duncan Coutts <dcoutts@gentoo.org> mtl-1.0.ebuild:
Remove unnecessary blocker.
diff --git a/dev-haskell/mtl/mtl-1.0-r1.ebuild b/dev-haskell/mtl/mtl-1.0-r1.ebuild
index e7b8fa4924e6..5f4d2933d3b5 100644
--- a/dev-haskell/mtl/mtl-1.0-r1.ebuild
+++ b/dev-haskell/mtl/mtl-1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/mtl/mtl-1.0-r1.ebuild,v 1.4 2007/07/08 15:48:32 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/mtl/mtl-1.0-r1.ebuild,v 1.5 2007/12/13 05:47:02 dcoutts Exp $
CABAL_FEATURES="lib profile haddock"
inherit haskell-cabal
@@ -19,3 +19,8 @@ IUSE=""
DEPEND=">=dev-lang/ghc-6.6"
S="${WORKDIR}/ghc-${GHC_PV}/libraries/${PN}"
+
+src_unpack() {
+ unpack "${A}"
+ cabal-mksetup
+}
diff --git a/dev-haskell/mtl/mtl-1.0.1.ebuild b/dev-haskell/mtl/mtl-1.0.1.ebuild
index e9781804cea7..872462b5f302 100644
--- a/dev-haskell/mtl/mtl-1.0.1.ebuild
+++ b/dev-haskell/mtl/mtl-1.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/mtl/mtl-1.0.1.ebuild,v 1.5 2007/12/12 13:24:30 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/mtl/mtl-1.0.1.ebuild,v 1.6 2007/12/13 05:47:02 dcoutts Exp $
CABAL_FEATURES="lib profile haddock"
inherit haskell-cabal
@@ -20,8 +20,7 @@ DEPEND=">=dev-lang/ghc-6.6"
S="${WORKDIR}/ghc-${GHC_PV}/libraries/${PN}"
-# Sadly Setup.hs in the ghc-6.6.1 extralibs was not tested with Cabal-1.1.6.x
src_unpack() {
unpack "${A}"
- sed -i -e "/type Hook/ s/UserHooks/Maybe UserHooks/" "${S}/Setup.hs"
+ cabal-mksetup
}