summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-03-09 12:45:49 +0000
committerMark Wright <gienah@gentoo.org>2014-03-09 12:45:49 +0000
commit2a573591edb43879cd8163af9d79b71cd6494d6d (patch)
tree7401f747a6dc3bf0777afa1a1c48f9a2e932b6f2 /dev-haskell/http-client
parentBump http-attoparsec to 0.1.1 (diff)
downloadgentoo-2-2a573591edb43879cd8163af9d79b71cd6494d6d.tar.gz
gentoo-2-2a573591edb43879cd8163af9d79b71cd6494d6d.tar.bz2
gentoo-2-2a573591edb43879cd8163af9d79b71cd6494d6d.zip
Bump http-client to 0.2.2.2
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/http-client')
-rw-r--r--dev-haskell/http-client/ChangeLog9
-rw-r--r--dev-haskell/http-client/http-client-0.2.2.2.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/dev-haskell/http-client/ChangeLog b/dev-haskell/http-client/ChangeLog
index ba8fd9cb9d5c..8cfc25454da3 100644
--- a/dev-haskell/http-client/ChangeLog
+++ b/dev-haskell/http-client/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/http-client
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http-client/ChangeLog,v 1.1 2013/12/11 06:05:46 gienah Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http-client/ChangeLog,v 1.2 2014/03/09 12:45:49 gienah Exp $
+
+*http-client-0.2.2.2 (09 Mar 2014)
+
+ 09 Mar 2014; Mark Wright <gienah@gentoo.org> +http-client-0.2.2.2.ebuild:
+ Bump http-client to 0.2.2.2
*http-client-0.2.0.3 (11 Dec 2013)
diff --git a/dev-haskell/http-client/http-client-0.2.2.2.ebuild b/dev-haskell/http-client/http-client-0.2.2.2.ebuild
new file mode 100644
index 000000000000..cc318b5f25ce
--- /dev/null
+++ b/dev-haskell/http-client/http-client-0.2.2.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http-client/http-client-0.2.2.2.ebuild,v 1.1 2014/03/09 12:45:49 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="An HTTP client engine, intended as a base layer for more user-friendly packages."
+HOMEPAGE="https://github.com/snoyberg/http-client"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/base64-bytestring-1.0:=[profile?] <dev-haskell/base64-bytestring-1.1:=[profile?]
+ >=dev-haskell/blaze-builder-0.3:=[profile?]
+ >=dev-haskell/case-insensitive-1.0:=[profile?] <dev-haskell/case-insensitive-1.2:=[profile?]
+ dev-haskell/cookie:=[profile?]
+ dev-haskell/data-default-class:=[profile?]
+ >=dev-haskell/failure-0.2:=[profile?] <dev-haskell/failure-0.3:=[profile?]
+ >=dev-haskell/http-types-0.8:=[profile?]
+ >=dev-haskell/network-2.3:=[profile?]
+ dev-haskell/publicsuffixlist:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-haskell/zlib-bindings-0.1:=[profile?] <dev-haskell/zlib-bindings-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/deepseq
+ dev-haskell/hspec
+ dev-haskell/monad-control
+ dev-haskell/zlib )
+"