summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Francisco Araujo <araujo@gentoo.org>2008-07-05 23:48:17 +0000
committerLuis Francisco Araujo <araujo@gentoo.org>2008-07-05 23:48:17 +0000
commit4a939781649ad7e359a307343f43146a919f3226 (patch)
tree2dcb9664c3656e33fcf93eb5a9a979824183554c /dev-haskell/hmake/hmake-3.11.ebuild
parentRev bump for libmtp-0.3.0 compat. Bug #230885. (diff)
downloadgentoo-2-4a939781649ad7e359a307343f43146a919f3226.tar.gz
gentoo-2-4a939781649ad7e359a307343f43146a919f3226.tar.bz2
gentoo-2-4a939781649ad7e359a307343f43146a919f3226.zip
Fixing bug #154848
(Portage version: 2.2_rc1/cvs/Linux 2.6.24.3 x86_64)
Diffstat (limited to 'dev-haskell/hmake/hmake-3.11.ebuild')
-rw-r--r--dev-haskell/hmake/hmake-3.11.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-haskell/hmake/hmake-3.11.ebuild b/dev-haskell/hmake/hmake-3.11.ebuild
index c5ea41bc136d..1abe5838a5f2 100644
--- a/dev-haskell/hmake/hmake-3.11.ebuild
+++ b/dev-haskell/hmake/hmake-3.11.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hmake/hmake-3.11.ebuild,v 1.13 2008/03/10 22:42:35 araujo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hmake/hmake-3.11.ebuild,v 1.14 2008/07/05 23:48:17 araujo Exp $
-inherit base eutils fixheadtails ghc-package
+inherit base eutils fixheadtails ghc-package flag-o-matic
DESCRIPTION="A make tool for Haskell programs"
HOMEPAGE="http://www.haskell.org/hmake/"
@@ -16,8 +16,7 @@ IUSE=""
DEPEND="!>=dev-lang/ghc-6.8
sys-libs/readline
>=sys-apps/sandbox-1.2.12"
-RDEPEND="dev-lang/ghc
- sys-libs/readline"
+RDEPEND="sys-libs/readline"
# sandbox dependency due to bug #97441, #101433
@@ -41,6 +40,8 @@ src_unpack() {
# the line above prevents current fixheadtails.eclass from doing nonsense;
# double space before -n is significant
ht_fix_all
+ # Make it compile with -Wl, -O1
+ filter-ldflags -*
}
src_compile() {