summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2014-01-29 21:57:40 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2014-01-29 21:57:40 +0000
commitace6399c8cd869d8885027402a93543863984fad (patch)
tree8c8bab404a4fee38af27f11aa920ab1b72aefc63 /dev-haskell/hlint
parentInitial import. Help writing simple, concise and fast generic operations in h... (diff)
downloadgentoo-2-ace6399c8cd869d8885027402a93543863984fad.tar.gz
gentoo-2-ace6399c8cd869d8885027402a93543863984fad.tar.bz2
gentoo-2-ace6399c8cd869d8885027402a93543863984fad.zip
Initiali import of library and tool for source code suggestions from gentoo-haskell overlay (asked by asgar).
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell/hlint')
-rw-r--r--dev-haskell/hlint/ChangeLog10
-rw-r--r--dev-haskell/hlint/files/60hlint-gentoo.el7
-rw-r--r--dev-haskell/hlint/hlint-1.8.55.ebuild69
-rw-r--r--dev-haskell/hlint/metadata.xml11
4 files changed, 97 insertions, 0 deletions
diff --git a/dev-haskell/hlint/ChangeLog b/dev-haskell/hlint/ChangeLog
new file mode 100644
index 000000000000..22febbb5a954
--- /dev/null
+++ b/dev-haskell/hlint/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-haskell/hlint
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hlint/ChangeLog,v 1.1 2014/01/29 21:57:40 slyfox Exp $
+
+*hlint-1.8.55 (29 Jan 2014)
+
+ 29 Jan 2014; Sergei Trofimovich <slyfox@gentoo.org> +files/60hlint-gentoo.el,
+ +hlint-1.8.55.ebuild, +metadata.xml:
+ Initiali import of library and tool for source code suggestions from gentoo-
+ haskell overlay (asked by asgar).
diff --git a/dev-haskell/hlint/files/60hlint-gentoo.el b/dev-haskell/hlint/files/60hlint-gentoo.el
new file mode 100644
index 000000000000..990d5a89b5fb
--- /dev/null
+++ b/dev-haskell/hlint/files/60hlint-gentoo.el
@@ -0,0 +1,7 @@
+
+;; hlint emacs integration site initialisation
+(add-to-list 'load-path "@SITELISP@")
+(require 'hs-lint)
+(defun hlint-haskell-mode-hook ()
+ (local-set-key "\C-cl" 'hs-lint))
+(add-hook 'haskell-mode-hook 'hlint-haskell-mode-hook)
diff --git a/dev-haskell/hlint/hlint-1.8.55.ebuild b/dev-haskell/hlint/hlint-1.8.55.ebuild
new file mode 100644
index 000000000000..f23fc6945aeb
--- /dev/null
+++ b/dev-haskell/hlint/hlint-1.8.55.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hlint/hlint-1.8.55.ebuild,v 1.1 2014/01/29 21:57:40 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal elisp-common
+
+DESCRIPTION="Source code suggestions"
+HOMEPAGE="http://community.haskell.org/~ndm/hlint/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="emacs"
+
+RDEPEND=">=dev-haskell/cpphs-1.11:=[profile?]
+ >=dev-haskell/haskell-src-exts-1.14:=[profile?] <dev-haskell/haskell-src-exts-1.15:=[profile?]
+ >=dev-haskell/hscolour-1.17:=[profile?]
+ >=dev-haskell/transformers-0.0:=[profile?]
+ >=dev-haskell/uniplate-1.5:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+"
+
+SITEFILE="60${PN}-gentoo.el"
+
+src_configure() {
+ local threaded_flag=""
+ if $(ghc-supports-threaded-runtime); then
+ threaded_flag="--flags=threaded"
+ else
+ threaded_flag="--flags=-threaded"
+ fi
+ cabal_src_configure \
+ $threaded_flag
+}
+
+src_compile() {
+ cabal_src_compile
+
+ use emacs && elisp-compile data/hs-lint.el
+}
+
+src_install() {
+ cabal_src_install
+
+ if use emacs; then
+ elisp-install ${PN} data/*.el data/*.elc || die "elisp-install failed."
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ dodoc hlint.htm
+}
+
+pkg_postinst() {
+ ghc-package_pkg_postinst
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-haskell/hlint/metadata.xml b/dev-haskell/hlint/metadata.xml
new file mode 100644
index 000000000000..e31b571f3ae3
--- /dev/null
+++ b/dev-haskell/hlint/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ HLint gives suggestions on how to improve your source code.
+ </longdescription>
+</pkgmetadata>