summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2015-04-05 05:12:24 +0000
committerMark Wright <gienah@gentoo.org>2015-04-05 05:12:24 +0000
commit29fb06fe72f9217da01d6a2e4e7824486a693626 (patch)
tree9f5dc091f14450798115ad943ace243020b17291 /dev-haskell/edit-distance
parentBump c2hs to 0.25.2 (diff)
downloadgentoo-2-29fb06fe72f9217da01d6a2e4e7824486a693626.tar.gz
gentoo-2-29fb06fe72f9217da01d6a2e4e7824486a693626.tar.bz2
gentoo-2-29fb06fe72f9217da01d6a2e4e7824486a693626.zip
Patch edit-distance-0.2.1.2 for ghc 7.10.1
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/edit-distance')
-rw-r--r--dev-haskell/edit-distance/ChangeLog7
-rw-r--r--dev-haskell/edit-distance/edit-distance-0.2.1.2.ebuild9
2 files changed, 12 insertions, 4 deletions
diff --git a/dev-haskell/edit-distance/ChangeLog b/dev-haskell/edit-distance/ChangeLog
index 2c0a639999f5..be68c1016b12 100644
--- a/dev-haskell/edit-distance/ChangeLog
+++ b/dev-haskell/edit-distance/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-haskell/edit-distance
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/edit-distance/ChangeLog,v 1.6 2014/07/25 08:59:32 slyfox Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/edit-distance/ChangeLog,v 1.7 2015/04/05 05:12:24 gienah Exp $
+
+ 05 Apr 2015; Mark Wright <gienah@gentoo.org> edit-distance-0.2.1.2.ebuild:
+ Patch edit-distance-0.2.1.2 for ghc 7.10.1
25 Jul 2014; Sergei Trofimovich <slyfox@gentoo.org> metadata.xml:
Drop redundant '<maintainer>' field, leave only '<herd>'.
diff --git a/dev-haskell/edit-distance/edit-distance-0.2.1.2.ebuild b/dev-haskell/edit-distance/edit-distance-0.2.1.2.ebuild
index d78862eeb104..d99a0682b8d3 100644
--- a/dev-haskell/edit-distance/edit-distance-0.2.1.2.ebuild
+++ b/dev-haskell/edit-distance/edit-distance-0.2.1.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/edit-distance/edit-distance-0.2.1.2.ebuild,v 1.2 2013/07/21 17:29:16 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/edit-distance/edit-distance-0.2.1.2.ebuild,v 1.3 2015/04/05 05:12:24 gienah Exp $
EAPI=5
@@ -23,6 +23,11 @@ RDEPEND=">=dev-haskell/random-1.0:=[profile?]
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.2"
+src_prepare() {
+ sed -e 's@LANGUAGE @LANGUAGE FlexibleContexts, @' \
+ -i "${S}/Text/EditDistance/STUArray.hs" || die
+}
+
src_configure() {
haskell-cabal_src_configure \
--flag=splitbase \