summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-03-10 15:41:21 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-03-10 15:41:21 +0000
commit7e26bc6d113cc93fccc2776c4be037076ed6dde4 (patch)
tree8b9ed204cbcff4c1c5bfba73ada7cbe706d858fa /dev-haskell/diff
parentUse EAPI 4 to make use of REPLACING_VERSIONS which enables us to show pkg_pos... (diff)
downloadgentoo-2-7e26bc6d113cc93fccc2776c4be037076ed6dde4.tar.gz
gentoo-2-7e26bc6d113cc93fccc2776c4be037076ed6dde4.tar.bz2
gentoo-2-7e26bc6d113cc93fccc2776c4be037076ed6dde4.zip
Initial version. Basic haskell implementation of the standard diff algorithm. A depend for app-text/pandoc-1.9.
(Portage version: 2.2.0_alpha90_p1/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/diff')
-rw-r--r--dev-haskell/diff/ChangeLog11
-rw-r--r--dev-haskell/diff/diff-0.1.3.ebuild28
-rw-r--r--dev-haskell/diff/metadata.xml11
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-haskell/diff/ChangeLog b/dev-haskell/diff/ChangeLog
new file mode 100644
index 000000000000..a46b15481d5f
--- /dev/null
+++ b/dev-haskell/diff/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-haskell/diff
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/diff/ChangeLog,v 1.1 2012/03/10 15:41:21 slyfox Exp $
+
+*diff-0.1.3 (10 Mar 2012)
+
+ 10 Mar 2012; Sergei Trofimovich <slyfox@gentoo.org> +diff-0.1.3.ebuild,
+ +metadata.xml:
+ Initial version. Basic haskell implementation of the standard diff algorithm.
+ A depend for app-text/pandoc-1.9.
+
diff --git a/dev-haskell/diff/diff-0.1.3.ebuild b/dev-haskell/diff/diff-0.1.3.ebuild
new file mode 100644
index 000000000000..5a14e9973982
--- /dev/null
+++ b/dev-haskell/diff/diff-0.1.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/diff/diff-0.1.3.ebuild,v 1.1 2012/03/10 15:41:21 slyfox Exp $
+
+# ebuild generated by hackport 0.2.17.9999
+
+EAPI=4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="Diff"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="O(ND) diff algorithm in haskell."
+HOMEPAGE="http://hackage.haskell.org/package/Diff"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-haskell/diff/metadata.xml b/dev-haskell/diff/metadata.xml
new file mode 100644
index 000000000000..f05bbcb07114
--- /dev/null
+++ b/dev-haskell/diff/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Basic implementation of the standard diff algorithm.
+ </longdescription>
+</pkgmetadata>