summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-05-25 09:20:46 +0000
committerMark Wright <gienah@gentoo.org>2013-05-25 09:20:46 +0000
commitce4244ac3dbf2a6a5f1213a826697c434e197c70 (patch)
treeb5c586c883b9656523992ea4acc81761c61d20ef /dev-haskell/chasingbottoms
parentVersion bump. Bug #469592 (diff)
downloadgentoo-2-ce4244ac3dbf2a6a5f1213a826697c434e197c70.tar.gz
gentoo-2-ce4244ac3dbf2a6a5f1213a826697c434e197c70.tar.bz2
gentoo-2-ce4244ac3dbf2a6a5f1213a826697c434e197c70.zip
Bump chasingbottoms to 1.3.0.6
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/chasingbottoms')
-rw-r--r--dev-haskell/chasingbottoms/ChangeLog7
-rw-r--r--dev-haskell/chasingbottoms/chasingbottoms-1.3.0.6.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-haskell/chasingbottoms/ChangeLog b/dev-haskell/chasingbottoms/ChangeLog
index a8a3d64c9684..f3957a4d18fc 100644
--- a/dev-haskell/chasingbottoms/ChangeLog
+++ b/dev-haskell/chasingbottoms/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/chasingbottoms
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/chasingbottoms/ChangeLog,v 1.2 2013/04/16 06:13:37 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/chasingbottoms/ChangeLog,v 1.3 2013/05/25 09:20:46 gienah Exp $
+
+*chasingbottoms-1.3.0.6 (25 May 2013)
+
+ 25 May 2013; Mark Wright <gienah@gentoo.org> +chasingbottoms-1.3.0.6.ebuild:
+ Bump chasingbottoms to 1.3.0.6
16 Apr 2013; Sergei Trofimovich <slyfox@gentoo.org>
+files/chasingbottoms-1.3.0.5-ghc-7.6.patch:
diff --git a/dev-haskell/chasingbottoms/chasingbottoms-1.3.0.6.ebuild b/dev-haskell/chasingbottoms/chasingbottoms-1.3.0.6.ebuild
new file mode 100644
index 000000000000..3281785c482a
--- /dev/null
+++ b/dev-haskell/chasingbottoms/chasingbottoms-1.3.0.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/chasingbottoms/chasingbottoms-1.3.0.6.ebuild,v 1.1 2013/05/25 09:20:46 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="ChasingBottoms"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="For testing partial and infinite values."
+HOMEPAGE="http://hackage.haskell.org/package/ChasingBottoms"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-haskell/mtl-1.1:=[profile?]
+ <dev-haskell/mtl-2.2:=[profile?]
+ >=dev-haskell/quickcheck-2.1:2=[profile?]
+ <dev-haskell/quickcheck-2.7:2=[profile?]
+ =dev-haskell/random-1.0*:=[profile?]
+ >=dev-haskell/syb-0.1.0.2:=[profile?]
+ <dev-haskell/syb-0.5:=[profile?]
+ >=dev-lang/ghc-6.12.1:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag test build-tests)
+}