summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2015-04-04 09:11:09 +0000
committerMark Wright <gienah@gentoo.org>2015-04-04 09:11:09 +0000
commitba8113169ec2f926b10e3c25e87d0a30b8f72343 (patch)
tree904a0ba9952c86605e34886edf09ca7d8f283d7d /dev-haskell/chasingbottoms
parentBump threads to 0.5.1.3 (diff)
downloadgentoo-2-ba8113169ec2f926b10e3c25e87d0a30b8f72343.tar.gz
gentoo-2-ba8113169ec2f926b10e3c25e87d0a30b8f72343.tar.bz2
gentoo-2-ba8113169ec2f926b10e3c25e87d0a30b8f72343.zip
Bump chasingbottoms to 1.3.0.11-r1
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/chasingbottoms')
-rw-r--r--dev-haskell/chasingbottoms/ChangeLog8
-rw-r--r--dev-haskell/chasingbottoms/chasingbottoms-1.3.0.11-r1.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-haskell/chasingbottoms/ChangeLog b/dev-haskell/chasingbottoms/ChangeLog
index 78999d1e8027..dc2e951406b3 100644
--- a/dev-haskell/chasingbottoms/ChangeLog
+++ b/dev-haskell/chasingbottoms/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/chasingbottoms
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/chasingbottoms/ChangeLog,v 1.13 2015/01/31 19:20:34 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/chasingbottoms/ChangeLog,v 1.14 2015/04/04 09:11:09 gienah Exp $
+
+*chasingbottoms-1.3.0.11-r1 (04 Apr 2015)
+
+ 04 Apr 2015; Mark Wright <gienah@gentoo.org>
+ +chasingbottoms-1.3.0.11-r1.ebuild:
+ Bump chasingbottoms to 1.3.0.11-r1
31 Jan 2015; Alexander Vershilov <qnikst@gentoo.org>
-chasingbottoms-1.3.0.5-r2.ebuild, -chasingbottoms-1.3.0.6.ebuild,
diff --git a/dev-haskell/chasingbottoms/chasingbottoms-1.3.0.11-r1.ebuild b/dev-haskell/chasingbottoms/chasingbottoms-1.3.0.11-r1.ebuild
new file mode 100644
index 000000000000..15f8346de057
--- /dev/null
+++ b/dev-haskell/chasingbottoms/chasingbottoms-1.3.0.11-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/chasingbottoms/chasingbottoms-1.3.0.11-r1.ebuild,v 1.1 2015/04/04 09:11:09 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+#hackport: flags: -build-tests
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+MY_PN="ChasingBottoms"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="For testing partial and infinite values"
+HOMEPAGE="http://hackage.haskell.org/package/ChasingBottoms"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # takes a lot
+
+RDEPEND=">=dev-haskell/mtl-1.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/quickcheck-2.1:2=[profile?]
+ >=dev-haskell/random-1.0:=[profile?] <dev-haskell/random-1.2:=[profile?]
+ >=dev-haskell/syb-0.1.0.2:=[profile?] <dev-haskell/syb-0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.9.2
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ cabal_chdeps \
+ 'QuickCheck >= 2.1 && < 2.8' 'QuickCheck >= 2.1'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-build-tests
+}