summaryrefslogtreecommitdiff
path: root/dev-go
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2015-05-21 06:58:41 +0000
committerZac Medico <zmedico@gentoo.org>2015-05-21 06:58:41 +0000
commit05d3b00965c4888c299824e1139c0755a5732b62 (patch)
treee25e1d787ac1faaf7a2968704fd7d3d6f1c19c65 /dev-go
parentAdd ~amd64 keyword. (diff)
downloadgentoo-2-05d3b00965c4888c299824e1139c0755a5732b62.tar.gz
gentoo-2-05d3b00965c4888c299824e1139c0755a5732b62.tar.bz2
gentoo-2-05d3b00965c4888c299824e1139c0755a5732b62.zip
Add 1.4.2_p20150520 snapshot.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key FDE8EF85AE5719A3)
Diffstat (limited to 'dev-go')
-rw-r--r--dev-go/go-net/ChangeLog7
-rw-r--r--dev-go/go-net/go-net-1.4.2_p20150520.ebuild93
2 files changed, 99 insertions, 1 deletions
diff --git a/dev-go/go-net/ChangeLog b/dev-go/go-net/ChangeLog
index f878d21928ef..b593f32cdfa6 100644
--- a/dev-go/go-net/ChangeLog
+++ b/dev-go/go-net/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-go/go-net
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/go-net/ChangeLog,v 1.2 2015/05/21 06:16:46 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-net/ChangeLog,v 1.3 2015/05/21 06:58:41 zmedico Exp $
+
+*go-net-1.4.2_p20150520 (21 May 2015)
+
+ 21 May 2015; Zac Medico <zmedico@gentoo.org> +go-net-1.4.2_p20150520.ebuild:
+ Add 1.4.2_p20150520 snapshot.
21 May 2015; Zac Medico <zmedico@gentoo.org> go-net-9999.ebuild:
Add src_test.
diff --git a/dev-go/go-net/go-net-1.4.2_p20150520.ebuild b/dev-go/go-net/go-net-1.4.2_p20150520.ebuild
new file mode 100644
index 000000000000..b9cdd4175b28
--- /dev/null
+++ b/dev-go/go-net/go-net-1.4.2_p20150520.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-net/go-net-1.4.2_p20150520.ebuild,v 1.1 2015/05/21 06:58:41 zmedico Exp $
+
+EAPI=5
+inherit git-r3
+
+KEYWORDS="~amd64"
+DESCRIPTION="Go supplementary network libraries"
+MY_PN=${PN##*-}
+GO_PN=golang.org/x/${MY_PN}
+HOMEPAGE="https://godoc.org/${GO_PN}"
+EGIT_COMMIT="7212a0803472eb1ec2686896a7c626528172a7a6"
+SRC_URI="https://github.com/golang/${MY_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+DEPEND=">=dev-lang/go-1.4
+ dev-go/go-text"
+RDEPEND=""
+S="${WORKDIR}/src/${GO_PN}"
+EGIT_CHECKOUT_DIR="${S}"
+STRIP_MASK="*.a"
+
+src_unpack() {
+ default
+ mkdir -p src/${GO_PN%/*} || die
+ mv ${MY_PN}-${EGIT_COMMIT} src/${GO_PN} || die
+}
+
+src_compile() {
+ # Create a writable GOROOT in order to avoid sandbox violations.
+ GOROOT="${WORKDIR}/goroot"
+ cp -sR "${EPREFIX}"/usr/lib/go "${GOROOT}" || die
+ rm -rf "${GOROOT}/src/${GO_PN}" \
+ "${GOROOT}/pkg/linux_${ARCH}/${GO_PN}" || die
+ GOROOT="${GOROOT}" GOPATH=${WORKDIR} go install -v -x -work ${GO_PN}/... || die
+}
+
+src_test() {
+ GOROOT="${GOROOT}" GOPATH=${WORKDIR} \
+ go test -run "^(Example(WithTimeout|Parse)|"$(
+ echo -n '|Test(Background|TODO|WithCancel|ParentFinishesChild|'
+ echo -n 'ChildFinishesFirst|Deadline|Timeout|CanceledTimeout|'
+ echo -n 'Values|Allocs|SimultaneousCancels|InterlockedCancels|'
+ echo -n 'LayersCancel|LayersTimeout|CancelRemoves|EntityLength|'
+ echo -n 'Unescape|UnescapeEscape|Parser|NodeConsistency|Renderer|'
+ echo -n 'Tokenizer|MaxBuffer|MaxBufferReconstruction|Passthrough|'
+ echo -n 'BufAPI|ConvertNewlines|ReaderEdgeCases|Known|Hits|Misses|'
+ echo -n 'ForeignObject|Decode|Encode|Names|Sniff|Reader|FromMeta|'
+ echo -n 'XML|MarshalAndParseExtension|ParseIPv4Header|'
+ echo -n 'MarshalAndParseMessageForIPv4|MarshalAndParseMessageForIPv6|'
+ echo -n 'MarshalAndParseMultipartMessageForIPv4|'
+ echo -n 'MarshalAndParseMultipartMessageForIPv6|IDNA|Punycode|'
+ echo -n 'PunycodeErrors|MarshalHeader|ParseHeader|ICMPString|'
+ echo -n 'ICMPFilter|UDPSinglePacketConnWithMultipleGroupListeners|'
+ echo -n 'UDPMultiplePacketConnWithMultipleGroupListeners|'
+ echo -n 'UDPPerInterfaceSinglePacketConnWithSingleGroupListener|'
+ echo -n 'PacketConnConcurrentReadWriteUnicastUDP|'
+ echo -n 'PacketConnReadWriteUnicastUDP|ConnUnicastSocketOptions|'
+ echo -n 'PacketConnUnicastSocketOptions|ParseHeader|ICMPString|'
+ echo -n 'ICMPFilter|UDPSinglePacketConnWithMultipleGroupListeners|'
+ echo -n 'UDPMultiplePacketConnWithMultipleGroupListeners|'
+ echo -n 'UDPPerInterfaceSinglePacketConnWithSingleGroupListener|'
+ echo -n 'PacketConnConcurrentReadWriteUnicastUDP|ConnInitiatorPathMTU|'
+ echo -n 'ConnResponderPathMTU|PacketConnReadWriteUnicastUDP|'
+ echo -n 'ConnUnicastSocketOptions|PacketConnUnicastSocketOptions|'
+ echo -n 'LimitListener|LimitListenerError|PerHost|FromURL|SOCKS5|'
+ echo -n 'NodeLabel|Find|ICANN|PublicSuffix|SlowPublicSuffix|'
+ echo -n 'EffectiveTLDPlusOne|SlashClean|DirResolve|Walk|Dir|MemFS|'
+ echo -n 'MemFSRoot|MemFileReaddir|MemFile|MemFileWriteAllocs|WalkFS|'
+ echo -n 'ParseIfHeader|WalkToRoot|MemLSCanCreate|MemLSLookup|'
+ echo -n 'MemLSConfirm|MemLSNonCanonicalRoot|MemLSExpiry|MemLS|'
+ echo -n 'ParseTimeout|MemPS|ReadLockInfo|ReadPropfind|'
+ echo -n 'SecWebSocketAccept|HybiClientHandshake|'
+ echo -n 'HybiClientHandshakeWithHeader|HybiServerHandshake|'
+ echo -n 'HybiServerHandshakeNoSubProtocol|'
+ echo -n 'HybiServerHandshakeHybiBadVersion|HybiShortTextFrame|'
+ echo -n 'HybiShortMaskedTextFrame|HybiShortBinaryFrame|'
+ echo -n 'HybiControlFrame|HybiLongFrame|HybiClientRead|'
+ echo -n 'HybiShortRead|HybiServerRead|HybiServerReadWithoutMasking|'
+ echo -n 'HybiClientReadWithMasking|HybiServerFirefoxHandshake|Echo|'
+ echo -n 'Addr|Count|WithQuery|WithProtocol|WithTwoProtocol|'
+ echo -n 'WithBadProtocol|HTTP|TrailingSpaces|DialConfigBadVersion|'
+ echo -n 'SmallBuffer|ParseAuthority|Close))$') \
+ -x -v ${GO_PN}/... || die $?
+}
+
+src_install() {
+ insinto /usr/lib/go
+ find "${WORKDIR}"/{pkg,src} -name '.git*' -exec rm -rf {} \; 2>/dev/null
+ doins -r "${WORKDIR}"/{pkg,src}
+}