summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-07-17 12:33:39 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-07-17 12:33:39 +0000
commitf20c26d05fbf39982f52b600f9db8f267a1fd27e (patch)
treecbcdb890c7fe7f92e729eda1133fe87510e76d3a /dev-games
parentAnother hardcoded path in the Linux source tree (depmod) wrt #426698 by Kyle ... (diff)
downloadgentoo-2-f20c26d05fbf39982f52b600f9db8f267a1fd27e.tar.gz
gentoo-2-f20c26d05fbf39982f52b600f9db8f267a1fd27e.tar.bz2
gentoo-2-f20c26d05fbf39982f52b600f9db8f267a1fd27e.zip
Fix build with gcc-4.7 Bug #426870
(Portage version: 2.1.11.7/cvs/Linux i686)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/crystalspace/ChangeLog6
-rw-r--r--dev-games/crystalspace/crystalspace-1.4.0.ebuild5
-rw-r--r--dev-games/crystalspace/files/crystalspace-1.4.0-gcc47.patch42
3 files changed, 50 insertions, 3 deletions
diff --git a/dev-games/crystalspace/ChangeLog b/dev-games/crystalspace/ChangeLog
index 965be74c833d..abd3d2156288 100644
--- a/dev-games/crystalspace/ChangeLog
+++ b/dev-games/crystalspace/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-games/crystalspace
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/ChangeLog,v 1.55 2012/05/03 06:35:32 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/ChangeLog,v 1.56 2012/07/17 12:33:39 tupone Exp $
+
+ 17 Jul 2012; Tupone Alfredo <tupone@gentoo.org> crystalspace-1.4.0.ebuild,
+ +files/crystalspace-1.4.0-gcc47.patch:
+ Fix build with gcc-4.7 Bug #426870 by flameeyes@gentoo.org
03 May 2012; Jeff Horelick <jdhore@gentoo.org> crystalspace-1.4.0.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/dev-games/crystalspace/crystalspace-1.4.0.ebuild b/dev-games/crystalspace/crystalspace-1.4.0.ebuild
index 9fea9d7e6813..c838c9521bcb 100644
--- a/dev-games/crystalspace/crystalspace-1.4.0.ebuild
+++ b/dev-games/crystalspace/crystalspace-1.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-1.4.0.ebuild,v 1.10 2012/05/03 06:35:32 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-1.4.0.ebuild,v 1.11 2012/07/17 12:33:39 tupone Exp $
EAPI=2
inherit eutils flag-o-matic multilib java-pkg-opt-2 autotools wxwidgets versionator
@@ -60,7 +60,8 @@ src_prepare() {
docs/Jamfile \
|| die "sed failed"
epatch "${FILESDIR}"/${P}-bullet.patch \
- "${FILESDIR}"/${P}-png15.patch
+ "${FILESDIR}"/${P}-png15.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
AT_M4DIR=mk/autoconf
eautoreconf
}
diff --git a/dev-games/crystalspace/files/crystalspace-1.4.0-gcc47.patch b/dev-games/crystalspace/files/crystalspace-1.4.0-gcc47.patch
new file mode 100644
index 000000000000..74ac5df38296
--- /dev/null
+++ b/dev-games/crystalspace/files/crystalspace-1.4.0-gcc47.patch
@@ -0,0 +1,42 @@
+--- include/csutil/blockallocator.h.old 2012-07-17 09:08:57.203478402 +0200
++++ include/csutil/blockallocator.h 2012-07-17 09:10:34.556642885 +0200
+@@ -166,7 +166,7 @@
+ ~csBlockAllocator()
+ {
+ ObjectDispose dispose (*this, false);
+- DisposeAll (dispose);
++ this->DisposeAll (dispose);
+ }
+
+ /**
+@@ -177,7 +177,7 @@
+ void Empty()
+ {
+ ObjectDispose dispose (*this, true);
+- DisposeAll (dispose);
++ this->DisposeAll (dispose);
+ }
+
+ /**
+--- include/csutil/parray.h.old 2012-07-17 13:02:11.524886456 +0200
++++ include/csutil/parray.h 2012-07-17 13:02:43.531639147 +0200
+@@ -106,7 +106,7 @@
+ {
+ CS_ASSERT (this->GetSize () > 0);
+ T* ret = GetAndClear (this->GetSize () - 1); // see *1*
+- Truncate (this->GetSize () - 1);
++ this->Truncate (this->GetSize () - 1);
+ return ret;
+ }
+
+--- include/csutil/refarr.h.old 2012-07-17 09:16:33.084469347 +0200
++++ include/csutil/refarr.h 2012-07-17 09:17:04.008298074 +0200
+@@ -106,7 +106,7 @@
+ {
+ CS_ASSERT (this->GetSize () > 0);
+ csRef<T> ret = this->Get (this->GetSize () - 1); // see *1*
+- SetSize (this->GetSize () - 1);
++ this->SetSize (this->GetSize () - 1);
+ return csPtr<T> (ret);
+ }
+ };