summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-01-24 00:16:26 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-01-24 00:16:26 +0000
commitec5b4db5238e1d1753e20ad25331fb8e55bb7da6 (patch)
tree53fa07af30468379b5be4f09735f25955f282e3b /dev-games
parentold (diff)
downloadgentoo-2-ec5b4db5238e1d1753e20ad25331fb8e55bb7da6.tar.gz
gentoo-2-ec5b4db5238e1d1753e20ad25331fb8e55bb7da6.tar.bz2
gentoo-2-ec5b4db5238e1d1753e20ad25331fb8e55bb7da6.zip
version bump wrt #453138
(Portage version: 2.2.0_alpha159/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/crystalspace/ChangeLog10
-rw-r--r--dev-games/crystalspace/crystalspace-2.0.ebuild133
-rw-r--r--dev-games/crystalspace/files/crystalspace-2.0-gcc47.patch42
3 files changed, 183 insertions, 2 deletions
diff --git a/dev-games/crystalspace/ChangeLog b/dev-games/crystalspace/ChangeLog
index abd3d2156288..aacb6e2755d7 100644
--- a/dev-games/crystalspace/ChangeLog
+++ b/dev-games/crystalspace/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-games/crystalspace
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/ChangeLog,v 1.56 2012/07/17 12:33:39 tupone Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/ChangeLog,v 1.57 2013/01/24 00:16:26 hasufell Exp $
+
+*crystalspace-2.0 (24 Jan 2013)
+
+ 24 Jan 2013; Julian Ospald <hasufell@gentoo.org> +crystalspace-2.0.ebuild,
+ +files/crystalspace-2.0-gcc47.patch:
+ version bump wrt #453138
17 Jul 2012; Tupone Alfredo <tupone@gentoo.org> crystalspace-1.4.0.ebuild,
+files/crystalspace-1.4.0-gcc47.patch:
diff --git a/dev-games/crystalspace/crystalspace-2.0.ebuild b/dev-games/crystalspace/crystalspace-2.0.ebuild
new file mode 100644
index 000000000000..373dcac04dd8
--- /dev/null
+++ b/dev-games/crystalspace/crystalspace-2.0.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-2.0.ebuild,v 1.1 2013/01/24 00:16:26 hasufell Exp $
+
+EAPI=5
+inherit eutils flag-o-matic multilib java-pkg-opt-2 autotools wxwidgets versionator
+
+MY_P=${PN}-src-${PV}
+PATH_P=${PN}-$(get_version_component_range 1-2)
+
+DESCRIPTION="Portable 3D Game Development Kit written in C++"
+HOMEPAGE="http://crystal.sourceforge.net/"
+SRC_URI="mirror://sourceforge/crystal/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="3ds alsa bullet cal3d cegui cg doc java jpeg mng ode png speex truetype vorbis wxwidgets"
+
+COMMON_DEP="virtual/opengl
+ media-libs/openal
+ x11-libs/libXt
+ x11-libs/libXxf86vm
+ sys-libs/zlib
+ cg? ( media-gfx/nvidia-cg-toolkit )
+ ode? ( <dev-games/ode-0.12 )
+ cal3d? ( >=media-libs/cal3d-0.11 )
+ jpeg? ( virtual/jpeg )
+ bullet? ( sci-physics/bullet )
+ vorbis? ( media-libs/libvorbis )
+ speex? ( media-libs/libogg
+ media-libs/speex )
+ truetype? ( >=media-libs/freetype-2.1 )
+ alsa? ( media-libs/alsa-lib )
+ mng? ( media-libs/libmng )
+ png? ( media-libs/libpng:0 )
+ wxwidgets? ( x11-libs/wxGTK:2.8[X,opengl] )
+ cegui? ( >=dev-games/cegui-0.5.0 )
+ 3ds? ( media-libs/lib3ds )"
+
+RDEPEND="${COMMON_DEP}
+ java? ( >=virtual/jre-1.5 )"
+
+DEPEND="${COMMON_DEP}
+ java? ( >=virtual/jdk-1.5
+ dev-java/ant-core )
+ dev-util/ftjam
+ dev-lang/swig
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # Installing doc conflict with dodoc on src_install
+ # Removing conflicting target
+ sed -i \
+ -e "/^InstallDoc/d" \
+ Jamfile.in \
+ docs/Jamfile \
+ || die "sed failed"
+ epatch "${FILESDIR}"/${P}-gcc47.patch
+ AT_M4DIR=mk/autoconf
+ eautoreconf
+}
+
+src_configure() {
+ if use wxwidgets; then
+ WX_GTK_VER="2.8"
+ need-wxwidgets gtk2
+ fi
+
+ econf \
+ --disable-as-needed \
+ --enable-cpu-specific-optimizations=no \
+ --disable-separate-debug-info \
+ --without-lcms \
+ --without-jackasyn \
+ --without-perl \
+ $(use_with java) \
+ --disable-make-emulation \
+ $(use_with bullet) \
+ --without-python \
+ $(use_with png) \
+ $(use_with jpeg) \
+ $(use_with mng) \
+ $(use_with vorbis) \
+ $(use_with speex) \
+ $(use_with 3ds) \
+ $(use_with ode) \
+ $(use_with truetype freetype2) \
+ $(use_with cal3d) \
+ $(use_with wxwidgets wx) \
+ $(use_with cegui CEGUI) \
+ $(use_with cg Cg) \
+ $(use_with alsa asound)
+ #remove unwanted CFLAGS added by ./configure
+ sed -i -e '/COMPILER\.CFLAGS\.optimize/d' \
+ Jamconfig \
+ || die "sed failed"
+}
+
+src_compile() {
+ local jamopts=$(echo "${MAKEOPTS}" | sed -ne "/-j/ { s/.*\(-j[[:space:]]*[0-9]\+\).*/\1/; p }")
+ jam -q -dx ${jamopts} || die "compile failed"
+}
+
+src_install() {
+ for installTarget in bin plugin lib include data config bindings
+ do
+ jam -q -s DESTDIR="${D}" install_${installTarget} \
+ || die "jam install_${installTarget} failed"
+ done
+ if use doc; then
+ jam -q -s DESTDIR="${D}" install_doc || die "jam install_doc failed"
+ fi
+ dodoc README docs/history*
+
+ echo "CRYSTAL_PLUGIN=/usr/$(get_libdir)/${PATH_P}" > 90crystalspace
+ echo "CRYSTAL_CONFIG=/etc/${PATH_P}" >> 90crystalspace
+ doenvd 90crystalspace
+}
+
+pkg_postinst() {
+ elog "Examples coming with this package, need correct light calculation"
+ elog "Do the following commands, with the root account, to fix that:"
+ # Fill cache directory for the examples
+ local dir
+ for dir in castle flarge isomap parallaxtest partsys r3dtest stenciltest \
+ terrain terrainf;
+ do
+ elog "cslight -video=null /usr/share/${PATH_P}/data/maps/${dir}"
+ done
+}
diff --git a/dev-games/crystalspace/files/crystalspace-2.0-gcc47.patch b/dev-games/crystalspace/files/crystalspace-2.0-gcc47.patch
new file mode 100644
index 000000000000..c5144b94eb3b
--- /dev/null
+++ b/dev-games/crystalspace/files/crystalspace-2.0-gcc47.patch
@@ -0,0 +1,42 @@
+--- include/csutil/blockallocator.h
++++ include/csutil/blockallocator.h
+@@ -193,7 +193,7 @@
+ ~csBlockAllocator()
+ {
+ ObjectDispose dispose (*this, false);
+- DisposeAll (dispose);
++ this->DisposeAll (dispose);
+ }
+
+ /**
+@@ -215,7 +215,7 @@
+ void DeleteAll ()
+ {
+ ObjectDispose dispose (*this, true);
+- DisposeAll (dispose);
++ this->DisposeAll (dispose);
+ }
+
+ /**
+--- include/csutil/parray.h
++++ include/csutil/parray.h
+@@ -112,7 +112,7 @@
+ {
+ CS_ASSERT (this->GetSize () > 0);
+ T* ret = GetAndClear (this->GetSize () - 1); // see *1*
+- Truncate (this->GetSize () - 1);
++ this->Truncate (this->GetSize () - 1);
+ return ret;
+ }
+
+--- include/csutil/refarr.h
++++ include/csutil/refarr.h
+@@ -111,7 +111,7 @@
+ {
+ CS_ASSERT (this->GetSize () > 0);
+ csRef<T> ret = this->Get (this->GetSize () - 1); // see *1*
+- SetSize (this->GetSize () - 1);
++ this->SetSize (this->GetSize () - 1);
+ return ret;
+ }
+ };