summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-01-05 01:08:19 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-01-05 01:08:19 +0000
commit4639c9271ab7a90066f9004a8b0423dc1d42d5ad (patch)
tree23b216c39204d4559c4d4e8950ec2cee6cc33078 /dev-games
parentPulling broken version (diff)
downloadgentoo-2-4639c9271ab7a90066f9004a8b0423dc1d42d5ad.tar.gz
gentoo-2-4639c9271ab7a90066f9004a8b0423dc1d42d5ad.tar.bz2
gentoo-2-4639c9271ab7a90066f9004a8b0423dc1d42d5ad.zip
Add glut USE flag
(Portage version: 2.1.2_rc4-r5)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/guichan/ChangeLog7
-rw-r--r--dev-games/guichan/guichan-0.5.0.ebuild24
2 files changed, 19 insertions, 12 deletions
diff --git a/dev-games/guichan/ChangeLog b/dev-games/guichan/ChangeLog
index a76c7c19bd78..a17ca9dd7e19 100644
--- a/dev-games/guichan/ChangeLog
+++ b/dev-games/guichan/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-games/guichan
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/ChangeLog,v 1.7 2006/08/20 05:11:05 mr_bones_ Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/ChangeLog,v 1.8 2007/01/05 01:08:19 nyhm Exp $
+
+ 05 Jan 2007; Tristan Heaven <nyhm@gentoo.org> guichan-0.5.0.ebuild:
+ Add glut USE flag
*guichan-0.5.0 (20 Aug 2006)
diff --git a/dev-games/guichan/guichan-0.5.0.ebuild b/dev-games/guichan/guichan-0.5.0.ebuild
index 8093fd57973b..19ed75c242bc 100644
--- a/dev-games/guichan/guichan-0.5.0.ebuild
+++ b/dev-games/guichan/guichan-0.5.0.ebuild
@@ -1,8 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/guichan-0.5.0.ebuild,v 1.2 2006/09/19 16:46:26 mr_bones_ Exp $
-
-inherit eutils autotools
+# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/guichan-0.5.0.ebuild,v 1.3 2007/01/05 01:08:19 nyhm Exp $
DESCRIPTION="a portable C++ GUI library designed for games using Allegro, SDL and/or OpenGL"
HOMEPAGE="http://guichan.sourceforge.net/"
@@ -11,25 +9,31 @@ SRC_URI="mirror://sourceforge/guichan/${P}-src.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="sdl opengl allegro"
+IUSE="allegro glut opengl sdl"
-DEPEND="opengl? ( virtual/opengl )
- sdl? ( media-libs/libsdl media-libs/sdl-image )
- allegro? ( media-libs/allegro )"
+DEPEND="allegro? ( media-libs/allegro )
+ glut? ( virtual/glut )
+ opengl? ( virtual/opengl )
+ sdl? (
+ media-libs/libsdl
+ media-libs/sdl-image
+ )"
S=${WORKDIR}/${P}-src
src_compile() {
econf \
+ --disable-dependency-tracking \
$(use_enable allegro) \
+ $(use_enable glut) \
+ $(use_enable opengl) \
$(use_enable sdl) \
$(use_enable sdl sdlimage) \
- $(use_enable opengl) \
|| die
emake || die "emake failed"
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog NEWS README TODO
}