summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-05-14 01:46:59 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-05-14 01:46:59 +0000
commit5c557398e26061f016e6322f50bbabff859c7be3 (patch)
treeb51cb673e67f66bd6930d0d388635fc5e9897ad2 /dev-games/crystalspace
parentMask =www-client/opera-9.21 until it goes into beta. (diff)
downloadgentoo-2-5c557398e26061f016e6322f50bbabff859c7be3.tar.gz
gentoo-2-5c557398e26061f016e6322f50bbabff859c7be3.tar.bz2
gentoo-2-5c557398e26061f016e6322f50bbabff859c7be3.zip
Lock to wxGTK-2.6 and use wxwidgets.eclass.
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-games/crystalspace')
-rw-r--r--dev-games/crystalspace/ChangeLog10
-rw-r--r--dev-games/crystalspace/crystalspace-1.0.1.ebuild14
-rw-r--r--dev-games/crystalspace/crystalspace-1.0.ebuild14
3 files changed, 31 insertions, 7 deletions
diff --git a/dev-games/crystalspace/ChangeLog b/dev-games/crystalspace/ChangeLog
index 48ca89cf1182..51e18604b425 100644
--- a/dev-games/crystalspace/ChangeLog
+++ b/dev-games/crystalspace/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-games/crystalspace
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/ChangeLog,v 1.28 2007/03/26 14:57:08 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/ChangeLog,v 1.29 2007/05/14 01:46:59 dirtyepic Exp $
+
+ 14 May 2007; Ryan Hill <dirtyepic@gentoo.org> crystalspace-1.0.ebuild,
+ crystalspace-1.0.1.ebuild:
+ Lock to wxGTK-2.6 and use wxwidgets.eclass.
+
+ 14 May 2007; Ryan Hill <dirtyepic@gentoo.org> crystalspace-1.0.ebuild,
+ crystalspace-1.0.1.ebuild:
+ Lock to wxGTK-2.6 and use wxwidgets.eclass.
26 Mar 2007; Chris Gianelloni <wolf31o2@gentoo.org>
crystalspace-0.98.4.ebuild:
diff --git a/dev-games/crystalspace/crystalspace-1.0.1.ebuild b/dev-games/crystalspace/crystalspace-1.0.1.ebuild
index f016d0c6a4eb..031a17a15334 100644
--- a/dev-games/crystalspace/crystalspace-1.0.1.ebuild
+++ b/dev-games/crystalspace/crystalspace-1.0.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-1.0.1.ebuild,v 1.2 2007/03/04 07:50:54 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-1.0.1.ebuild,v 1.3 2007/05/14 01:46:59 dirtyepic Exp $
-inherit flag-o-matic java-pkg-opt-2 multilib
+inherit flag-o-matic java-pkg-opt-2 multilib wxwidgets
MY_P=${PN}-src-${PV}
DESCRIPTION="Portable 3D Game Development Kit written in C++"
@@ -30,7 +30,7 @@ RDEPEND="virtual/opengl
mng? ( media-libs/libmng )
png? ( media-libs/libpng )
wxwindows? ( x11-libs/pango
- >=x11-libs/wxGTK-2.6 )
+ =x11-libs/wxGTK-2.6* )
javascript? ( dev-lang/spidermonkey )
cegui? ( >=dev-games/cegui-0.5.0 )
x11-libs/libXaw
@@ -57,6 +57,14 @@ src_unpack() {
}
src_compile() {
+ if useq wxwindows; then
+ WX_GTK_VER=2.6
+ need-wxwidgets gtk2
+ if [[ ! -e /usr/bin/wx-config ]]; then
+ sed -i -e "s:wx-config:${WX_CONFIG_NAME}:g" configure
+ fi
+ fi
+
# -O3 is hanging compilation of python script plugin
# trying -O2 just in case
replace-flags -O3 -O2
diff --git a/dev-games/crystalspace/crystalspace-1.0.ebuild b/dev-games/crystalspace/crystalspace-1.0.ebuild
index 89b0fea5d44c..7e6b6748b0b3 100644
--- a/dev-games/crystalspace/crystalspace-1.0.ebuild
+++ b/dev-games/crystalspace/crystalspace-1.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-1.0.ebuild,v 1.8 2007/03/04 07:50:54 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-1.0.ebuild,v 1.9 2007/05/14 01:46:59 dirtyepic Exp $
-inherit java-pkg-opt-2 multilib
+inherit java-pkg-opt-2 multilib wxwidgets
MY_P=${PN}-src-${PV}
DESCRIPTION="Portable 3D Game Development Kit written in C++"
@@ -30,7 +30,7 @@ RDEPEND="virtual/opengl
mng? ( media-libs/libmng )
png? ( media-libs/libpng )
wxwindows? ( x11-libs/pango
- >=x11-libs/wxGTK-2.6 )
+ =x11-libs/wxGTK-2.6* )
javascript? ( dev-lang/spidermonkey )
cegui? ( >=dev-games/cegui-0.5.0 )
x11-libs/libXaw
@@ -57,6 +57,14 @@ src_unpack() {
}
src_compile() {
+ if useq wxwindows; then
+ WX_GTK_VER=2.6
+ need-wxwidgets gtk2
+ if [[ ! -e /usr/bin/wx-config ]]; then
+ sed -i -e "s:wx-config:${WX_CONFIG_NAME}:g" configure
+ fi
+ fi
+
econf --enable-cpu-specific-optimizations=no \
--disable-separate-debug-info \
--without-lcms \