summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-09-12 22:33:43 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-09-12 22:33:43 +0000
commit1f6291b695c71a7c9e12fa1efce4f3e62e05f84d (patch)
tree05f7d3f6aa1622f0f435e3f4ffad92e2eed5a8ea /dev-games/clanlib
parentSlotmove diablo jdk and jre to 0 to 1.5. (diff)
downloadgentoo-2-1f6291b695c71a7c9e12fa1efce4f3e62e05f84d.tar.gz
gentoo-2-1f6291b695c71a7c9e12fa1efce4f3e62e05f84d.tar.bz2
gentoo-2-1f6291b695c71a7c9e12fa1efce4f3e62e05f84d.zip
Fix building with amd64. Bug #146114
(Portage version: 2.1.1)
Diffstat (limited to 'dev-games/clanlib')
-rw-r--r--dev-games/clanlib/ChangeLog7
-rw-r--r--dev-games/clanlib/clanlib-0.6.5-r3.ebuild5
-rw-r--r--dev-games/clanlib/files/clanlib-0.6.5-64bit.patch37
3 files changed, 46 insertions, 3 deletions
diff --git a/dev-games/clanlib/ChangeLog b/dev-games/clanlib/ChangeLog
index 1e70996129de..7872dc921fe7 100644
--- a/dev-games/clanlib/ChangeLog
+++ b/dev-games/clanlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-games/clanlib
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/ChangeLog,v 1.34 2006/09/11 22:38:17 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/ChangeLog,v 1.35 2006/09/12 22:33:43 tupone Exp $
+
+ 12 Sep 2006; <tupone@gentoo.org> +files/clanlib-0.6.5-64bit.patch,
+ clanlib-0.6.5-r3.ebuild:
+ Fix building with amd64. Bug #146114 by Frank Weinberg
+ using patch given in Bug #146849 by Pacho Ramos
11 Sep 2006; <tupone@gentoo.org> clanlib-0.6.5-r3.ebuild:
Removed lua flag. Bug #136587 by Kai.
diff --git a/dev-games/clanlib/clanlib-0.6.5-r3.ebuild b/dev-games/clanlib/clanlib-0.6.5-r3.ebuild
index ce07addf7e9f..4603e800465f 100644
--- a/dev-games/clanlib/clanlib-0.6.5-r3.ebuild
+++ b/dev-games/clanlib/clanlib-0.6.5-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/clanlib-0.6.5-r3.ebuild,v 1.10 2006/09/11 22:38:17 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/clanlib-0.6.5-r3.ebuild,v 1.11 2006/09/12 22:33:43 tupone Exp $
inherit eutils flag-o-matic
@@ -10,7 +10,7 @@ SRC_URI="http://www.clanlib.org/download/legacy/ClanLib-${PV}-1.tar.gz"
LICENSE="LGPL-2"
SLOT="0.6"
-KEYWORDS="-amd64 x86" #not big endian safe #82779
+KEYWORDS="amd64 x86" #not big endian safe #82779
IUSE="arts oss esd alsa png opengl truetype X vorbis mikmod jpeg directfb joystick"
DEPEND=">=media-libs/hermes-1.3.2
@@ -47,6 +47,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-freetype.patch
epatch "${FILESDIR}"/${P}-gcc41.patch
epatch "${FILESDIR}"/${P}-uclibc.patch
+ epatch "${FILESDIR}"/${P}-64bit.patch
sed -i 's:@comp_mode@::' Setup/Unix/clanlib-config.in
}
diff --git a/dev-games/clanlib/files/clanlib-0.6.5-64bit.patch b/dev-games/clanlib/files/clanlib-0.6.5-64bit.patch
new file mode 100644
index 000000000000..5cacb50c4fc8
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-0.6.5-64bit.patch
@@ -0,0 +1,37 @@
+--- Sources/SmallJPEG/jpgd/jpegdecoder.cpp.old 2006-09-13 00:08:55.000000000 +0200
++++ Sources/SmallJPEG/jpgd/jpegdecoder.cpp 2006-09-13 00:10:41.000000000 +0200
+@@ -19,6 +19,7 @@
+ // License along with this library; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ //------------------------------------------------------------------------------
++#include <stdint.h>
+ #include "jpegdecoder.h"
+ //------------------------------------------------------------------------------
+ // Coefficients are stored in this sequence in the data stream.
+@@ -102,7 +103,7 @@
+ blocks[i] = q;
+
+ // Round to qword boundry, to avoid misaligned accesses with MMX code
+- return ((void *)(((uint)q + 7) & ~7));
++ return ((void *)(((uintptr_t)q + 7) & ~7));
+ }
+ //------------------------------------------------------------------------------
+ // Clear buffer to word values.
+@@ -1870,7 +1871,7 @@
+ q = (uchar *)alloc(max_blocks_per_row * 64 * sizeof(BLOCK_TYPE) + 8);
+
+ // Align to 8-byte boundry, for MMX code
+- q = (uchar *)(((uint)q + 7) & ~7);
++ q = (uchar *)(((uintptr_t)q + 7) & ~7);
+
+ // The block_seg[] array's name dates back to the
+ // 16-bit assembler implementation. "seg" stood for "segment".
+@@ -1880,7 +1881,7 @@
+ for (i = 0; i < max_blocks_per_row; i++)
+ block_max_zag_set[i] = 64;
+
+- Psample_buf = (uchar *)(((uint)alloc(max_blocks_per_row * 64 + 8) + 7) & ~7);
++ Psample_buf = (uchar *)(((uintptr_t)alloc(max_blocks_per_row * 64 + 8) + 7) & ~7);
+
+ total_lines_left = image_y_size;
+