summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Kapusta <ayoy@gentoo.org>2010-09-08 17:32:00 +0000
committerDominik Kapusta <ayoy@gentoo.org>2010-09-08 17:32:00 +0000
commit9c1124bc5a46d9bd0f4eebe26d13fb8a8ad1a9c2 (patch)
tree57e3f17dfa7d1442caa9f8752073bf63063a02f4 /dev-embedded/scratchbox-toolchain-cs2009q3-eglibc2_10/scratchbox-toolchain-cs2009q3-eglibc2_10-1.0.17-r1.ebuild
parentMarked ~amd64-linux, bug #336273 (diff)
downloadgentoo-2-9c1124bc5a46d9bd0f4eebe26d13fb8a8ad1a9c2.tar.gz
gentoo-2-9c1124bc5a46d9bd0f4eebe26d13fb8a8ad1a9c2.tar.bz2
gentoo-2-9c1124bc5a46d9bd0f4eebe26d13fb8a8ad1a9c2.zip
Adding arm-soft toolchain
(Portage version: 2.2_rc77/cvs/Linux x86_64)
Diffstat (limited to 'dev-embedded/scratchbox-toolchain-cs2009q3-eglibc2_10/scratchbox-toolchain-cs2009q3-eglibc2_10-1.0.17-r1.ebuild')
-rw-r--r--dev-embedded/scratchbox-toolchain-cs2009q3-eglibc2_10/scratchbox-toolchain-cs2009q3-eglibc2_10-1.0.17-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-embedded/scratchbox-toolchain-cs2009q3-eglibc2_10/scratchbox-toolchain-cs2009q3-eglibc2_10-1.0.17-r1.ebuild b/dev-embedded/scratchbox-toolchain-cs2009q3-eglibc2_10/scratchbox-toolchain-cs2009q3-eglibc2_10-1.0.17-r1.ebuild
new file mode 100644
index 000000000000..f7b20432e241
--- /dev/null
+++ b/dev-embedded/scratchbox-toolchain-cs2009q3-eglibc2_10/scratchbox-toolchain-cs2009q3-eglibc2_10-1.0.17-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/scratchbox-toolchain-cs2009q3-eglibc2_10/scratchbox-toolchain-cs2009q3-eglibc2_10-1.0.17-r1.ebuild,v 1.1 2010/09/08 17:32:00 ayoy Exp $
+
+ARMHARDV="hard-${PV}-3"
+ARMSOFTV="soft-${PV}-4"
+I486V="${PV}-3"
+
+DESCRIPTION="A cross-compilation toolkit designed to make embedded Linux application development easier."
+HOMEPAGE="http://www.scratchbox.org/"
+SRC_URI="http://scratchbox.org/download/files/sbox-releases/hathor/tarball/${PN/_/.}-armv7-${ARMHARDV}-i386.tar.gz
+ http://scratchbox.org/download/files/sbox-releases/hathor/tarball/${PN/_/.}-armv7-${ARMSOFTV}-i386.tar.gz
+ http://scratchbox.org/download/files/sbox-releases/hathor/tarball/${PN/_/.}-i486-${I486V}-i386.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Stripping BREAKS scratchbox, it runs in a chroot and is pre-stripped when needed (bug #296294)
+RESTRICT="strip"
+
+DEPEND=""
+RDEPEND="=dev-embedded/scratchbox-1.0*"
+
+TARGET_DIR="/opt/scratchbox"
+
+S=${WORKDIR}/scratchbox
+
+src_install() {
+ dodir ${TARGET_DIR}
+ cp -pRP * "${D}/${TARGET_DIR}"
+}