summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2008-05-30 22:45:28 +0000
committerJurek Bartuszek <jurek@gentoo.org>2008-05-30 22:45:28 +0000
commitacf977382e00d3ade5dbd30e8905388310b1ca3d (patch)
tree79dd533480572a5f2dfe55dbc084c0d3cd137830 /dev-dotnet
parentdev-dotnet/mono-fuse-0.4.2: Version bump (bug #213672) (diff)
downloadgentoo-2-acf977382e00d3ade5dbd30e8905388310b1ca3d.tar.gz
gentoo-2-acf977382e00d3ade5dbd30e8905388310b1ca3d.tar.bz2
gentoo-2-acf977382e00d3ade5dbd30e8905388310b1ca3d.zip
dev-dotnet/monouml: Added dev-util/pkgconfig dependency (bug #206118)
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/monouml/ChangeLog7
-rw-r--r--dev-dotnet/monouml/monouml-0.1.ebuild17
2 files changed, 14 insertions, 10 deletions
diff --git a/dev-dotnet/monouml/ChangeLog b/dev-dotnet/monouml/ChangeLog
index 596e37431b8c..5a8ecfe61766 100644
--- a/dev-dotnet/monouml/ChangeLog
+++ b/dev-dotnet/monouml/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-dotnet/monouml
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/monouml/ChangeLog,v 1.5 2007/08/11 14:48:14 beandog Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/monouml/ChangeLog,v 1.6 2008/05/30 22:45:28 jurek Exp $
+
+ 30 May 2008; Jurek Bartuszek <jurek@gentoo.org> monouml-0.1.ebuild:
+ Added dev-util/pkgconfig dependency (bug #206118)
11 Aug 2007; Steve Dibb <beandog@gentoo.org> monouml-0.1.ebuild:
amd64 stable, bug 186690
diff --git a/dev-dotnet/monouml/monouml-0.1.ebuild b/dev-dotnet/monouml/monouml-0.1.ebuild
index 226e921fdbd8..65d1324dbf0c 100644
--- a/dev-dotnet/monouml/monouml-0.1.ebuild
+++ b/dev-dotnet/monouml/monouml-0.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/monouml/monouml-0.1.ebuild,v 1.5 2007/08/11 14:48:14 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/monouml/monouml-0.1.ebuild,v 1.6 2008/05/30 22:45:28 jurek Exp $
inherit mono eutils
@@ -19,25 +19,26 @@ DEPEND=">=dev-lang/mono-1.1.4
>=dev-dotnet/gtk-sharp-1.9.2
>=dev-dotnet/gnome-sharp-1.9.2
>=dev-dotnet/glade-sharp-1.9.2
- app-arch/unzip"
+ app-arch/unzip
+ dev-util/pkgconfig"
KEYWORDS="amd64 x86"
SLOT="0"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
- cp ${WORKDIR}/${EC_P}/*.dll ${WORKDIR}/${P}/bin/ || die
+ cp "${WORKDIR}"/${EC_P}/*.dll "${WORKDIR}"/${P}/bin/ || die
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
# Workaround for messed up paths
dodir /usr/$(get_libdir)
- mv ${D}/usr/monouml ${D}/usr/$(get_libdir)/
- sed -i -e "s#/usr/${PN}#/usr/$(get_libdir)/${PN}#g" ${D}/usr/bin/monouml
+ mv "${D}"/usr/monouml "${D}"/usr/$(get_libdir)/
+ sed -i -e "s#/usr/${PN}#/usr/$(get_libdir)/${PN}#g" "${D}"/usr/bin/monouml
dodoc ChangeLog README AUTHORS
}