summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-06-17 11:06:23 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-06-17 11:06:23 +0000
commit8c514d8197dcba5dff76b894aeab8235bfa00e5b (patch)
treed576e7289d34e740bf999f26684c8461bf25b009 /dev-dotnet/xsp/xsp-2.4.2_pre2.ebuild
parentBump (diff)
downloadgentoo-2-8c514d8197dcba5dff76b894aeab8235bfa00e5b.tar.gz
gentoo-2-8c514d8197dcba5dff76b894aeab8235bfa00e5b.tar.bz2
gentoo-2-8c514d8197dcba5dff76b894aeab8235bfa00e5b.zip
Bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-dotnet/xsp/xsp-2.4.2_pre2.ebuild')
-rw-r--r--dev-dotnet/xsp/xsp-2.4.2_pre2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-dotnet/xsp/xsp-2.4.2_pre2.ebuild b/dev-dotnet/xsp/xsp-2.4.2_pre2.ebuild
new file mode 100644
index 000000000000..9357cfd7124c
--- /dev/null
+++ b/dev-dotnet/xsp/xsp-2.4.2_pre2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/xsp-2.4.2_pre2.ebuild,v 1.1 2009/06/17 11:06:23 loki_val Exp $
+
+EAPI=2
+
+inherit go-mono mono autotools
+
+PATCHDIR="${FILESDIR}/2.2/"
+
+DESCRIPTION="XSP is a small web server that can host ASP.NET pages"
+HOMEPAGE="http://www.go-mono.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE=""
+
+RDEPEND="dev-db/sqlite:3"
+DEPEND="${RDEPEND}"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+pkg_preinst() {
+ enewgroup aspnet
+ # Give aspnet home dir of /tmp since it must create ~/.wapi
+ enewuser aspnet -1 -1 /tmp aspnet
+}
+
+src_install() {
+ mv_command="cp -ar" go-mono_src_install
+ newinitd "${PATCHDIR}"/xsp.initd xsp || die
+ newinitd "${PATCHDIR}"/mod-mono-server.initd mod-mono-server || die
+ newconfd "${PATCHDIR}"/xsp.confd xsp || die
+ newconfd "${PATCHDIR}"/mod-mono-server.confd mod-mono-server || die
+
+ keepdir /var/run/aspnet
+}
+
+pkg_postinst() {
+ chown aspnet:aspnet /var/run/aspnet
+}