summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-07-28 18:20:54 +0000
committerSamuli Suominen <drac@gentoo.org>2008-07-28 18:20:54 +0000
commit8e2f45c43b23651df6c11ac9582e0d1f767e4603 (patch)
tree6a2b61cb1278f184967455f2ac98de76be4113df /dev-dotnet/taglib-sharp
parentAdd local USE flags to metadata.xml (diff)
downloadgentoo-2-8e2f45c43b23651df6c11ac9582e0d1f767e4603.tar.gz
gentoo-2-8e2f45c43b23651df6c11ac9582e0d1f767e4603.tar.bz2
gentoo-2-8e2f45c43b23651df6c11ac9582e0d1f767e4603.zip
Fix documentation building (prepare for stable, required by banshee)
(Portage version: 2.2_rc3/cvs/Linux 2.6.26-rc3 x86_64)
Diffstat (limited to 'dev-dotnet/taglib-sharp')
-rw-r--r--dev-dotnet/taglib-sharp/ChangeLog7
-rw-r--r--dev-dotnet/taglib-sharp/files/taglib-sharp-2.0.3.0-fix-doc-failure.patch41
-rw-r--r--dev-dotnet/taglib-sharp/files/taglib-sharp-2.0.3.0-fix-docdir.patch37
-rw-r--r--dev-dotnet/taglib-sharp/taglib-sharp-2.0.3.0.ebuild13
4 files changed, 89 insertions, 9 deletions
diff --git a/dev-dotnet/taglib-sharp/ChangeLog b/dev-dotnet/taglib-sharp/ChangeLog
index f1444044c78f..6d9f9bb02e12 100644
--- a/dev-dotnet/taglib-sharp/ChangeLog
+++ b/dev-dotnet/taglib-sharp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-dotnet/taglib-sharp
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/taglib-sharp/ChangeLog,v 1.11 2008/07/28 15:47:03 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/taglib-sharp/ChangeLog,v 1.12 2008/07/28 18:20:54 drac Exp $
+
+ 28 Jul 2008; Samuli Suominen <drac@gentoo.org>
+ +files/taglib-sharp-2.0.3.0-fix-doc-failure.patch,
+ files/taglib-sharp-2.0.3.0-fix-docdir.patch, taglib-sharp-2.0.3.0.ebuild:
+ Fix documentation building.
28 Jul 2008; Raúl Porcel <armin76@gentoo.org>
taglib-sharp-2.0.2.0.ebuild:
diff --git a/dev-dotnet/taglib-sharp/files/taglib-sharp-2.0.3.0-fix-doc-failure.patch b/dev-dotnet/taglib-sharp/files/taglib-sharp-2.0.3.0-fix-doc-failure.patch
new file mode 100644
index 000000000000..29662408701f
--- /dev/null
+++ b/dev-dotnet/taglib-sharp/files/taglib-sharp-2.0.3.0-fix-doc-failure.patch
@@ -0,0 +1,41 @@
+diff -ur taglib-sharp-2.0.3.0.orig/src/TagLib/File.cs taglib-sharp-2.0.3.0/src/TagLib/File.cs
+--- taglib-sharp-2.0.3.0.orig/src/TagLib/File.cs 2008-01-03 03:24:13.000000000 +0200
++++ taglib-sharp-2.0.3.0/src/TagLib/File.cs 2008-07-28 20:50:15.000000000 +0300
+@@ -106,7 +106,7 @@
+
+ /// <summary>
+ /// This delegate is used for intervening in <see
+- /// cref="Create(string)" /> by resolving the file type
++ /// cref="File.Create(string)" /> by resolving the file type
+ /// before any standard resolution operations.
+ /// </summary>
+ /// <param name="abstraction">
+@@ -127,17 +127,17 @@
+ /// </returns>
+ /// <remarks>
+ /// <para>A <see cref="FileTypeResolver" /> is one way of
+- /// altering the behavior of <see cref="Create(string)"
++ /// altering the behavior of <see cref="File.Create(string)"
+ /// />.</para>
+- /// <para>When <see cref="Create(string)" /> is called, the
++ /// <para>When <see cref="File.Create(string)" /> is called, the
+ /// registered resolvers are invoked in the reverse order in
+ /// which they were registered. The resolver may then perform
+ /// any operations necessary, including other type-finding
+ /// methods.</para>
+ /// <para>If the resolver returns a new <see cref="File" />,
+ /// it will instantly be returned, by <see
+- /// cref="Create(string)" />. If it returns <see
+- /// langword="null" />, <see cref="Create(string)" /> will
++ /// cref="File.Create(string)" />. If it returns <see
++ /// langword="null" />, <see cref="File.Create(string)" /> will
+ /// continue to process. If the resolver throws an exception
+ /// it will be uncaught.</para>
+ /// <para>To register a resolver, use <see
+@@ -1769,4 +1769,4 @@
+
+ #endregion
+ }
+-}
+\ Ei rivinvaihtoa tiedoston lopussa
++}
diff --git a/dev-dotnet/taglib-sharp/files/taglib-sharp-2.0.3.0-fix-docdir.patch b/dev-dotnet/taglib-sharp/files/taglib-sharp-2.0.3.0-fix-docdir.patch
index 807a2152c158..014d0b9143e6 100644
--- a/dev-dotnet/taglib-sharp/files/taglib-sharp-2.0.3.0-fix-docdir.patch
+++ b/dev-dotnet/taglib-sharp/files/taglib-sharp-2.0.3.0-fix-docdir.patch
@@ -1,5 +1,6 @@
---- taglib-sharp-2.0.3.0/docs/Makefile.am 2008-01-03 10:14:19.000000000 +0200
-+++ taglib-sharp-2.0.3.0-new/docs/Makefile.am 2008-07-01 08:14:53.000000000 +0300
+diff -ur taglib-sharp-2.0.3.0.orig/docs/Makefile.am taglib-sharp-2.0.3.0/docs/Makefile.am
+--- taglib-sharp-2.0.3.0.orig/docs/Makefile.am 2008-01-03 10:14:19.000000000 +0200
++++ taglib-sharp-2.0.3.0/docs/Makefile.am 2008-07-28 21:14:35.000000000 +0300
@@ -10,7 +10,7 @@
XmlInjector.exe: XmlInjector.cs
mcs -out:$@ -r:System.Xml $<
@@ -9,3 +10,35 @@
monodoc_DATA = \
taglib-sharp-docs.zip \
taglib-sharp-docs.tree \
+@@ -23,7 +23,6 @@
+ rm -rf $(srcdir)/en; \
+ fi
+ monodocer /assembly:$(ASSEMBLY) /importslashdoc:$(SLASHDOC) /path:en
+- $(MONO) $(srcdir)/XmlInjector.exe $(srcdir)/Package.en.xml InsertMissingValues
+
+ update-html: $(srcdir)/en
+ if [ -d taglib-sharp-web-docs ]; then \
+@@ -35,12 +34,6 @@
+ taglib-sharp-docs.zip taglib-sharp-docs.tree: $(srcdir)/en/index.xml
+ $(DOC_ASSEMBLER) $(srcdir)/en
+
+-install-data-hook: $(srcdir)/XmlInjector.exe $(srcdir)/Package.en.xml
+- $(MONO) $(srcdir)/XmlInjector.exe $(srcdir)/Package.en.xml InjectMenuItem
+-
+-uninstall-hook: $(srcdir)/XmlInjector.exe $(srcdir)/Package.en.xml
+- $(MONO) $(srcdir)/XmlInjector.exe $(srcdir)/Package.en.xml RemoveMenuItem
+-
+ clean-local:
+ if [ -d $(srcdir)/en ]; then \
+ rm -rf $(srcdir)/en; \
+Vain hakemistossa taglib-sharp-2.0.3.0/docs: Makefile.am.orig
+Vain hakemistossa taglib-sharp-2.0.3.0/docs: Makefile.am.rej
+diff -ur taglib-sharp-2.0.3.0.orig/docs/taglib-sharp-docs.source taglib-sharp-2.0.3.0/docs/taglib-sharp-docs.source
+--- taglib-sharp-2.0.3.0.orig/docs/taglib-sharp-docs.source 2007-05-09 21:23:36.000000000 +0300
++++ taglib-sharp-2.0.3.0/docs/taglib-sharp-docs.source 2008-07-28 21:14:35.000000000 +0300
+@@ -1,4 +1,4 @@
+ <?xml version="1.0"?>
+ <monodoc>
+- <source provider="ecma" basefile="taglib-sharp-docs" path="classlib-taglib-sharp" />
++ <source provider="ecma" basefile="taglib-sharp-docs" path="various" title="TagLib" />
+ </monodoc>
diff --git a/dev-dotnet/taglib-sharp/taglib-sharp-2.0.3.0.ebuild b/dev-dotnet/taglib-sharp/taglib-sharp-2.0.3.0.ebuild
index 78130ca49834..ec63e436d7be 100644
--- a/dev-dotnet/taglib-sharp/taglib-sharp-2.0.3.0.ebuild
+++ b/dev-dotnet/taglib-sharp/taglib-sharp-2.0.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/taglib-sharp/taglib-sharp-2.0.3.0.ebuild,v 1.1 2008/07/07 16:18:01 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/taglib-sharp/taglib-sharp-2.0.3.0.ebuild,v 1.2 2008/07/28 18:20:54 drac Exp $
inherit autotools mono eutils
@@ -11,12 +11,13 @@ SRC_URI="http://www.taglib-sharp.com/Download/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="gnome"
+IUSE="doc gnome"
RDEPEND="dev-lang/mono
gnome? ( >=dev-dotnet/gnome-sharp-2 )"
DEPEND="${RDEPEND}
- dev-util/pkgconfig"
+ dev-util/pkgconfig
+ doc? ( dev-util/monodoc )"
src_unpack() {
unpack ${A}
@@ -28,15 +29,15 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-fix-docs-test.patch
# Allow gnome-sharp to be an optional dependency
epatch "${FILESDIR}"/${PN}-gnome-sharp-toggle.patch
+ # Fix documentation building
+ epatch "${FILESDIR}"/${P}-fix-doc-failure.patch
eautoreconf
}
src_compile() {
- # --enable-docs fails, fixme
- econf --disable-docs \
+ econf $(use_enable doc docs) \
$(use_enable gnome gnome-sharp) || die "econf failed."
-
emake -j1 || die "emake failed."
}