summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-08-31 13:58:26 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-08-31 13:58:26 +0000
commit4f7d2cc982bf59080de92488ad853d8668147a05 (patch)
tree031450c90cd896a0e23422ce41ec4dbbdc4e29dd /dev-dotnet/monotorrent
parentInitial commit (Audacious and MPD plugin). (diff)
downloadgentoo-2-4f7d2cc982bf59080de92488ad853d8668147a05.tar.gz
gentoo-2-4f7d2cc982bf59080de92488ad853d8668147a05.tar.bz2
gentoo-2-4f7d2cc982bf59080de92488ad853d8668147a05.zip
Use mono.snk.bz2 from mirrors, drop old.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'dev-dotnet/monotorrent')
-rw-r--r--dev-dotnet/monotorrent/ChangeLog6
-rw-r--r--dev-dotnet/monotorrent/files/mono.snkbin596 -> 0 bytes
-rw-r--r--dev-dotnet/monotorrent/monotorrent-0.70.ebuild48
-rw-r--r--dev-dotnet/monotorrent/monotorrent-0.72.ebuild7
4 files changed, 9 insertions, 52 deletions
diff --git a/dev-dotnet/monotorrent/ChangeLog b/dev-dotnet/monotorrent/ChangeLog
index 205eb64e065b..c296d5f455c2 100644
--- a/dev-dotnet/monotorrent/ChangeLog
+++ b/dev-dotnet/monotorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-dotnet/monotorrent
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/monotorrent/ChangeLog,v 1.5 2009/07/21 19:17:06 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/monotorrent/ChangeLog,v 1.6 2009/08/31 13:58:26 loki_val Exp $
+
+ 31 Aug 2009; Peter Alfredsen <loki_val@gentoo.org>
+ -monotorrent-0.70.ebuild, monotorrent-0.72.ebuild, -files/mono.snk:
+ Use mono.snk.bz2 from mirrors, drop old.
21 Jul 2009; Christian Faulhammer <fauli@gentoo.org>
monotorrent-0.72.ebuild:
diff --git a/dev-dotnet/monotorrent/files/mono.snk b/dev-dotnet/monotorrent/files/mono.snk
deleted file mode 100644
index 380116c18fc3..000000000000
--- a/dev-dotnet/monotorrent/files/mono.snk
+++ /dev/null
Binary files differ
diff --git a/dev-dotnet/monotorrent/monotorrent-0.70.ebuild b/dev-dotnet/monotorrent/monotorrent-0.70.ebuild
deleted file mode 100644
index 742cea338a49..000000000000
--- a/dev-dotnet/monotorrent/monotorrent-0.70.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/monotorrent/monotorrent-0.70.ebuild,v 1.2 2009/05/06 00:04:07 loki_val Exp $
-
-EAPI=2
-
-inherit mono multilib
-
-DESCRIPTION="Monotorrent is an open source C# bittorrent library"
-HOMEPAGE="http://projects.qnetp.net/projects/show/monotorrent"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE=""
-RDEPEND=">=dev-lang/mono-2.0.1"
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.23"
-
-# The hack we do to get the dll installed in the GAC makes the unit-tests
-# defunct.
-RESTRICT="test"
-
-src_prepare() {
- sed -i \
- -e "/InternalsVisibleTo/d" \
- MonoTorrent/AssemblyInfo.cs* || die
-}
-
-src_compile() {
- emake -j1 ASSEMBLY_COMPILER_COMMAND="/usr/bin/gmcs -keyfile:${FILESDIR}/mono.snk"
-}
-
-src_install() {
- egacinstall $(find . -name "MonoTorrent.dll")
- dodir /usr/$(get_libdir)/pkgconfig
- ebegin "Installing .pc file"
- sed \
- -e "s:@LIBDIR@:$(get_libdir):" \
- -e "s:@PACKAGENAME@:${PN}:" \
- -e "s:@DESCRIPTION@:${DESCRIPTION}:" \
- -e "s:@VERSION@:${PV}:" \
- -e 's;@LIBS@;-r:${libdir}/mono/monotorrent/MonoTorrent.dll;' \
- "${FILESDIR}"/${PN}.pc.in > "${D}"/usr/$(get_libdir)/pkgconfig/${PN}.pc
- PKG_CONFIG_PATH="${D}/usr/$(get_libdir)/pkgconfig/" pkg-config --exists monotorrent || die ".pc file failed to validate."
- eend $?
-}
diff --git a/dev-dotnet/monotorrent/monotorrent-0.72.ebuild b/dev-dotnet/monotorrent/monotorrent-0.72.ebuild
index ca205e522b23..138138e16207 100644
--- a/dev-dotnet/monotorrent/monotorrent-0.72.ebuild
+++ b/dev-dotnet/monotorrent/monotorrent-0.72.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/monotorrent/monotorrent-0.72.ebuild,v 1.4 2009/07/21 19:17:06 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/monotorrent/monotorrent-0.72.ebuild,v 1.5 2009/08/31 13:58:26 loki_val Exp $
EAPI=2
@@ -8,7 +8,8 @@ inherit mono multilib
DESCRIPTION="Monotorrent is an open source C# bittorrent library"
HOMEPAGE="http://projects.qnetp.net/projects/show/monotorrent"
-SRC_URI="http://projects.qnetp.net/attachments/download/13/${P}.tar.gz"
+SRC_URI="http://projects.qnetp.net/attachments/download/13/${P}.tar.gz
+ mirror://gentoo/mono.snk.bz2"
LICENSE="MIT"
SLOT="0"
@@ -29,7 +30,7 @@ src_prepare() {
}
src_compile() {
- emake -j1 ASSEMBLY_COMPILER_COMMAND="/usr/bin/gmcs -keyfile:${FILESDIR}/mono.snk"
+ emake -j1 ASSEMBLY_COMPILER_COMMAND="/usr/bin/gmcs -keyfile:${WORKDIR}/mono.snk"
}
src_install() {