summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2003-07-31 03:14:40 +0000
committerMasatomo Nakano <nakano@gentoo.org>2003-07-31 03:14:40 +0000
commitf0812581681d3cc4898ec0bdbef964f144b25423 (patch)
treefe1c460a79edbf6f82fe4f53a5f52ce19c1269fa /dev-db
parentVersion bumped. (diff)
downloadgentoo-2-f0812581681d3cc4898ec0bdbef964f144b25423.tar.gz
gentoo-2-f0812581681d3cc4898ec0bdbef964f144b25423.tar.bz2
gentoo-2-f0812581681d3cc4898ec0bdbef964f144b25423.zip
Version bumped.
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/postgresql/ChangeLog8
-rw-r--r--dev-db/postgresql/Manifest5
-rw-r--r--dev-db/postgresql/files/digest-postgresql-7.3.41
-rw-r--r--dev-db/postgresql/files/postgresql.init-7.3.455
-rw-r--r--dev-db/postgresql/postgresql-7.3.4.ebuild180
5 files changed, 246 insertions, 3 deletions
diff --git a/dev-db/postgresql/ChangeLog b/dev-db/postgresql/ChangeLog
index cea48def1e87..6af2f0adb216 100644
--- a/dev-db/postgresql/ChangeLog
+++ b/dev-db/postgresql/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/postgresql
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.59 2003/06/10 13:21:09 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.60 2003/07/31 03:14:22 nakano Exp $
+
+*postgresql-7.3.4 (31 Jul 2003)
+
+ 31 Jul 2003; Masatomo Nakano <nakano@gentoo.org> postgresql-7.3.4.ebuild,
+ files/postgresql.init-7.3.4:
+ Version bumped and modified init script.
*postgresql-7.3.3 (06 Jun 2003)
10 Jun 2003; Masatomo Nakano <nakano@gentoo.org> postgresql-7.3.3.ebuild:
diff --git a/dev-db/postgresql/Manifest b/dev-db/postgresql/Manifest
index 94cd2752d60a..e14a35cfb0ec 100644
--- a/dev-db/postgresql/Manifest
+++ b/dev-db/postgresql/Manifest
@@ -1,9 +1,10 @@
MD5 b74ddef00a98e9d3a9ca05f73def5222 postgresql-7.3.ebuild 5542
MD5 81d6711326226ed25d35a9723fd83edf postgresql-7.3.3.ebuild 5958
MD5 2e752de9634e2a5cd5d9f159434d8a89 postgresql-7.3.2.ebuild 5949
-MD5 64048afc8551006a922a36f223eb2d36 ChangeLog 9594
-MD5 d696f1ed8591e02bcb657b71d8ef1ed2 postgresql-7.3.4.ebuild 6082
+MD5 8cb023189b367d9ee8e151e96fd2f5a5 ChangeLog 9778
+MD5 b7456f58fd7fcc709bdc877bef755eb4 postgresql-7.3.4.ebuild 6028
MD5 bc6938c5fbc47a864dddb0c885f0a6dd files/pgsql 613
+MD5 b0b26f2f466f14fcab3085e2ce726413 files/postgresql.init-7.3.4 1138
MD5 26e2c8e4978d59f58bf13e94bbdc446b files/postgres 851
MD5 7506f28d74e703211fb53ebd246b5791 files/digest-postgresql-7.3.2 70
MD5 b140ea7a1bde8bbe8d14c34d7b2bf243 files/digest-postgresql-7.3.3 70
diff --git a/dev-db/postgresql/files/digest-postgresql-7.3.4 b/dev-db/postgresql/files/digest-postgresql-7.3.4
new file mode 100644
index 000000000000..67e5ed1a6f38
--- /dev/null
+++ b/dev-db/postgresql/files/digest-postgresql-7.3.4
@@ -0,0 +1 @@
+MD5 82878d6d74c36384af3595d26ed38067 postgresql-7.3.4.tar.gz 11265028
diff --git a/dev-db/postgresql/files/postgresql.init-7.3.4 b/dev-db/postgresql/files/postgresql.init-7.3.4
new file mode 100644
index 000000000000..9ea516e3e0bb
--- /dev/null
+++ b/dev-db/postgresql/files/postgresql.init-7.3.4
@@ -0,0 +1,55 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# /space/gentoo/cvsroot/gentoo-x86/dev-db/postgresql/files/postgresql.rc6,v 1.1 2002/01/06 00:53:24 woodchip Exp
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ ! -d $PGDATA ]; then
+ eerror "directory not found: $PGDATA"
+ eerror "You should create PGDATA directory first."
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting postgres"
+ if [ -f $PGDATA/postmaster.pid ]; then
+ rm $PGDATA/postmaster.pid
+ fi
+ su - $PGUSER -c "/usr/bin/pg_ctl start -D '$PGDATA' -s -l '$PGLOG' -o '$PGOPTS'"
+
+ while :
+ do
+ cnt=$(($cnt + 1))
+ if [ -f "$PGDATA/postmaster.pid" ]; then
+ ret=0
+ break
+ fi
+
+ if [ $cnt -eq 30 ]; then
+ eerror "Please see log file: $PGLOG"
+ ret=1
+ break
+ fi
+ sleep 1
+ done
+ eend $ret
+}
+
+stop () {
+ ebegin "Stopping postgres"
+ su - $PGUSER -c "/usr/bin/pg_ctl stop -D '$PGDATA' -s -m fast"
+ eend $?
+}
+
+svc_restart () {
+ ebegin "Restarting postgres"
+ su - $PGUSER -c "/usr/bin/pg_ctl restart -D '$PGDATA' -s -m fast -l '$PGLOG' -o '$PGOPTS'"
+ eend $?
+}
diff --git a/dev-db/postgresql/postgresql-7.3.4.ebuild b/dev-db/postgresql/postgresql-7.3.4.ebuild
new file mode 100644
index 000000000000..aed08af578c8
--- /dev/null
+++ b/dev-db/postgresql/postgresql-7.3.4.ebuild
@@ -0,0 +1,180 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.4.ebuild,v 1.1 2003/07/31 03:14:22 nakano Exp $
+
+DESCRIPTION="sophisticated Object-Relational DBMS"
+SRC_URI="ftp://ftp.postgresql.org/pub/source/v${PV}/${P}.tar.gz
+ ftp://ftp8.us.postgresql.org/pub/pgsql/v${PV}/${P}.tar.gz"
+HOMEPAGE="http://www.postgresql.org/"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+IUSE="ssl nls java python tcltk perl libg++ pam readline zlib"
+
+filter-flags -ffast-math
+
+DEPEND="virtual/glibc
+ sys-devel/autoconf
+ app-admin/sudo
+ >=sys-libs/ncurses-5.2
+ zlib? ( >=sys-libs/zlib-1.1.3 )
+ readline? ( >=sys-libs/readline-4.1 )
+ tcltk? ( >=dev-lang/tcl-8 >=dev-lang/tk-8.3.3-r1 )
+ perl? ( >=dev-lang/perl-5.6.1-r2 )
+ python? ( >=dev-lang/python-2.2 dev-python/egenix-mx-base )
+ java? ( >=virtual/jdk-1.3* >=dev-java/ant-1.3 )
+ ssl? ( >=dev-libs/openssl-0.9.6-r1 )
+ nls? ( sys-devel/gettext )"
+# java dep workaround for portage bug
+# x86? ( java? ( =dev-java/sun-jdk-1.3* >=dev-java/ant-1.3 ) )
+RDEPEND="virtual/glibc
+ zlib? ( >=sys-libs/zlib-1.1.3 )
+ tcltk? ( >=dev-lang/tcl-8 )
+ perl? ( >=dev-lang/perl-5.6.1-r2 )
+ python? ( >=dev-lang/python-2.2 )
+ java? ( >=virtual/jdk-1.3* )
+ ssl? ( >=dev-libs/openssl-0.9.6-r1 )"
+
+PG_DIR="/var/lib/postgresql"
+
+pkg_setup() {
+ if [ -f ${PG_DIR}/data/PG_VERSION ] ; then
+ PG_MAJOR=`cat ${PG_DIR}/data/PG_VERSION | cut -f1 -d.`
+ PG_MINOR=`cat ${PG_DIR}/data/PG_VERSION | cut -f2 -d.`
+ if [ ${PG_MAJOR} -lt 7 ] || [ ${PG_MAJOR} -eq 7 -a ${PG_MINOR} -lt 3 ] ; then
+ eerror "Postgres ${PV} cannot upgrade your existing databases, you must"
+ eerror "use pg_dump to export your existing databases to a file, and then"
+ eerror "pg_restore to import them when you have upgraded completely."
+ eerror "You must remove your entire database directory to continue."
+ eerror "(database directory = ${PG_DIR})."
+ exit 1
+ fi
+ fi
+}
+
+check_java_config() {
+ JDKHOME="`java-config --jdk-home`"
+ if [ -z "${JDKHOME}" ] || [ ! -d "${JDKHOME}" ]; then
+ NOJDKERROR="You need to use java-config to set your JVM to a JDK!"
+ eerror "${NOJDKERROR}"
+ die "${NOJDKERROR}"
+ fi
+}
+
+src_compile() {
+ use java && check_java_config
+
+ local myconf
+ use tcltk && myconf="--with-tcl"
+ use python && myconf="$myconf --with-python"
+ use perl && myconf="$myconf --with-perl"
+ use java && myconf="$myconf --with-java"
+ use ssl && myconf="$myconf --with-openssl"
+ use nls && myconf="$myconf --enable-nls"
+ use libg++ && myconf="$myconf --with-CXX"
+ use pam && myconf="$myconf --with-pam"
+ use readline || myconf="$myconf --without-readline"
+ use zlib || myconf="$myconf --without-zlib"
+
+ # these are the only working CFLAGS I could get on ppc, so locking them
+ # down, anything more aggressive fails (i.e. -mcpu or -Ox)
+ # Gerk - Nov 26, 2002
+ use ppc && CFLAGS="-pipe -fsigned-char"
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --docdir=/usr/share/doc/${P} \
+ --libdir=/usr/lib \
+ --enable-depend \
+ --with-gnu-ld \
+ --with-maxbackends=1024 \
+ $myconf || die
+
+ make || die
+ cd contrib
+ make || die
+}
+
+src_install() {
+ addwrite "/usr/share/man/man3/Pg.3pm"
+
+ if [ "`use perl`" ]
+ then
+ mv ${S}/src/pl/plperl/Makefile ${S}/src/pl/plperl/Makefile_orig
+ sed -e "s:(INST_DYNAMIC) /usr/lib:(INST_DYNAMIC) ${D}/usr/lib:" \
+ ${S}/src/pl/plperl/Makefile_orig > ${S}/src/pl/plperl/Makefile
+ mv ${S}/src/pl/plperl/GNUmakefile ${S}/src/pl/plperl/GNUmakefile_orig
+ sed -e "s:\$(DESTDIR)\$(plperl_installdir):\$(plperl_installdir):" \
+ ${S}/src/pl/plperl/GNUmakefile_orig > ${S}/src/pl/plperl/GNUmakefile
+ fi
+
+ make DESTDIR=${D} LIBDIR=${D}/usr/lib install || die
+ make DESTDIR=${D} install-all-headers || die
+ cd ${S}/contrib
+ make DESTDIR=${D} LIBDIR=${D}/usr/lib install || die
+ cd ${S}
+ dodoc COPYRIGHT HISTORY INSTALL README register.txt
+ dodoc contrib/adddepend/*
+ cd ${S}/doc
+ dodoc FAQ* KNOWN_BUGS MISSING_FEATURES README*
+ dodoc TODO bug.template
+ docinto sgml
+ dodoc src/sgml/*.{sgml,dsl}
+ docinto sgml/ref
+ dodoc src/sgml/ref/*.sgml
+ docinto sgml/graphics
+ dodoc src/graphics/*
+ rm -rf ${D}/usr/doc ${D}/mnt
+ exeinto /usr/bin
+
+ if [ `use java` ]; then
+ dojar ${D}/usr/share/postgresql/java/postgresql.jar
+ rm ${D}/usr/share/postgresql/java/postgresql.jar
+ fi
+
+ dodir /usr/include/postgresql/pgsql
+ cp ${D}/usr/include/*.h ${D}/usr/include/postgresql/pgsql
+
+ exeinto /etc/init.d/
+ newexe ${FILESDIR}/postgresql.init-${PV} postgresql || die
+
+ insinto /etc/conf.d/
+ newins ${FILESDIR}/postgresql.conf postgresql || die
+}
+
+pkg_postinst() {
+ einfo "Execute the following command"
+ einfo "ebuild /var/db/pkg/dev-db/${PF}/${PF}.ebuild config"
+ einfo "to setup the initial database environment."
+ einfo ""
+ einfo "Make sure the postgres user in /etc/passwd has an account setup with /bin/bash as the shell, or /bin/true"
+}
+
+pkg_config() {
+ einfo "Creating data directory ..."
+ mkdir -p ${PG_DIR}/data
+ chown -Rf postgres.postgres ${PG_DIR}
+ chmod 700 ${PG_DIR}/data
+
+ einfo "Initializing the database ..."
+ if [ -f ${PG_DIR}/data/PG_VERSION ] ; then
+ PG_MAJOR=`cat ${PG_DIR}/data/PG_VERSION | cut -f1 -d.`
+ PG_MINOR=`cat ${PG_DIR}/data/PG_VERSION | cut -f2 -d.`
+ if [ ${PG_MAJOR} -lt 7 ] || [ ${PG_MAJOR} -eq 7 -a ${PG_MINOR} -lt 3 ] ; then
+ eerror "Postgres ${PV} cannot upgrade your existing databases."
+ eerror "You must remove your entire database directory to continue."
+ eerror "(database directory = ${PG_DIR})."
+ exit 1
+ else
+ einfon "A postgres data directory already exists from version "; cat ${PG_DIR}/data/PG_VERSION
+ einfo "Read the documentation to check how to upgrade to version ${PV}."
+ fi
+ else
+ sudo -u postgres /usr/bin/initdb --pgdata ${PG_DIR}/data
+ einfo "If you are upgrading from a pre-7.3 version of PostgreSQL, please read"
+ einfo "the README.adddepend file for information on how to properly migrate"
+ einfo "all serial columns, unique keys and foreign keys to this version."
+ fi
+}