summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2015-07-28 02:26:22 +0000
committerBrian Evans <grknight@gentoo.org>2015-07-28 02:26:22 +0000
commitc419312685a0528cfa9d02507b2bd2ccfcf37e25 (patch)
treeeeaa85715ba5c26112ecbbcf30bc5d55ed288a03 /dev-db
parentRevbumps for new mysql packaging splitting client and server (diff)
downloadgentoo-2-c419312685a0528cfa9d02507b2bd2ccfcf37e25.tar.gz
gentoo-2-c419312685a0528cfa9d02507b2bd2ccfcf37e25.tar.bz2
gentoo-2-c419312685a0528cfa9d02507b2bd2ccfcf37e25.zip
Revbumps for new mysql packaging splitting client and server
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xD1F781EFF9F4A3B6)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mariadb-galera/ChangeLog8
-rw-r--r--dev-db/mariadb-galera/mariadb-galera-10.0.20-r1.ebuild137
-rw-r--r--dev-db/mariadb-galera/metadata.xml3
3 files changed, 147 insertions, 1 deletions
diff --git a/dev-db/mariadb-galera/ChangeLog b/dev-db/mariadb-galera/ChangeLog
index 28b447334488..73f2230b789c 100644
--- a/dev-db/mariadb-galera/ChangeLog
+++ b/dev-db/mariadb-galera/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/mariadb-galera
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mariadb-galera/ChangeLog,v 1.16 2015/06/29 17:06:14 grknight Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mariadb-galera/ChangeLog,v 1.17 2015/07/28 02:26:22 grknight Exp $
+
+*mariadb-galera-10.0.20-r1 (28 Jul 2015)
+
+ 28 Jul 2015; Brian Evans <grknight@gentoo.org>
+ +mariadb-galera-10.0.20-r1.ebuild, metadata.xml:
+ Revbumps for new mysql packaging splitting client and server
*mariadb-galera-10.0.20 (29 Jun 2015)
diff --git a/dev-db/mariadb-galera/mariadb-galera-10.0.20-r1.ebuild b/dev-db/mariadb-galera/mariadb-galera-10.0.20-r1.ebuild
new file mode 100644
index 000000000000..33e9659999e6
--- /dev/null
+++ b/dev-db/mariadb-galera/mariadb-galera-10.0.20-r1.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mariadb-galera/mariadb-galera-10.0.20-r1.ebuild,v 1.1 2015/07/28 02:26:22 grknight Exp $
+
+EAPI="5"
+MY_EXTRAS_VER="20150717-1707Z"
+WSREP_REVISION="25"
+HAS_TOOLS_PATCH="1"
+SUBSLOT="18"
+
+inherit toolchain-funcs mysql-multilib
+# only to make repoman happy. it is really set in the eclass
+IUSE="$IUSE"
+
+# REMEMBER: also update eclass/mysql*.eclass before committing!
+KEYWORDS="~amd64 ~x86"
+
+# When MY_EXTRAS is bumped, the index should be revised to exclude these.
+EPATCH_EXCLUDE=''
+
+DEPEND="|| ( >=sys-devel/gcc-3.4.6 >=sys-devel/gcc-apple-4.0 )"
+RDEPEND="${RDEPEND}"
+
+# Please do not add a naive src_unpack to this ebuild
+# If you want to add a single patch, copy the ebuild to an overlay
+# and create your own mysql-extras tarball, looking at 000_index.txt
+
+# Official test instructions:
+# USE='embedded extraengine perl ssl static-libs community' \
+# FEATURES='test userpriv -usersandbox' \
+# ebuild mariadb-galera-X.X.XX.ebuild \
+# digest clean package
+multilib_src_test() {
+
+ if ! multilib_is_native_abi ; then
+ einfo "Server tests not available on non-native abi".
+ return 0;
+ fi
+
+ local TESTDIR="${BUILD_DIR}/mysql-test"
+ local retstatus_unit
+ local retstatus_tests
+
+ # Bug #213475 - MySQL _will_ object strenously if your machine is named
+ # localhost. Also causes weird failures.
+ [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost"
+
+ if use server ; then
+
+ if [[ $UID -eq 0 ]]; then
+ die "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
+ fi
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+
+ einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ addpredict /this-dir-does-not-exist/t9.MYI
+
+ # Run CTest (test-units)
+ cmake-utils_src_test
+ retstatus_unit=$?
+ [[ $retstatus_unit -eq 0 ]] || eerror "test-unit failed"
+
+ # Ensure that parallel runs don't die
+ export MTR_BUILD_THREAD="$((${RANDOM} % 100))"
+ # Enable parallel testing, auto will try to detect number of cores
+ # You may set this by hand.
+ # The default maximum is 8 unless MTR_MAX_PARALLEL is increased
+ export MTR_PARALLEL="${MTR_PARALLEL:-auto}"
+
+ # create directories because mysqladmin might right out of order
+ mkdir -p "${T}"/var-tests{,/log}
+
+ # Create a symlink to provided binaries so the tests can find them when client-libs is off
+ if ! use client-libs ; then
+ ln -srf /usr/bin/my_print_defaults "${BUILD_DIR}/client/my_print_defaults" || die
+ ln -srf /usr/bin/perror "${BUILD_DIR}/client/perror" || die
+ mysql-multilib_disable_test main.perror "String mismatch due to not building local perror"
+ fi
+
+ # These are failing in MariaDB 10.0 for now and are believed to be
+ # false positives:
+ #
+ # main.information_schema, binlog.binlog_statement_insert_delayed,
+ # main.mysqld--help, funcs_1.is_triggers, funcs_1.is_tables_mysql,
+ # funcs_1.is_columns_mysql, main.bootstrap
+ # fails due to USE=-latin1 / utf8 default
+ #
+ # main.mysql_client_test, main.mysql_client_test_nonblock
+ # main.mysql_client_test_comp:
+ # segfaults at random under Portage only, suspect resource limits.
+ #
+ # wsrep.variables:
+ # Expects the sys-cluster/galera library to be installed and configured
+ #
+ # wsrep.foreign_key:
+ # Issues a configuration deprecation warning which does not affect data
+ #
+
+ for t in main.mysql_client_test main.mysql_client_test_nonblock \
+ main.mysql_client_test_comp main.bootstrap \
+ binlog.binlog_statement_insert_delayed main.information_schema \
+ main.mysqld--help wsrep.variables wsrep.foreign_key \
+ funcs_1.is_triggers funcs_1.is_tables_mysql funcs_1.is_columns_mysql ; do
+ mysql-multilib_disable_test "$t" "False positives in Gentoo"
+ done
+
+ # Run mysql tests
+ pushd "${TESTDIR}"
+
+ # run mysql-test tests
+ # The PATH addition is required for the galera suite to find the sst scripts
+ # Skipping galera tests for now until MDEV-7544 is resovled
+ WSREP_LOG_DIR="${T}/var-tests/wsrep" \
+ PATH="${BUILD_DIR}/scripts:${PATH}" \
+ perl mysql-test-run.pl --force --vardir="${T}/var-tests" --skip-test=galera
+ retstatus_tests=$?
+ [[ $retstatus_tests -eq 0 ]] || eerror "tests failed"
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+
+ popd
+
+ # Cleanup is important for these testcases.
+ pkill -9 -f "${S}/ndb" 2>/dev/null
+ pkill -9 -f "${S}/sql" 2>/dev/null
+
+ failures=""
+ [[ $retstatus_unit -eq 0 ]] || failures="${failures} test-unit"
+ [[ $retstatus_tests -eq 0 ]] || failures="${failures} tests"
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+
+ [[ -z "$failures" ]] || die "Test failures: $failures"
+ einfo "Tests successfully completed"
+ else
+
+ einfo "Skipping server tests due to minimal build."
+ fi
+}
diff --git a/dev-db/mariadb-galera/metadata.xml b/dev-db/mariadb-galera/metadata.xml
index 7c8bf6edc4ec..e0a0598ce6ff 100644
--- a/dev-db/mariadb-galera/metadata.xml
+++ b/dev-db/mariadb-galera/metadata.xml
@@ -8,6 +8,7 @@ dev-db/mysql
dev-db/mariadb
-->
<use>
+ <flag name='client-libs'>Build the libmysqlclient libraries</flag>
<flag name='cluster'>Add support for NDB clustering (deprecated)</flag>
<flag name='community'>Enables the community features from upstream.</flag>
<flag name='embedded'>Build embedded server (libmysqld)</flag>
@@ -17,11 +18,13 @@ dev-db/mariadb
<flag name='minimal'>Install client programs only, no server</flag>
<flag name='oqgraph'>Add support for the Open Query GRAPH engine</flag>
<flag name='profiling'>Add support for statement profiling (requires USE=community).</flag>
+ <flag name='server'>Build the server program</flag>
<flag name='sst-rsync'>Add tools needed to support the rsync SST method</flag>
<flag name='sst-xtrabackup'>Add tools needed to support the xtrabackup and xtrabackup-v2 SST methods</flag>
<flag name="systemtap">Build support for profiling and tracing using <pkg>dev-util/systemtap</pkg></flag>
<flag name='sphinx'>Add suport for the sphinx full-text search engine</flag>
<flag name='test'>Install upstream testsuites for end use.</flag>
<flag name='tokudb'>Add support for TokuDB storage engine</flag>
+ <flag name='tools'>Build the command line tools (mysql, mysqldump, mysqladmin, etc)</flag>
</use>
</pkgmetadata>