summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorFederico Ferri <mescalinum@gentoo.org>2009-08-09 03:06:32 +0000
committerFederico Ferri <mescalinum@gentoo.org>2009-08-09 03:06:32 +0000
commitc0a86ee6e391bdb3d2f0f12639b3a5ef75cb1a58 (patch)
treec8174bf42c22b4c4f3e3be9ead94345f2aa555bc /dev-db
parentstable amd64, bug 280668 (diff)
downloadgentoo-2-c0a86ee6e391bdb3d2f0f12639b3a5ef75cb1a58.tar.gz
gentoo-2-c0a86ee6e391bdb3d2f0f12639b3a5ef75cb1a58.tar.bz2
gentoo-2-c0a86ee6e391bdb3d2f0f12639b3a5ef75cb1a58.zip
fix bug 247210
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pgaccess/ChangeLog11
-rw-r--r--dev-db/pgaccess/files/pgaccess-0.99.0.20040219-tcl8.5.patch14
-rw-r--r--dev-db/pgaccess/pgaccess-0.99.0.20040219-r1.ebuild47
3 files changed, 70 insertions, 2 deletions
diff --git a/dev-db/pgaccess/ChangeLog b/dev-db/pgaccess/ChangeLog
index eec2c01db9dc..55e087b025fb 100644
--- a/dev-db/pgaccess/ChangeLog
+++ b/dev-db/pgaccess/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/pgaccess
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgaccess/ChangeLog,v 1.15 2008/05/21 15:56:32 dev-zero Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgaccess/ChangeLog,v 1.16 2009/08/09 03:06:31 mescalinum Exp $
+
+*pgaccess-0.99.0.20040219-r1 (09 Aug 2009)
+
+ 09 Aug 2009; Federico Ferri <mescalinum@gentoo.org>
+ +pgaccess-0.99.0.20040219-r1.ebuild,
+ +files/pgaccess-0.99.0.20040219-tcl8.5.patch:
+ fix bug 247210
21 May 2008; Tiziano Müller <dev-zero@gentoo.org> pgaccess-0.98.8.ebuild,
pgaccess-0.99.0.20040219.ebuild:
diff --git a/dev-db/pgaccess/files/pgaccess-0.99.0.20040219-tcl8.5.patch b/dev-db/pgaccess/files/pgaccess-0.99.0.20040219-tcl8.5.patch
new file mode 100644
index 000000000000..94d7e9323b6d
--- /dev/null
+++ b/dev-db/pgaccess/files/pgaccess-0.99.0.20040219-tcl8.5.patch
@@ -0,0 +1,14 @@
+diff -urpN a/lib/mainlib.tcl b/lib/mainlib.tcl
+--- a/lib/mainlib.tcl 2009-08-09 04:28:13.000000000 +0200
++++ b/lib/mainlib.tcl 2009-08-09 04:55:59.000000000 +0200
+@@ -3186,8 +3186,8 @@ proc vTclWindow.pgaw:Main {base} {
+ -columns [list 0 "" left] \
+ -selectforeground #708090 \
+ -labelbackground #DDDDDD \
+- -labelforeground navy
+- ]
++ -labelforeground navy \
++ -activestyle none]
+
+ set body [$::Mainlib::Win(mclist) bodypath]
+ bind $body <Double-Button-1> [bind TablelistBody <Double-Button-1>]
diff --git a/dev-db/pgaccess/pgaccess-0.99.0.20040219-r1.ebuild b/dev-db/pgaccess/pgaccess-0.99.0.20040219-r1.ebuild
new file mode 100644
index 000000000000..39c357fc6948
--- /dev/null
+++ b/dev-db/pgaccess/pgaccess-0.99.0.20040219-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgaccess/pgaccess-0.99.0.20040219-r1.ebuild,v 1.1 2009/08/09 03:06:31 mescalinum Exp $
+
+inherit eutils
+
+MY_P=${P//./_}
+
+DESCRIPTION="a database frontend for postgresql"
+HOMEPAGE="http://www.pgaccess.org/"
+SRC_URI="mirror://sourceforge/pgaccess/${MY_P}.tgz"
+LICENSE="POSTGRESQL"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+DEPEND="virtual/libc"
+
+RDEPEND=">=dev-lang/tcl-8.3.4
+ >=dev-lang/tk-8.3.4
+ >=virtual/postgresql-server-7.3
+ dev-tcltk/tcllib"
+
+src_compile() {
+ cd ${S}
+ epatch ${FILESDIR}/${P}.patch
+ epatch ${FILESDIR}/${P}-tcl8.5.patch
+}
+
+src_install() {
+ make prefix=${D} install || die
+ rm -rf ${D}/usr/lib/pgaccess/win32 \
+ ${D}/usr/lib/pgaccess/Makefile
+ rm -rf ${D}/usr/lib/pgaccess/osx
+ dodir /usr/share/doc/${PF}
+ mv ${D}/usr/lib/pgaccess/{README,changelog,copyright,demo,doc/html,todo} ${D}/usr/share/doc/${PF}
+ rmdir ${D}/usr/lib/pgaccess/doc
+}
+
+pkg_postinst() {
+ einfo "When running the program, if you encount the error "
+ einfo "\"Error: Shared library file: '/usr/lib/libpgtcl.so' does not exist.\","
+ einfo "you need to emerge postgresql with USE='tcltk' again"
+}