summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorGeert Bevin <gbevin@gentoo.org>2002-01-31 14:46:07 +0000
committerGeert Bevin <gbevin@gentoo.org>2002-01-31 14:46:07 +0000
commit1ce50dc018c2ebf1d5cf69a401ff44f7765e7bef (patch)
treeddd6e992b2f5fe4f94c943428ed88b298f4e4ba5 /dev-db
parentadded download url (diff)
downloadgentoo-2-1ce50dc018c2ebf1d5cf69a401ff44f7765e7bef.tar.gz
gentoo-2-1ce50dc018c2ebf1d5cf69a401ff44f7765e7bef.tar.bz2
gentoo-2-1ce50dc018c2ebf1d5cf69a401ff44f7765e7bef.zip
Added support for python 2.1 and cleaned up some spurious perl lib
generated dirs.
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/postgresql/files/digest-postgresql-7.1.3-r3 (renamed from dev-db/postgresql/files/digest-postgresql-7.1.3-r2)0
-rw-r--r--dev-db/postgresql/files/postgresql-7.1.3-python21-configure-gentoo.diff20
-rw-r--r--dev-db/postgresql/files/postgresql-7.1.3-python21-makefiles-gentoo.diff44
-rw-r--r--dev-db/postgresql/postgresql-7.1.3-r3.ebuild (renamed from dev-db/postgresql/postgresql-7.1.3-r2.ebuild)46
4 files changed, 99 insertions, 11 deletions
diff --git a/dev-db/postgresql/files/digest-postgresql-7.1.3-r2 b/dev-db/postgresql/files/digest-postgresql-7.1.3-r3
index e8dbf2b65914..e8dbf2b65914 100644
--- a/dev-db/postgresql/files/digest-postgresql-7.1.3-r2
+++ b/dev-db/postgresql/files/digest-postgresql-7.1.3-r3
diff --git a/dev-db/postgresql/files/postgresql-7.1.3-python21-configure-gentoo.diff b/dev-db/postgresql/files/postgresql-7.1.3-python21-configure-gentoo.diff
new file mode 100644
index 000000000000..f3376a4a1938
--- /dev/null
+++ b/dev-db/postgresql/files/postgresql-7.1.3-python21-configure-gentoo.diff
@@ -0,0 +1,20 @@
+--- postgresql-7.1.3/configure_orig 2002-01-31 13:51:50.000000000 +0100
++++ postgresql-7.1.3/configure 2002-01-31 13:52:01.000000000 +0100
+@@ -1834,7 +1834,7 @@
+ yes)
+ echo "$ac_t""yes" 1>&6
+ # Extract the first word of "python", so it can be a program name with args.
+-set dummy python; ac_word=$2
++set dummy python2.1; ac_word=$2
+ echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
+ echo "configure:1840: checking for $ac_word" >&5
+ if eval "test \"`echo '$''{'ac_cv_prog_PYTHON'+set}'`\" = set"; then
+@@ -1848,7 +1848,7 @@
+ for ac_dir in $ac_dummy; do
+ test -z "$ac_dir" && ac_dir=.
+ if test -f $ac_dir/$ac_word; then
+- ac_cv_prog_PYTHON="python"
++ ac_cv_prog_PYTHON="python2.1"
+ break
+ fi
+ done
diff --git a/dev-db/postgresql/files/postgresql-7.1.3-python21-makefiles-gentoo.diff b/dev-db/postgresql/files/postgresql-7.1.3-python21-makefiles-gentoo.diff
new file mode 100644
index 000000000000..86bc53454003
--- /dev/null
+++ b/dev-db/postgresql/files/postgresql-7.1.3-python21-makefiles-gentoo.diff
@@ -0,0 +1,44 @@
+--- postgresql-7.1.3/src/interfaces/python/Makefile.pre.in_orig 2002-01-31 14:19:30.000000000 +0100
++++ postgresql-7.1.3/src/interfaces/python/Makefile.pre.in 2002-01-31 14:19:55.000000000 +0100
+@@ -89,10 +89,10 @@
+ # === Variables that you may want to customize (rarely) ===
+
+ # (Static) build target
+-TARGET= python
++TARGET= python2.1
+
+ # Installed python binary (used only by boot target)
+-PYTHON= python
++PYTHON= python2.1
+
+ # Add more -I and -D options here
+ CFLAGS= $(OPT) -I$(INCLUDEPY) -I$(EXECINCLUDEPY) $(DEFS)
+--- postgresql-7.1.3/src/interfaces/python/mkdefines_orig 2000-10-02 05:27:27.000000000 +0200
++++ postgresql-7.1.3/src/interfaces/python/mkdefines 2002-01-31 14:20:15.000000000 +0100
+@@ -1,4 +1,4 @@
+-#! /usr/bin/env python
++#! /usr/bin/env python2.1
+
+ import string
+
+--- postgresql-7.1.3/src/interfaces/python/PyGreSQL.spec_orig 2002-01-31 14:20:36.000000000 +0100
++++ postgresql-7.1.3/src/interfaces/python/PyGreSQL.spec 2002-01-31 14:21:26.000000000 +0100
+@@ -37,8 +37,8 @@
+ mkdir -p $RPM_BUILD_ROOT/usr/lib/python%{pythonversion}/lib-dynload
+ cc -fpic -shared -o $RPM_BUILD_ROOT/usr/lib/python%{pythonversion}/lib-dynload/_pg.so -I/usr/include/pgsql/ -I/usr/include/python1.5 pgmodule.c -lpq
+ ## import fails, since _pg is not yet installed
+-python -c 'import pg' || true
+-python -c 'import pgdb' || true
++python2.1 -c 'import pg' || true
++python2.1 -c 'import pgdb' || true
+
+ %install
+ cp *.py *.pyc $RPM_BUILD_ROOT/usr/lib/python%{pythonversion}/
+--- postgresql-7.1.3/src/interfaces/python/setup.py_orig 2002-01-31 14:20:41.000000000 +0100
++++ postgresql-7.1.3/src/interfaces/python/setup.py 2002-01-31 14:21:01.000000000 +0100
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2.1
+
+ # Setup script for the PyGreSQL version 3
+ # created 2000/04 Mark Alexander <mwa@gate.net>
diff --git a/dev-db/postgresql/postgresql-7.1.3-r2.ebuild b/dev-db/postgresql/postgresql-7.1.3-r3.ebuild
index d6ea614c5f04..732932a96429 100644
--- a/dev-db/postgresql/postgresql-7.1.3-r2.ebuild
+++ b/dev-db/postgresql/postgresql-7.1.3-r3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Geert Bevin <gbevin@theleaf.be>
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.1.3-r2.ebuild,v 1.1 2002/01/31 02:14:33 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.1.3-r3.ebuild,v 1.1 2002/01/31 14:46:07 gbevin Exp $
S=${WORKDIR}/${P}
DESCRIPTION="PostgreSQL is a sophisticated Object-Relational DBMS"
@@ -15,18 +15,18 @@ DEPEND="virtual/glibc
>=sys-libs/zlib-1.1.3
tcltk? ( >=dev-lang/tcl-8 )
perl? ( >=sys-devel/perl-5.6.1-r2 )
+ python? ( ~dev-lang/python-2.1.1 )
java? ( >=virtual/jdk-1.3 >=dev-java/ant-1.3 )
ssl? ( >=dev-libs/openssl-0.9.6-r1 )
nls? ( sys-devel/gettext )"
-# python? ( >=dev-lang/python-2.2-r4 )
RDEPEND="virtual/glibc
>=sys-libs/zlib-1.1.3
tcltk? ( >=dev-lang/tcl-8 )
perl? ( >=sys-devel/perl-5.6.1-r2 )
+ python? ( ~dev-lang/python-2.1.1 )
java? ( >=virtual/jdk-1.3 )
ssl? ( >=dev-libs/openssl-0.9.6-r1 )"
-# python? ( >=dev-lang/python-2.2-r4 )
src_unpack() {
@@ -37,11 +37,14 @@ src_unpack() {
# we know that a shared libperl is present, the default perl
# config is however set to the static libperl.a
# just remove the check
- patch -p1 < ${FILESDIR}/${P}-dyn-libperl-gentoo.diff
+ patch -p1 < ${FILESDIR}/${P}-dyn-libperl-gentoo.diff || die
+
+ # patch configure to use python 2.1 for sure
+ patch -p1 < ${FILESDIR}/${P}-python21-configure-gentoo.diff || die
# This patch is based on Lamar Owens, Thomas Lockhards and
# Thron Eivind Glomsrod work. Thanks you all.
- patch -p1 < ${FILESDIR}/${P}-perl5-GNUmakefile-gentoo.diff
+ patch -p1 < ${FILESDIR}/${P}-perl5-GNUmakefile-gentoo.diff || die
}
src_compile() {
@@ -51,10 +54,10 @@ src_compile() {
then
myconf="--with-tcl"
fi
-# if [ "`use python`" ]
-# then
-# myconf="$myconf --with-python"
-# fi
+ if [ "`use python`" ]
+ then
+ myconf="$myconf --with-python"
+ fi
if [ "`use perl`" ]
then
myconf="$myconf --with-perl"
@@ -84,6 +87,17 @@ src_compile() {
--enable-syslog \
$myconf || die
+ if [ "`use python`" ]
+ then
+ # generate python makefiles
+ cd ${S}/src/interfaces/python
+ make Makefile.pre.in
+
+ cd ${S}
+ # patch makefiles to use python 2.1 for sure
+ patch -p1 < ${FILESDIR}/${P}-python21-makefiles-gentoo.diff || die
+ fi
+
emake || die
}
@@ -95,9 +109,20 @@ src_install () {
mv ${S}/src/pl/plperl/Makefile ${S}/src/pl/plperl/Makefile_orig
sed -e "s:(INST_DYNAMIC) /usr/lib:(INST_DYNAMIC) ${D}/usr/lib:" \
${S}/src/pl/plperl/Makefile_orig > ${S}/src/pl/plperl/Makefile
+ mv ${S}/src/pl/plperl/GNUmakefile ${S}/src/pl/plperl/GNUmakefile_orig
+ sed -e "s:\$(DESTDIR)\$(plperl_installdir):\$(plperl_installdir):" \
+ ${S}/src/pl/plperl/GNUmakefile_orig > ${S}/src/pl/plperl/GNUmakefile
+ fi
+
+ if [ "`use python`" ]
+ then
+ mkdir -p ${D}/usr/lib/python2.1/site-packages
+ mv ${S}/src/Makefile.global ${S}/src/Makefile.global_orig
+ sed -e "s:python_moduledir = /usr/lib/python2.1:python_moduledir = ${D}/usr/lib/python2.1:" \
+ ${S}/src/Makefile.global_orig > ${S}/src/Makefile.global
fi
- make DESTDIR=${D} install || die
+ make DESTDIR=${D} LIBDIR=${D}/usr/lib install || die
make DESTDIR=${D} install-all-headers || die
dodoc COPYRIGHT HISTORY INSTALL README register.txt
cd ${S}/doc
@@ -110,7 +135,6 @@ src_install () {
dodoc src/sgml/ref/*.sgml
docinto sgml/graphics
dodoc src/graphics/*
- mv ${D}/usr/doc/postgresql/html ${D}/usr/share/doc/${PF}
rm -rf ${D}/usr/doc ${D}/mnt
exeinto /usr/bin