summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-04 21:36:16 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-04 21:36:16 +0000
commit1c2562da7c9a7ebb776963369cf6a6f9496288c5 (patch)
tree05af096ea4820b0c4c2805cc52ecd4319c31e6c3 /dev-db
parentDelete older ebuild. (diff)
downloadgentoo-2-1c2562da7c9a7ebb776963369cf6a6f9496288c5.tar.gz
gentoo-2-1c2562da7c9a7ebb776963369cf6a6f9496288c5.tar.bz2
gentoo-2-1c2562da7c9a7ebb776963369cf6a6f9496288c5.zip
Delete calls to deprecated python_version().
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/metakit/ChangeLog6
-rw-r--r--dev-db/metakit/metakit-2.4.9.6.ebuild26
-rw-r--r--dev-db/metakit/metakit-2.4.9.7.ebuild20
3 files changed, 25 insertions, 27 deletions
diff --git a/dev-db/metakit/ChangeLog b/dev-db/metakit/ChangeLog
index eb2e4dbc70f3..15281ac2641e 100644
--- a/dev-db/metakit/ChangeLog
+++ b/dev-db/metakit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/metakit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/metakit/ChangeLog,v 1.45 2010/02/22 11:46:57 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/metakit/ChangeLog,v 1.46 2010/04/04 21:36:16 arfrever Exp $
+
+ 04 Apr 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ metakit-2.4.9.6.ebuild, metakit-2.4.9.7.ebuild:
+ Delete calls to deprecated python_version().
22 Feb 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
metakit-2.4.9.7.ebuild:
diff --git a/dev-db/metakit/metakit-2.4.9.6.ebuild b/dev-db/metakit/metakit-2.4.9.6.ebuild
index 87ffa906e79e..a80009252dea 100644
--- a/dev-db/metakit/metakit-2.4.9.6.ebuild
+++ b/dev-db/metakit/metakit-2.4.9.6.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/metakit/metakit-2.4.9.6.ebuild,v 1.7 2007/06/24 21:51:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/metakit/metakit-2.4.9.6.ebuild,v 1.8 2010/04/04 21:36:16 arfrever Exp $
-inherit python multilib eutils
+inherit eutils multilib python
DESCRIPTION="Embedded database library"
HOMEPAGE="http://www.equi4.com/metakit/"
@@ -11,7 +11,7 @@ SRC_URI="http://www.equi4.com/pub/mk/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~hppa ia64 ppc s390 sparc x86"
-IUSE="python tcl static"
+IUSE="python static tcl"
DEPEND=">=sys-apps/sed-4
python? ( >=dev-lang/python-2.2.1 )
@@ -20,19 +20,19 @@ DEPEND=">=sys-apps/sed-4
RESTRICT="test"
src_unpack() {
- python_version
+ unpack ${A}
+ cd "${S}"
- unpack ${A} ; cd ${S}
# Fix all hardcoded python2.5 paths
- for name in python/scxx/PWOBase.h python/PyHead.h python/PyStorage.cpp ; do
- sed -i -e "s:Python.h:python${PYVER}/Python.h:" ${name}
+ for name in python/scxx/PWOBase.h python/PyHead.h python/PyStorage.cpp; do
+ sed -i -e "s:Python.h:python$(python_get_version)/Python.h:" ${name}
done
- sed -i -e "s:python2.5:python${PYVER}:" unix/configure
+ sed -i -e "s:python2.5:python$(python_get_version):" unix/configure
}
src_compile() {
local myconf mycxxflags
- use python && myconf="--with-python=/usr/include/python${PYVER},/usr/$(get_libdir)/python${PYVER}/site-packages"
+ use python && myconf="--with-python=$(python_get_includedir),$(python_get_sitedir)"
use tcl && myconf="${myconf} --with-tcl=/usr/include,/usr/$(get_libdir)"
use static && myconf="${myconf} --disable-shared"
use static || mycxxflags="-fPIC"
@@ -51,10 +51,8 @@ src_compile() {
}
src_install () {
- python_version
-
- use python && dodir /usr/$(get_libdir)/python${PYVER}/site-packages
- make DESTDIR=${D} install || die
+ use python && dodir $(python_get_sitedir)
+ make DESTDIR="${D}" install || die
dodoc CHANGES README WHATSNEW
dohtml MetaKit.html
diff --git a/dev-db/metakit/metakit-2.4.9.7.ebuild b/dev-db/metakit/metakit-2.4.9.7.ebuild
index f04f9eb4d758..9dfad74aa090 100644
--- a/dev-db/metakit/metakit-2.4.9.7.ebuild
+++ b/dev-db/metakit/metakit-2.4.9.7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/metakit/metakit-2.4.9.7.ebuild,v 1.3 2010/02/22 11:46:57 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/metakit/metakit-2.4.9.7.ebuild,v 1.4 2010/04/04 21:36:16 arfrever Exp $
-inherit python multilib eutils
+inherit eutils multilib python
DESCRIPTION="Embedded database library"
HOMEPAGE="http://www.equi4.com/metakit/"
@@ -11,7 +11,7 @@ SRC_URI="http://www.equi4.com/pub/mk/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~s390 ~sparc ~x86"
-IUSE="python tcl static"
+IUSE="python static tcl"
DEPEND=">=sys-apps/sed-4
python? ( >=dev-lang/python-2.2.1 )
@@ -20,21 +20,19 @@ DEPEND=">=sys-apps/sed-4
RESTRICT="test"
src_unpack() {
- python_version
-
unpack ${A}
cd "${S}"
# Fix all hardcoded python2.5 paths
- for name in python/scxx/PWOBase.h python/PyHead.h python/PyStorage.cpp ; do
- sed -i -e "s:Python.h:python${PYVER}/Python.h:" ${name}
+ for name in python/scxx/PWOBase.h python/PyHead.h python/PyStorage.cpp; do
+ sed -i -e "s:Python.h:python$(python_get_version)/Python.h:" ${name}
done
- sed -i -e "s:python2.5:python${PYVER}:" unix/configure
+ sed -i -e "s:python2.5:python$(python_get_version):" unix/configure
}
src_compile() {
local myconf mycxxflags
- use python && myconf="--with-python=/usr/include/python${PYVER},/usr/$(get_libdir)/python${PYVER}/site-packages"
+ use python && myconf="--with-python=$(python_get_includedir),$(python_get_sitedir)"
use tcl && myconf="${myconf} --with-tcl=/usr/include,/usr/$(get_libdir)"
use static && myconf="${myconf} --disable-shared"
use static || mycxxflags="-fPIC"
@@ -53,9 +51,7 @@ src_compile() {
}
src_install () {
- python_version
-
- use python && dodir /usr/$(get_libdir)/python${PYVER}/site-packages
+ use python && dodir $(python_get_sitedir)
make DESTDIR="${D}" install || die
dodoc CHANGES README