summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2010-04-05 22:31:38 +0000
committerVlastimil Babka <caster@gentoo.org>2010-04-05 22:31:38 +0000
commit178fd7fbffe78b36c44c5d1eae6e7f7b9b271e26 (patch)
tree38f1364b58ec86904e2c65c8573932d77c1bd982 /dev-db
parentBump to EAPI=3, add prefix keywords & patch (diff)
downloadgentoo-2-178fd7fbffe78b36c44c5d1eae6e7f7b9b271e26.tar.gz
gentoo-2-178fd7fbffe78b36c44c5d1eae6e7f7b9b271e26.tar.bz2
gentoo-2-178fd7fbffe78b36c44c5d1eae6e7f7b9b271e26.zip
Fix sandbox problems. Bug #253163, thanks to Jimmy.Jazz@gmx.net for the patch.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/hsqldb/ChangeLog7
-rw-r--r--dev-db/hsqldb/hsqldb-1.8.0.10.ebuild9
-rw-r--r--dev-db/hsqldb/hsqldb-1.8.1.2.ebuild10
3 files changed, 16 insertions, 10 deletions
diff --git a/dev-db/hsqldb/ChangeLog b/dev-db/hsqldb/ChangeLog
index 26f79c1aacce..13dd3800a559 100644
--- a/dev-db/hsqldb/ChangeLog
+++ b/dev-db/hsqldb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/hsqldb
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/hsqldb/ChangeLog,v 1.54 2010/03/09 10:31:28 ali_bush Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/hsqldb/ChangeLog,v 1.55 2010/04/05 22:31:38 caster Exp $
+
+ 05 Apr 2010; Vlastimil Babka <caster@gentoo.org> hsqldb-1.8.0.10.ebuild,
+ hsqldb-1.8.1.2.ebuild:
+ Fix sandbox problems. Bug #253163, thanks to Jimmy.Jazz@gmx.net for the
+ patch.
*hsqldb-1.8.1.2 (08 Mar 2010)
diff --git a/dev-db/hsqldb/hsqldb-1.8.0.10.ebuild b/dev-db/hsqldb/hsqldb-1.8.0.10.ebuild
index 39b0de3d11cc..4767149d1557 100644
--- a/dev-db/hsqldb/hsqldb-1.8.0.10.ebuild
+++ b/dev-db/hsqldb/hsqldb-1.8.0.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/hsqldb/hsqldb-1.8.0.10.ebuild,v 1.5 2010/01/15 17:43:33 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/hsqldb/hsqldb-1.8.0.10.ebuild,v 1.6 2010/04/05 22:31:38 caster Exp $
EAPI=1
JAVA_PKG_IUSE="doc source test"
@@ -117,15 +117,16 @@ src_install() {
exeinto "${HSQLDB_HOME}/bin"
doexe bin/hsqldb || die
+ # Make sure that files have correct permissions
+ chown -R hsqldb:hsqldb "${D}${HSQLDB_HOME}"
+ chmod o-rwx "${D}${HSQLDB_HOME}"
+
# Create symlinks to authorization files in the server home dir
# (required by the hqldb init script)
insinto "${HSQLDB_HOME}"
dosym /etc/hsqldb/server.properties "${HSQLDB_HOME}/server.properties" || die
dosym /etc/hsqldb/sqltool.rc "${HSQLDB_HOME}/sqltool.rc" || die
- # Make sure that files have correct permissions
- chown -R hsqldb:hsqldb "${D}${HSQLDB_HOME}"
- chmod o-rwx "${D}${HSQLDB_HOME}"
}
pkg_postinst() {
diff --git a/dev-db/hsqldb/hsqldb-1.8.1.2.ebuild b/dev-db/hsqldb/hsqldb-1.8.1.2.ebuild
index 9e0e8fbf6e7e..8b8b0ebc5e26 100644
--- a/dev-db/hsqldb/hsqldb-1.8.1.2.ebuild
+++ b/dev-db/hsqldb/hsqldb-1.8.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/hsqldb/hsqldb-1.8.1.2.ebuild,v 1.1 2010/03/09 10:31:28 ali_bush Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/hsqldb/hsqldb-1.8.1.2.ebuild,v 1.2 2010/04/05 22:31:38 caster Exp $
EAPI=1
JAVA_PKG_IUSE="doc source test"
@@ -119,15 +119,15 @@ src_install() {
exeinto "${HSQLDB_HOME}/bin"
doexe bin/hsqldb || die
+ # Make sure that files have correct permissions
+ chown -R hsqldb:hsqldb "${D}${HSQLDB_HOME}"
+ chmod o-rwx "${D}${HSQLDB_HOME}"
+
# Create symlinks to authorization files in the server home dir
# (required by the hqldb init script)
insinto "${HSQLDB_HOME}"
dosym /etc/hsqldb/server.properties "${HSQLDB_HOME}/server.properties" || die
dosym /etc/hsqldb/sqltool.rc "${HSQLDB_HOME}/sqltool.rc" || die
-
- # Make sure that files have correct permissions
- chown -R hsqldb:hsqldb "${D}${HSQLDB_HOME}"
- chmod o-rwx "${D}${HSQLDB_HOME}"
}
pkg_postinst() {