summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2004-02-20 02:56:58 +0000
committerRyan Phillips <rphillips@gentoo.org>2004-02-20 02:56:58 +0000
commit9d6961e032d163009d589c8f86b8e24fe2f17170 (patch)
tree923a6b3ce6bfd7a2a82947de989114a6b38d9c40 /dev-db/unixODBC/unixODBC-2.2.8.ebuild
parentadd patch from Frank Eibisch to correct wrapper not to use old options for gc... (diff)
downloadgentoo-2-9d6961e032d163009d589c8f86b8e24fe2f17170.tar.gz
gentoo-2-9d6961e032d163009d589c8f86b8e24fe2f17170.tar.bz2
gentoo-2-9d6961e032d163009d589c8f86b8e24fe2f17170.zip
version bump
Diffstat (limited to 'dev-db/unixODBC/unixODBC-2.2.8.ebuild')
-rw-r--r--dev-db/unixODBC/unixODBC-2.2.8.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/dev-db/unixODBC/unixODBC-2.2.8.ebuild b/dev-db/unixODBC/unixODBC-2.2.8.ebuild
new file mode 100644
index 000000000000..cdd4612dbe49
--- /dev/null
+++ b/dev-db/unixODBC/unixODBC-2.2.8.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.8.ebuild,v 1.1 2004/02/20 02:56:58 rphillips Exp $
+
+DESCRIPTION="ODBC Interface for Linux"
+HOMEPAGE="http://www.unixodbc.org/"
+SRC_URI="http://www.unixodbc.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~hppa ~alpha ~amd64 ~sparc"
+IUSE="qt gnome"
+
+DEPEND="virtual/glibc
+ >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2
+ gnome? ( gnome-base/gnome-libs )
+ qt? ( >=x11-libs/qt-3.0* )"
+
+# the configure.in patch is required for 'use qt'
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+
+# braindead check in configure fails - hack approach
+ epatch ${FILESDIR}/unixODBC-2.2.6-configure.in.patch
+
+ autoconf || die "autoconf failed"
+}
+
+src_compile() {
+ local myconf
+
+ if [ "`use qt`" ]
+ then
+ myconf="--enable-gui=yes"
+ else
+ myconf="--enable-gui=no"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/unixODBC \
+ ${myconf} || die
+
+ make || die
+
+ if [ "`use gnome`" ]
+ then
+ cd gODBCConfig
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/unixODBC \
+ ${myconf} || die
+
+ # not sure why these symlinks are needed. busted configure, i guess...
+ ln -s ../depcomp .
+ ln -s ../libtool .
+ make || die
+ cd ..
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ if [ "`use gnome`" ]
+ then
+ cd gODBCConfig
+ make DESTDIR=${D} install || die
+ cd ..
+ fi
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README*
+ find doc/ -name "Makefile*" -exec rm '{}' \;
+ dohtml doc/*
+ prepalldocs
+}