summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2013-02-06 21:15:21 +0000
committerMichael Haubenwallner <haubi@gentoo.org>2013-02-06 21:15:21 +0000
commitc29d308e0b07aa820770cac693546c2eff6a50bb (patch)
treea4de937e452fbf55efb54d4cc6503aa3333f674c /dev-db/tora
parentVersion bump, drop old (diff)
downloadgentoo-2-c29d308e0b07aa820770cac693546c2eff6a50bb.tar.gz
gentoo-2-c29d308e0b07aa820770cac693546c2eff6a50bb.tar.bz2
gentoo-2-c29d308e0b07aa820770cac693546c2eff6a50bb.zip
Add tora live-svn ebuild, for bug#455498.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key A630CCB8)
Diffstat (limited to 'dev-db/tora')
-rw-r--r--dev-db/tora/ChangeLog10
-rw-r--r--dev-db/tora/files/tora-9999-ext-loki.patch86
-rw-r--r--dev-db/tora/tora-9999.ebuild88
3 files changed, 182 insertions, 2 deletions
diff --git a/dev-db/tora/ChangeLog b/dev-db/tora/ChangeLog
index 788e85d73a56..d88824a6f3eb 100644
--- a/dev-db/tora/ChangeLog
+++ b/dev-db/tora/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/tora
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/ChangeLog,v 1.96 2012/09/30 17:06:35 armin76 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/ChangeLog,v 1.97 2013/02/06 21:15:21 haubi Exp $
+
+*tora-9999 (06 Feb 2013)
+
+ 06 Feb 2013; Michael Haubenwallner <haubi@gentoo.org> +tora-9999.ebuild,
+ +files/tora-9999-ext-loki.patch:
+ Add tora live-svn ebuild, for bug#455498.
30 Sep 2012; Raúl Porcel <armin76@gentoo.org> tora-2.1.1.ebuild,
tora-2.1.3-r1.ebuild:
diff --git a/dev-db/tora/files/tora-9999-ext-loki.patch b/dev-db/tora/files/tora-9999-ext-loki.patch
new file mode 100644
index 000000000000..a6ee2faa1bc7
--- /dev/null
+++ b/dev-db/tora/files/tora-9999-ext-loki.patch
@@ -0,0 +1,86 @@
+diff -Naur tora-2.1.4~/CMakeLists.txt tora-2.1.4/CMakeLists.txt
+--- tora-2.1.4~/CMakeLists.txt 2013-02-04 16:36:35.000000000 +0100
++++ tora-2.1.4/CMakeLists.txt 2013-02-04 17:07:00.084287072 +0100
+@@ -4,6 +4,7 @@
+ # options available for user's input
+ OPTION(WANT_DEBUG "Set the debug build and possible additional outputs" OFF)
+ OPTION(WANT_INTERNAL_QSCINTILLA "Use internal/bundled QScintilla2 source" OFF)
++OPTION(WANT_INTERNAL_LOKI "Use internal/bundled Loki source" OFF)
+ OPTION(ENABLE_ORACLE "Enable/Disable Oracle support at all. Including detection" ON)
+ OPTION(ENABLE_PGSQL "Enable/Disable PostgreSQL support. Including detection" ON)
+ OPTION(ENABLE_DB2 "Enable/Disable DB2 support. Including detection" ON)
+@@ -54,6 +55,7 @@
+ INCLUDE(CheckTypeSize)
+ INCLUDE(TestBigEndian)
+ INCLUDE(FindSubversion)
++INCLUDE(FindPkgConfig)
+
+
+ #Set the custom CMake module directory where our include/lib finders are
+@@ -222,6 +224,10 @@
+ MESSAGE(FATAL_ERROR "No Qt4 found")
+ ENDIF(QT_FOUND)
+
++IF (WANT_INTERNAL_LOKI)
++ELSE (WANT_INTERNAL_LOKI)
++ pkg_check_modules(LOKI REQUIRED ferrisloki)
++ENDIF (WANT_INTERNAL_LOKI)
+
+ IF (WANT_INTERNAL_QSCINTILLA)
+ MESSAGE(STATUS "QSci: Building with internal copy of QScintilla.")
+diff -Naur tora-2.1.4~/src/CMakeLists.txt tora-2.1.4/src/CMakeLists.txt
+--- tora-2.1.4~/src/CMakeLists.txt 2013-02-04 16:36:21.000000000 +0100
++++ tora-2.1.4/src/CMakeLists.txt 2013-02-04 17:06:50.373408475 +0100
+@@ -3,7 +3,10 @@
+
+ #Subdirectories
+ # ADD_SUBDIRECTORY(i18n)
+-ADD_SUBDIRECTORY(loki)
++# Default: loki as 3rd party lib!
++IF (WANT_INTERNAL_LOKI)
++ ADD_SUBDIRECTORY(loki)
++ENDIF(WANT_INTERNAL_LOKI)
+ IF (WIN32)
+ ADD_SUBDIRECTORY(windows)
+ ENDIF (WIN32)
+@@ -497,7 +500,9 @@
+ QT4_ADD_RESOURCES(TORA_RCC_SRCS ${TORA_RCC_FILES})
+
+
+-LINK_DIRECTORIES(./loki)
++IF (WANT_INTERNAL_LOKI)
++ LINK_DIRECTORIES(./loki)
++ENDIF(WANT_INTERNAL_LOKI)
+ IF (WIN32)
+ LINK_DIRECTORIES(./windows)
+ ENDIF (WIN32)
+@@ -506,7 +511,10 @@
+ ENDIF (WANT_INTERNAL_QSCINTILLA)
+
+
+-SET(TORA_LOKI_LIB "tora_loki_lib")
++IF (WANT_INTERNAL_LOKI)
++ SET(LOKI_LIBRARIES "tora_loki_lib")
++ SET(LOKI_INCLUDE_DIRS ${CMAKE_CURRENT_SOURCE_DIR}/loki/include)
++ENDIF(WANT_INTERNAL_LOKI)
+ IF (WANT_INTERNAL_QSCINTILLA)
+ SET (TORA_QSCINTILLA_LIB tora_qscintilla2_lib)
+ ENDIF (WANT_INTERNAL_QSCINTILLA)
+@@ -522,7 +530,7 @@
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${QT_INCLUDES}
+- ${CMAKE_CURRENT_SOURCE_DIR}/loki/include
++ ${LOKI_INCLUDE_DIRS}
+ ${CMAKE_CURRENT_SOURCE_DIR}/otl
+ )
+
+@@ -648,7 +656,7 @@
+ ENDIF(USE_EXPERIMENTAL)
+
+ # static
+-TARGET_LINK_LIBRARIES(${EXE_NAME} ${TORA_LOKI_LIB})
++TARGET_LINK_LIBRARIES(${EXE_NAME} ${LOKI_LIBRARIES})
+ IF (WANT_INTERNAL_QSCINTILLA)
+ TARGET_LINK_LIBRARIES(${EXE_NAME} ${TORA_QSCINTILLA_LIB} ${QT_LIBRARIES})
+ ENDIF (WANT_INTERNAL_QSCINTILLA)
diff --git a/dev-db/tora/tora-9999.ebuild b/dev-db/tora/tora-9999.ebuild
new file mode 100644
index 000000000000..66502d0aa9be
--- /dev/null
+++ b/dev-db/tora/tora-9999.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-9999.ebuild,v 1.1 2013/02/06 21:15:21 haubi Exp $
+
+EAPI=2
+
+inherit cmake-utils eutils
+
+if [[ ${PV} == 9999 ]]; then
+ ESVN_REPO_URI="https://tora.svn.sourceforge.net/svnroot/tora/trunk/tora"
+ inherit subversion
+ SRC_URI=""
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="TOra - Toolkit For Oracle"
+HOMEPAGE="http://tora.sourceforge.net"
+IUSE="debug mysql oracle oci8-instant-client postgres"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS=""
+
+DEPEND="
+ dev-libs/ferrisloki
+ x11-libs/qscintilla
+ x11-libs/qt-gui:4
+ x11-libs/qt-sql:4[mysql?,postgres?]
+ x11-libs/qt-xmlpatterns:4
+ oci8-instant-client? (
+ dev-db/oracle-instantclient-basic
+ dev-db/oracle-instantclient-sqlplus
+ )
+ postgres? ( dev-db/postgresql-server )
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if ( use oracle || use oci8-instant-client ) && [ -z "$ORACLE_HOME" ] ; then
+ eerror "ORACLE_HOME variable is not set."
+ eerror
+ eerror "You must install Oracle >= 8i client for Linux in"
+ eerror "order to compile TOra with Oracle support."
+ eerror
+ eerror "Otherwise specify -oracle in your USE variable."
+ eerror
+ eerror "You can download the Oracle software from"
+ eerror "http://www.oracle.com/technetwork/indexes/downloads/"
+ die
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ext-loki.patch #383109
+ sed -i \
+ -e "/COPYING/ d" \
+ CMakeLists.txt || die "Removal of COPYING file failed"
+ # 'svn info' needs .svn subdirectory
+ [[ ${PV} != 9999 ]] || ln -s "${ESVN_WC_PATH}"/.svn .svn || die
+}
+
+src_configure() {
+ local mycmakeargs=()
+ if use oracle || use oci8-instant-client ; then
+ mycmakeargs=(-DENABLE_ORACLE=ON)
+ else
+ mycmakeargs=(-DENABLE_ORACLE=OFF)
+ fi
+ mycmakeargs+=(
+ -DWANT_RPM=OFF
+ -DWANT_BUNDLE=OFF
+ -DWANT_BUNDLE_STANDALONE=OFF
+ -DWANT_INTERNAL_QSCINTILLA=OFF
+ -DWANT_INTERNAL_LOKI=OFF
+ $(cmake-utils_use_enable postgres PGSQL)
+ $(cmake-utils_use_want debug)
+ # path variables
+ -DTORA_DOC_DIR=share/doc/${PF}
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ doicon src/icons/${PN}.xpm || die
+ domenu debian/${PN}.desktop || die
+}