summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-08-13 10:34:29 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-08-13 10:34:29 +0000
commitbe1f557fce8cf45bcda3de64a389428c110f4c27 (patch)
tree06fd76d07766e81df2dca9969b650373343cd8ca /dev-db/tokyocabinet
parentVersion Bump sat4j-*. (diff)
downloadgentoo-2-be1f557fce8cf45bcda3de64a389428c110f4c27.tar.gz
gentoo-2-be1f557fce8cf45bcda3de64a389428c110f4c27.tar.bz2
gentoo-2-be1f557fce8cf45bcda3de64a389428c110f4c27.zip
Bump, lots of nice fixes by Johan Bergstroem, fixes #331555
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/tokyocabinet')
-rw-r--r--dev-db/tokyocabinet/ChangeLog8
-rw-r--r--dev-db/tokyocabinet/files/1.4.46.patch12
-rw-r--r--dev-db/tokyocabinet/files/remove_docinst.patch13
-rw-r--r--dev-db/tokyocabinet/tokyocabinet-1.4.46.ebuild48
4 files changed, 80 insertions, 1 deletions
diff --git a/dev-db/tokyocabinet/ChangeLog b/dev-db/tokyocabinet/ChangeLog
index f8f7438006b8..716f208f3b70 100644
--- a/dev-db/tokyocabinet/ChangeLog
+++ b/dev-db/tokyocabinet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/tokyocabinet
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tokyocabinet/ChangeLog,v 1.25 2010/06/02 10:55:17 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tokyocabinet/ChangeLog,v 1.26 2010/08/13 10:34:29 patrick Exp $
+
+*tokyocabinet-1.4.46 (13 Aug 2010)
+
+ 13 Aug 2010; Patrick Lauer <patrick@gentoo.org> +files/1.4.46.patch,
+ +tokyocabinet-1.4.46.ebuild, +files/remove_docinst.patch:
+ Bump, lots of nice fixes by Johan Bergstroem, fixes #331555
*tokyocabinet-1.4.45 (02 Jun 2010)
diff --git a/dev-db/tokyocabinet/files/1.4.46.patch b/dev-db/tokyocabinet/files/1.4.46.patch
new file mode 100644
index 000000000000..4814e95fb72d
--- /dev/null
+++ b/dev-db/tokyocabinet/files/1.4.46.patch
@@ -0,0 +1,12 @@
+diff --git a/Makefile.in b/Makefile.in
+index 8846c38..01caa50 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -125,7 +125,6 @@ install :
+ cd man && cp -Rf $(MAN3FILES) $(DESTDIR)$(MAN3DIR)
+ mkdir -p $(DESTDIR)$(PCDIR)
+ cp -Rf $(PCFILES) $(DESTDIR)$(PCDIR)
+- -[ "$$UID" = 0 ] && PATH=/sbin:/usr/sbin:$(PATH) ldconfig 2>/dev/null || true
+ @printf '\n'
+ @printf '#================================================================\n'
+ @printf '# Thanks for using Tokyo Cabinet.\n'
diff --git a/dev-db/tokyocabinet/files/remove_docinst.patch b/dev-db/tokyocabinet/files/remove_docinst.patch
new file mode 100644
index 000000000000..d513f54b753c
--- /dev/null
+++ b/dev-db/tokyocabinet/files/remove_docinst.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile.in b/Makefile.in
+index 8846c38..29ac11e 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -117,8 +117,6 @@ install :
+ cp -Rf $(COMMANDFILES) $(DESTDIR)$(BINDIR)
+ mkdir -p $(DESTDIR)$(LIBEXECDIR)
+ cp -Rf $(CGIFILES) $(DESTDIR)$(LIBEXECDIR)
+- mkdir -p $(DESTDIR)$(DATADIR)
+- cp -Rf $(DOCUMENTFILES) $(DESTDIR)$(DATADIR)
+ mkdir -p $(DESTDIR)$(MAN1DIR)
+ cd man && cp -Rf $(MAN1FILES) $(DESTDIR)$(MAN1DIR)
+ mkdir -p $(DESTDIR)$(MAN3DIR)
diff --git a/dev-db/tokyocabinet/tokyocabinet-1.4.46.ebuild b/dev-db/tokyocabinet/tokyocabinet-1.4.46.ebuild
new file mode 100644
index 000000000000..50f6dd04cde1
--- /dev/null
+++ b/dev-db/tokyocabinet/tokyocabinet-1.4.46.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tokyocabinet/tokyocabinet-1.4.46.ebuild,v 1.1 2010/08/13 10:34:29 patrick Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A library of routines for managing a database"
+HOMEPAGE="http://fallabs.com/tokyocabinet/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="debug doc examples"
+
+DEPEND="sys-libs/zlib
+ app-arch/bzip2"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/fix_rpath.patch"
+ epatch "${FILESDIR}/${PV}.patch"
+ epatch "${FILESDIR}/remove_docinst.patch"
+}
+
+src_configure() {
+ econf $(use_enable debug) --enable-off64
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ if use examples; then
+ insinto /usr/share/${PF}/example
+ doins example/* || die "Install failed"
+ fi
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r doc/* || die "Install failed"
+ fi
+}
+
+src_test() {
+ emake -j1 check || die "Tests failed"
+}