summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-01-30 04:23:26 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-01-30 04:23:26 +0000
commit3fcea5acc6c06cdbc40106f37bef2d36f5a59cdc (patch)
tree0dac26544d82156367874e8b3da4577375c6b6ba /dev-db/sqliteodbc
parentChange file order in patch to match equivalent 1.6.13 patch. (diff)
downloadgentoo-2-3fcea5acc6c06cdbc40106f37bef2d36f5a59cdc.tar.gz
gentoo-2-3fcea5acc6c06cdbc40106f37bef2d36f5a59cdc.tar.bz2
gentoo-2-3fcea5acc6c06cdbc40106f37bef2d36f5a59cdc.zip
Bump
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-db/sqliteodbc')
-rw-r--r--dev-db/sqliteodbc/ChangeLog9
-rw-r--r--dev-db/sqliteodbc/sqliteodbc-0.99.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/dev-db/sqliteodbc/ChangeLog b/dev-db/sqliteodbc/ChangeLog
index 245dce5d5350..e3b487601913 100644
--- a/dev-db/sqliteodbc/ChangeLog
+++ b/dev-db/sqliteodbc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/sqliteodbc
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqliteodbc/ChangeLog,v 1.34 2012/09/09 16:23:42 kensington Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqliteodbc/ChangeLog,v 1.35 2013/01/30 04:23:26 patrick Exp $
+
+*sqliteodbc-0.99 (30 Jan 2013)
+
+ 30 Jan 2013; Patrick Lauer <patrick@gentoo.org> +sqliteodbc-0.99.ebuild:
+ Bump
09 Sep 2012; Michael Palimaka <kensington@gentoo.org>
-files/sqliteodbc-0.83-respect_LDFLAGS.patch, -sqliteodbc-0.87.ebuild,
diff --git a/dev-db/sqliteodbc/sqliteodbc-0.99.ebuild b/dev-db/sqliteodbc/sqliteodbc-0.99.ebuild
new file mode 100644
index 000000000000..8e82024df33c
--- /dev/null
+++ b/dev-db/sqliteodbc/sqliteodbc-0.99.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqliteodbc/sqliteodbc-0.99.ebuild,v 1.1 2013/01/30 04:23:26 patrick Exp $
+
+EAPI=4
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="ODBC driver to access local SQLite database files."
+HOMEPAGE="http://www.ch-werner.de/sqliteodbc/"
+SRC_URI="http://www.ch-werner.de/sqliteodbc/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-db/sqlite-3.6
+ || (
+ >=dev-db/unixODBC-2.2
+ >=dev-db/libiodbc-3.5
+ )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.93-respect_LDFLAGS.patch"
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ dodir "/usr/$(get_libdir)"
+ einstall
+ find "${D}" -name '*.la' -exec rm -f {} + || die "la file removal failed"
+ dodoc ChangeLog README
+}