summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTal Peer <coredumb@gentoo.org>2004-03-16 11:28:25 +0000
committerTal Peer <coredumb@gentoo.org>2004-03-16 11:28:25 +0000
commit363ef8161f2a67309773f3566fc4f051b39996f0 (patch)
tree2b3d7f803c1f4aeb5d31a5a121b42b7080dd8692 /dev-db/sqlite
parentAdd 2.6.5-rc1. (Manifest recommit) (diff)
downloadgentoo-2-363ef8161f2a67309773f3566fc4f051b39996f0.tar.gz
gentoo-2-363ef8161f2a67309773f3566fc4f051b39996f0.tar.bz2
gentoo-2-363ef8161f2a67309773f3566fc4f051b39996f0.zip
Version bump
Diffstat (limited to 'dev-db/sqlite')
-rw-r--r--dev-db/sqlite/ChangeLog7
-rw-r--r--dev-db/sqlite/files/digest-sqlite-2.8.131
-rw-r--r--dev-db/sqlite/sqlite-2.8.13.ebuild36
3 files changed, 43 insertions, 1 deletions
diff --git a/dev-db/sqlite/ChangeLog b/dev-db/sqlite/ChangeLog
index 0fb512590664..b35ab25d6fcb 100644
--- a/dev-db/sqlite/ChangeLog
+++ b/dev-db/sqlite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/sqlite
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.24 2004/03/05 18:47:50 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.25 2004/03/16 11:28:25 coredumb Exp $
+
+*sqlite-2.8.13 (16 Mar 2004)
+
+ 16 Mar 2004; Tal Peer <coredumb@gentoo.org> sqlite-2.8.13.ebuild:
+ Version bump.
05 Mar 2004; <agriffis@gentoo.org> sqlite-2.8.11.ebuild,
sqlite-2.8.12.ebuild:
diff --git a/dev-db/sqlite/files/digest-sqlite-2.8.13 b/dev-db/sqlite/files/digest-sqlite-2.8.13
new file mode 100644
index 000000000000..046ad1f4d699
--- /dev/null
+++ b/dev-db/sqlite/files/digest-sqlite-2.8.13
@@ -0,0 +1 @@
+MD5 628fa52b5580b38ade75985dd4ba46dd sqlite-2.8.13.tar.gz 956008
diff --git a/dev-db/sqlite/sqlite-2.8.13.ebuild b/dev-db/sqlite/sqlite-2.8.13.ebuild
new file mode 100644
index 000000000000..141f2ab45b98
--- /dev/null
+++ b/dev-db/sqlite/sqlite-2.8.13.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-2.8.13.ebuild,v 1.1 2004/03/16 11:28:25 coredumb Exp $
+
+IUSE="nls"
+
+S=${WORKDIR}/sqlite
+DESCRIPTION="SQLite: An SQL Database Engine in a C Library."
+SRC_URI="http://www.sqlite.org/${P}.tar.gz"
+HOMEPAGE="http://www.sqlite.org"
+DEPEND="virtual/glibc
+ dev-lang/tcl"
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa"
+
+src_compile() {
+ local myconf
+ myconf="--enable-incore-db --enable-tempdb-in-ram"
+ myconf="${myconf} `use_with nls utf8`"
+ econf ${myconf} || die
+ emake all doc || die
+}
+
+src_install () {
+ dodir /usr/{bin,include,lib}
+
+ einstall || die
+
+ dobin lemon
+ dodoc README VERSION
+ doman sqlite.1
+ docinto html
+ dohtml doc/*.html doc/*.txt doc/*.png
+}
+