summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-07-05 08:41:51 +0000
committerIan Delaney <idella4@gentoo.org>2014-07-05 08:41:51 +0000
commitf9651cb00fd92961a98f1855472a088e64fba8d6 (patch)
treea0ad4a1ac0b6f3db210ca49a07c7f5b8e945a397 /dev-db/pgxnclient/pgxnclient-1.2-r1.ebuild
parentFix bug #515552 - Bump android studio to 0.8.1.135.1248636, thanks to C.J. Wi... (diff)
downloadgentoo-2-f9651cb00fd92961a98f1855472a088e64fba8d6.tar.gz
gentoo-2-f9651cb00fd92961a98f1855472a088e64fba8d6.tar.bz2
gentoo-2-f9651cb00fd92961a98f1855472a088e64fba8d6.zip
revbump; conversion -> distutils-r1, add missing dep setuptools, add test phase, remove old, fixes Bug 515020
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-db/pgxnclient/pgxnclient-1.2-r1.ebuild')
-rw-r--r--dev-db/pgxnclient/pgxnclient-1.2-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-db/pgxnclient/pgxnclient-1.2-r1.ebuild b/dev-db/pgxnclient/pgxnclient-1.2-r1.ebuild
new file mode 100644
index 000000000000..320eca8f892e
--- /dev/null
+++ b/dev-db/pgxnclient/pgxnclient-1.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgxnclient/pgxnclient-1.2-r1.ebuild,v 1.1 2014/07/05 08:41:51 idella4 Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="PostgreSQL Extension Network Client"
+HOMEPAGE="http://pgxnclient.projects.postgresql.org/ http://pypi.python.org/pypi/${PN}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=dev-db/postgresql-server-9.1"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ # suite written onlt for py2
+ pushd ${PN} > /dev/null
+ if ! python_is_python3; then
+ PYTHONPATH=../ "${PYTHON}" -m unittest discover || die "tests failed"
+ fi
+ popd > dev/null
+}