summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2012-11-08 11:15:01 +0000
committerAaron W. Swenson <titanofold@gentoo.org>2012-11-08 11:15:01 +0000
commit04e9b3a50e3572081c204b48c5e8e9252157fd25 (patch)
treeb125eddf419f389de7fe7a15b32eb77fe8eebb7f /dev-db/pgadmin3
parentAdd patch from pld-linux to build with latest ffmpeg releases. bug #435856 (diff)
downloadgentoo-2-04e9b3a50e3572081c204b48c5e8e9252157fd25.tar.gz
gentoo-2-04e9b3a50e3572081c204b48c5e8e9252157fd25.tar.bz2
gentoo-2-04e9b3a50e3572081c204b48c5e8e9252157fd25.zip
Version bump fixes bug 434994.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/pgadmin3')
-rw-r--r--dev-db/pgadmin3/ChangeLog7
-rw-r--r--dev-db/pgadmin3/pgadmin3-1.16.0.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-db/pgadmin3/ChangeLog b/dev-db/pgadmin3/ChangeLog
index cebafdb864e5..fb3fa8bb1256 100644
--- a/dev-db/pgadmin3/ChangeLog
+++ b/dev-db/pgadmin3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/pgadmin3
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/ChangeLog,v 1.86 2012/09/12 13:47:33 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/ChangeLog,v 1.87 2012/11/08 11:15:01 titanofold Exp $
+
+*pgadmin3-1.16.0 (08 Nov 2012)
+
+ 08 Nov 2012; <titan@gentoo.org> +pgadmin3-1.16.0.ebuild:
+ Version bump fixes bug 434994.
12 Sep 2012; Johannes Huber <johu@gentoo.org> pgadmin3-1.14.3.ebuild:
Stable for x86, wrt bug #428924
diff --git a/dev-db/pgadmin3/pgadmin3-1.16.0.ebuild b/dev-db/pgadmin3/pgadmin3-1.16.0.ebuild
new file mode 100644
index 000000000000..af4bb9a73c19
--- /dev/null
+++ b/dev-db/pgadmin3/pgadmin3-1.16.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/pgadmin3-1.16.0.ebuild,v 1.1 2012/11/08 11:15:01 titanofold Exp $
+
+EAPI="4"
+
+WX_GTK_VER="2.8"
+
+inherit multilib versionator wxwidgets
+
+DESCRIPTION="wxWidgets GUI for PostgreSQL."
+HOMEPAGE="http://www.pgadmin.org/"
+SRC_URI="mirror://postgresql/${PN}/release/v${PV}/src/${P}.tar.gz"
+
+LICENSE="POSTGRESQL"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="x11-libs/wxGTK:2.8[X,debug=]
+ >=dev-db/postgresql-base-8.4.0
+ >=dev-libs/libxml2-2.6.18
+ >=dev-libs/libxslt-1.1"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ local pgslot=$(postgresql-config show)
+
+ if [[ ${pgslot//.} < 84 ]] ; then
+ eerror "PostgreSQL slot must be set to 8.4 or higher."
+ eerror " postgresql-config set 8.4"
+ die "PostgreSQL slot is not set to 8.4 or higher."
+ fi
+}
+
+src_configure() {
+ econf --with-wx-version=2.8 \
+ $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newicon "${S}/pgadmin/include/images/pgAdmin3.png" ${PN}.png
+
+ # icon location for the desktop file provided in pkg folder
+ insinto /usr/share/pgadmin3
+ doins "${S}/pgadmin/include/images/pgAdmin3.png"
+
+ domenu "${S}/pkg/pgadmin3.desktop"
+
+ # Fixing world-writable files
+ fperms -R go-w /usr/share
+}