summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2004-09-23 19:32:44 +0000
committerMasatomo Nakano <nakano@gentoo.org>2004-09-23 19:32:44 +0000
commite1d764447c994f8f8ffcda7c92eefad85661e940 (patch)
tree125f9f8e5a146ec17b53e22c80488b50ff7d57bf /dev-db/pgaccess
parentMasked eclipse 3.1 M1 and newer (diff)
downloadgentoo-2-e1d764447c994f8f8ffcda7c92eefad85661e940.tar.gz
gentoo-2-e1d764447c994f8f8ffcda7c92eefad85661e940.tar.bz2
gentoo-2-e1d764447c994f8f8ffcda7c92eefad85661e940.zip
Version bump.
Diffstat (limited to 'dev-db/pgaccess')
-rw-r--r--dev-db/pgaccess/ChangeLog8
-rw-r--r--dev-db/pgaccess/files/digest-pgaccess-0.99.0.200402191
-rw-r--r--dev-db/pgaccess/files/pgaccess-0.99.0.20040219.patch23
-rw-r--r--dev-db/pgaccess/pgaccess-0.99.0.20040219.ebuild47
4 files changed, 78 insertions, 1 deletions
diff --git a/dev-db/pgaccess/ChangeLog b/dev-db/pgaccess/ChangeLog
index fe50cfc96394..5bd3bb6ab6c6 100644
--- a/dev-db/pgaccess/ChangeLog
+++ b/dev-db/pgaccess/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/pgaccess
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgaccess/ChangeLog,v 1.8 2004/09/03 00:45:10 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgaccess/ChangeLog,v 1.9 2004/09/23 19:32:44 nakano Exp $
+
+*pgaccess-0.99.0.20040219 (23 Sep 2004)
+
+ 23 Sep 2004; Masatomo Nakano <nakano@gentoo.org>
+ +files/pgaccess-0.99.0.20040219.patch, +pgaccess-0.99.0.20040219.ebuild:
+ Version bump. Ebuild submitted by Daniel Black <dragonheart@gentoo.org>.
03 Sep 2004; David Holm <dholm@gentoo.org> pgaccess-0.98.8.ebuild:
Added to ~ppc.
diff --git a/dev-db/pgaccess/files/digest-pgaccess-0.99.0.20040219 b/dev-db/pgaccess/files/digest-pgaccess-0.99.0.20040219
new file mode 100644
index 000000000000..3d95229a4795
--- /dev/null
+++ b/dev-db/pgaccess/files/digest-pgaccess-0.99.0.20040219
@@ -0,0 +1 @@
+MD5 5440a130da909368a7274ac6f4578039 pgaccess-0_99_0_20040219.tgz 1457184
diff --git a/dev-db/pgaccess/files/pgaccess-0.99.0.20040219.patch b/dev-db/pgaccess/files/pgaccess-0.99.0.20040219.patch
new file mode 100644
index 000000000000..8141ba848ad1
--- /dev/null
+++ b/dev-db/pgaccess/files/pgaccess-0.99.0.20040219.patch
@@ -0,0 +1,23 @@
+--- Makefile.orig 2003-05-23 05:32:53.000000000 +0930
++++ Makefile 2004-09-18 23:42:47.583843792 +0930
+@@ -7,15 +7,16 @@
+ #
+ #-------------------------------------------------------------------------
+
+-bindir = /usr/bin/X11
+-libdir = /usr/lib
++bindir = $(prefix)/usr/X11R6/bin
++libdir = $(prefix)/usr/lib
+ wish = /usr/bin/wish
+
+ pgaccess:
+ chmod a+x pgaccess.tcl
+- mkdir -p $(libdir)/pgaccess
++ [ -d $(libdir)/pgaccess ] || mkdir -p $(libdir)/pgaccess
+ cp -R * $(libdir)/pgaccess
+- ln -sf $(libdir)/pgaccess/pgaccess.tcl $(bindir)/pgaccess
++ [ -d $(bindir) ] || mkdir -p $(bindir)
++ cd $(bindir) && ln -sf /usr/lib/pgaccess/pgaccess.tcl pgaccess
+
+ all: pgaccess
+
diff --git a/dev-db/pgaccess/pgaccess-0.99.0.20040219.ebuild b/dev-db/pgaccess/pgaccess-0.99.0.20040219.ebuild
new file mode 100644
index 000000000000..6b7383367d90
--- /dev/null
+++ b/dev-db/pgaccess/pgaccess-0.99.0.20040219.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgaccess/pgaccess-0.99.0.20040219.ebuild,v 1.1 2004/09/23 19:32:44 nakano Exp $
+
+inherit eutils
+
+MY_P=${P//./_}
+
+DESCRIPTION="a database frontend for postgresql"
+HOMEPAGE="http://www.pgaccess.org/"
+SRC_URI="mirror://sourceforge/pgaccess/${MY_P}.tgz"
+LICENSE="POSTGRESQL"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+DEPEND="virtual/libc"
+
+RDEPEND=">=dev-lang/tcl-8.3.4
+ >=dev-lang/tk-8.3.4
+ >=dev-db/postgresql-7.3
+ dev-tcltk/tcllib"
+
+
+src_compile() {
+ cd ${S}
+ epatch ${FILESDIR}/${P}.patch
+}
+
+src_install() {
+ make prefix=${D} install || die
+ rm -rf ${D}/usr/lib/pgaccess/win32 \
+ ${D}/usr/lib/pgaccess/Makefile
+ rm -rf ${D}/usr/lib/pgaccess/osx
+ dodir /usr/share/doc/${PF}
+ mv ${D}/usr/lib/pgaccess/{README,changelog,copyright,demo,doc/html,todo} ${D}/usr/share/doc/${PF}
+ rmdir ${D}/usr/lib/pgaccess/doc
+}
+
+pkg_postinst() {
+ einfo "When running the program, if you encount the error "
+ einfo "\"Error: Shared library file: '/usr/lib/libpgtcl.so' does not exist.\","
+ einfo "you need to emerge postgresql with USE='tcltk' again"
+}