summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-09-20 06:46:56 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-09-20 06:46:56 +0000
commitd01f93028d2c5c65117387caad7cfcdd13c8a8d2 (patch)
tree793adb7ab97dfd041abe5c40130c08591257dee4 /dev-db/pg_top
parentVersion bump. (diff)
downloadgentoo-2-d01f93028d2c5c65117387caad7cfcdd13c8a8d2.tar.gz
gentoo-2-d01f93028d2c5c65117387caad7cfcdd13c8a8d2.tar.bz2
gentoo-2-d01f93028d2c5c65117387caad7cfcdd13c8a8d2.zip
Revision bump: EAPI 5, migrate to autotools-utils eclass. Respect CFLAGS, wrt bug #427882, thanks to Diego Elio Pettenò for discovering this issue and Gabriel Homeier for providing patch. Drop old revision
(Portage version: 2.2.2/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'dev-db/pg_top')
-rw-r--r--dev-db/pg_top/ChangeLog10
-rw-r--r--dev-db/pg_top/files/pg_top-3.6.2.patch17
-rw-r--r--dev-db/pg_top/pg_top-3.6.2-r1.ebuild31
-rw-r--r--dev-db/pg_top/pg_top-3.6.2.ebuild37
4 files changed, 51 insertions, 44 deletions
diff --git a/dev-db/pg_top/ChangeLog b/dev-db/pg_top/ChangeLog
index a13629e46fa5..29b3fb107be8 100644
--- a/dev-db/pg_top/ChangeLog
+++ b/dev-db/pg_top/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-db/pg_top
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pg_top/ChangeLog,v 1.7 2013/06/01 12:10:31 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pg_top/ChangeLog,v 1.8 2013/09/20 06:46:56 pinkbyte Exp $
+
+*pg_top-3.6.2-r1 (20 Sep 2013)
+
+ 20 Sep 2013; Sergey Popov <pinkbyte@gentoo.org> -pg_top-3.6.2.ebuild,
+ +pg_top-3.6.2-r1.ebuild, files/pg_top-3.6.2.patch:
+ Revision bump: EAPI 5, migrate to autotools-utils eclass. Respect CFLAGS, wrt
+ bug #427882, thanks to Diego Elio Pettenò for discovering this issue and
+ Gabriel Homeier for providing patch. Drop old revision
01 Jun 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due bug #151880
diff --git a/dev-db/pg_top/files/pg_top-3.6.2.patch b/dev-db/pg_top/files/pg_top-3.6.2.patch
index 0d4e82fe26a6..03ef912ed2b8 100644
--- a/dev-db/pg_top/files/pg_top-3.6.2.patch
+++ b/dev-db/pg_top/files/pg_top-3.6.2.patch
@@ -1,6 +1,5 @@
-diff -ru pg_top-3.6.2~/configure.ac pg_top-3.6.2/configure.ac
---- pg_top-3.6.2~/configure.ac 2008-12-21 14:43:47.000000000 +0100
-+++ pg_top-3.6.2/configure.ac 2008-12-21 14:44:21.000000000 +0100
+--- configure.ac.orig 2013-09-20 10:11:20.256444684 +0400
++++ configure.ac 2013-09-20 10:16:30.262459612 +0400
@@ -90,7 +90,7 @@
DBCFLAGS="-I$INCLUDEDIR"
@@ -19,6 +18,12 @@ diff -ru pg_top-3.6.2~/configure.ac pg_top-3.6.2/configure.ac
# check for libraries required by extension
extlibs=""
if test -n "$with_ext" -a -f "${srcdir}/ext/$with_ext.libs"; then
-Only in pg_top-3.6.2~: .configure.ac.swp
-Only in pg_top-3.6.2~: .configure.swp
-Only in pg_top-3.6.2~: .Makefile.am.swp
+@@ -216,8 +218,6 @@
+ AC_SUBST(SRC)
+ AC_SUBST(OBJ)
+
+-CFLAGS="-Wall -g"
+-
+ AC_MSG_CHECKING(for installation settings)
+ # calculate appropriate settings
+ OWNER=""
diff --git a/dev-db/pg_top/pg_top-3.6.2-r1.ebuild b/dev-db/pg_top/pg_top-3.6.2-r1.ebuild
new file mode 100644
index 000000000000..1388ae2010ed
--- /dev/null
+++ b/dev-db/pg_top/pg_top-3.6.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pg_top/pg_top-3.6.2-r1.ebuild,v 1.1 2013/09/20 06:46:56 pinkbyte Exp $
+
+EAPI="5"
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils eutils
+
+DESCRIPTION="'top' for PostgreSQL"
+HOMEPAGE="http://ptop.projects.postgresql.org/"
+SRC_URI="http://pgfoundry.org/frs/download.php/1780/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="dev-db/postgresql-base"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( FAQ HISTORY README TODO Y2K )
+PATCHES=( "${FILESDIR}/${P}.patch" )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ )
+ autotools-utils_src_configure
+}
diff --git a/dev-db/pg_top/pg_top-3.6.2.ebuild b/dev-db/pg_top/pg_top-3.6.2.ebuild
deleted file mode 100644
index aebef88a8721..000000000000
--- a/dev-db/pg_top/pg_top-3.6.2.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pg_top/pg_top-3.6.2.ebuild,v 1.6 2012/05/03 02:33:10 jdhore Exp $
-
-inherit eutils autotools
-
-DESCRIPTION="'top' for PostgreSQL"
-HOMEPAGE="http://ptop.projects.postgresql.org/"
-SRC_URI="http://pgfoundry.org/frs/download.php/1780/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug"
-
-COMMON_DEPEND="dev-db/postgresql-base"
-DEPEND="$COMMON_DEPEND
- virtual/pkgconfig"
-RDEPEND="$COMMON_DEPEND"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${P}.patch"
- eautoreconf
-}
-
-src_compile() {
- econf $(use_enable debug)
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc FAQ HISTORY README TODO Y2K
-}