summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2006-01-07 22:34:37 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2006-01-07 22:34:37 +0000
commit335ae5dbaa3725b297e635e995363086b27d9d28 (patch)
treee70743ec4ec37202c446fe6835dd1302a0d16812 /dev-db/oracle-instantclient-basic/oracle-instantclient-basic-10.2.0.1.ebuild
parent1.1.0 version bump. Ported existing patches, added gcc-4.1 patch. It should f... (diff)
downloadgentoo-2-335ae5dbaa3725b297e635e995363086b27d9d28.tar.gz
gentoo-2-335ae5dbaa3725b297e635e995363086b27d9d28.tar.bz2
gentoo-2-335ae5dbaa3725b297e635e995363086b27d9d28.zip
Bump to new upstream version, bug #102171
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'dev-db/oracle-instantclient-basic/oracle-instantclient-basic-10.2.0.1.ebuild')
-rw-r--r--dev-db/oracle-instantclient-basic/oracle-instantclient-basic-10.2.0.1.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/dev-db/oracle-instantclient-basic/oracle-instantclient-basic-10.2.0.1.ebuild b/dev-db/oracle-instantclient-basic/oracle-instantclient-basic-10.2.0.1.ebuild
new file mode 100644
index 000000000000..7f9fe9843a8b
--- /dev/null
+++ b/dev-db/oracle-instantclient-basic/oracle-instantclient-basic-10.2.0.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-basic/oracle-instantclient-basic-10.2.0.1.ebuild,v 1.1 2006/01/07 22:31:35 dertobi123 Exp $
+
+inherit eutils
+
+MY_P="${PN/oracle-/}-linux32-${PV}-20050713"
+MY_PSDK="${MY_P/basic/sdk}"
+
+S=${WORKDIR}
+DESCRIPTION="Oracle 10g client installation for Linux with SDK"
+HOMEPAGE="http://otn.oracle.com/software/tech/oci/instantclient/htdocs/linuxsoft.html"
+SRC_URI="${MY_P}.zip ${MY_PSDK}.zip"
+
+LICENSE="OTN"
+SLOT="${KV}"
+KEYWORDS="~x86"
+RESTRICT="fetch"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+# RDEPEND does not needs unzip
+
+pkg_nofetch() {
+ eerror "Please go to:"
+ eerror " ${HOMEPAGE}"
+ eerror "and download the Basic client package with SDK, which are:"
+ eerror " ${MY_P}.zip"
+ eerror " ${MY_PSDK}.zip"
+ eerror "Then after downloading put them in:"
+ eerror " ${DISTDIR}"
+}
+
+src_unpack() {
+ unzip ${DISTDIR}/${MY_P}.zip || die "unsuccesful unzip ${MY_P}.zip"
+ unzip ${DISTDIR}/${MY_PSDK}.zip || die "unsuccesful unzip ${MY_PSDK}.zip"
+}
+
+src_install() {
+ # library
+ dodir /usr/lib/oracle/${PV}/client/lib
+ cd ${S}/instantclient_10_2
+ insinto /usr/lib/oracle/${PV}/client/lib
+ doins *.jar *.so *.so.10.1
+
+ # fixes symlinks
+ dosym /usr/lib/oracle/${PV}/client/lib/libocci.so.10.1 /usr/lib/oracle/${PV}/client/lib/libocci.so
+ dosym /usr/lib/oracle/${PV}/client/lib/libclntsh.so.10.1 /usr/lib/oracle/${PV}/client/lib/libclntsh.so
+
+ # includes
+ dodir /usr/lib/oracle/${PV}/client/include
+ insinto /usr/lib/oracle/${PV}/client/include
+ cd ${S}/instantclient_10_2/sdk/include
+ doins *.h
+ # link to original location
+ dodir /usr/include/oracle/${PV}/
+ ln -s ${D}/usr/lib/oracle/${PV}/client/include ${D}/usr/include/oracle/${PV}/client
+
+ # share info
+ cd ${S}/instantclient_10_2/sdk/demo
+ dodoc *
+
+ # Add OCI libs to library path
+ dodir /etc/env.d
+ echo "ORACLE_HOME=/usr/lib/oracle/${PV}/client" >> ${D}/etc/env.d/50oracle-instantclient-basic
+ echo "LDPATH=/usr/lib/oracle/${PV}/client/lib" >> ${D}/etc/env.d/50oracle-instantclient-basic
+ echo "C_INCLUDE_PATH=/usr/lib/oracle/${PV}/client/include" >> ${D}/etc/env.d/50oracle-instantclient-basic
+
+}
+
+pkg_postinst() {
+ einfo "The Basic client page for Oracle 10g has been installed."
+ einfo "You may also wish to install the oracle-instantclient-jdbc (for"
+ einfo "supplemental JDBC functionality with Oracle) and the"
+ einfo "oracle-instantclient-sqlplus (for running the SQL*Plus application)"
+ einfo "packages as well."
+ einfo
+ einfo "Examples are located in /usr/share/doc/${PF}/"
+ einfo
+ ewarn "ORACLE_HOME (and others) are set in /etc/env.d/50oracle-instantclient-basic"
+}