summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrancesco Riosa <vivo@gentoo.org>2006-12-10 00:34:04 +0000
committerFrancesco Riosa <vivo@gentoo.org>2006-12-10 00:34:04 +0000
commit7c40dcfb0bbf5afbf6a5d588e2c3805ff4c90ced (patch)
tree2bc7299d9a319948cfbeed93ad1a6ec0e027c33a /dev-db/mysql-community
parentAdd ~x86-fbsd keyword (diff)
downloadgentoo-2-7c40dcfb0bbf5afbf6a5d588e2c3805ff4c90ced.tar.gz
gentoo-2-7c40dcfb0bbf5afbf6a5d588e2c3805ff4c90ced.tar.bz2
gentoo-2-7c40dcfb0bbf5afbf6a5d588e2c3805ff4c90ced.zip
version bump
(Portage version: 2.1.2_rc2-r5)
Diffstat (limited to 'dev-db/mysql-community')
-rw-r--r--dev-db/mysql-community/ChangeLog8
-rw-r--r--dev-db/mysql-community/files/digest-mysql-community-5.1.14_beta3
-rw-r--r--dev-db/mysql-community/mysql-community-5.1.14_beta.ebuild38
3 files changed, 48 insertions, 1 deletions
diff --git a/dev-db/mysql-community/ChangeLog b/dev-db/mysql-community/ChangeLog
index 14cd10f81a29..2c3d19894d11 100644
--- a/dev-db/mysql-community/ChangeLog
+++ b/dev-db/mysql-community/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/mysql-community
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-community/ChangeLog,v 1.5 2006/12/09 22:38:54 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-community/ChangeLog,v 1.6 2006/12/10 00:34:04 vivo Exp $
+
+*mysql-community-5.1.14_beta (10 Dec 2006)
+
+ 10 Dec 2006; Francesco Riosa <vivo@gentoo.org>
+ +mysql-community-5.1.14_beta.ebuild:
+ version bump
09 Dec 2006; Francesco Riosa <vivo@gentoo.org>
mysql-community-5.0.27.ebuild,
diff --git a/dev-db/mysql-community/files/digest-mysql-community-5.1.14_beta b/dev-db/mysql-community/files/digest-mysql-community-5.1.14_beta
new file mode 100644
index 000000000000..c6ef2da2aa85
--- /dev/null
+++ b/dev-db/mysql-community/files/digest-mysql-community-5.1.14_beta
@@ -0,0 +1,3 @@
+MD5 f02115e98c99558e062adcf2dc305283 mysql-5.1.14-beta.tar.gz 23640648
+RMD160 2acaa1393967a6fd57f9c37f3eef8dac62eb7138 mysql-5.1.14-beta.tar.gz 23640648
+SHA256 6b4990a784169560fd487d24c69efba1f73662500d0d3132375d8b5cd026bb67 mysql-5.1.14-beta.tar.gz 23640648
diff --git a/dev-db/mysql-community/mysql-community-5.1.14_beta.ebuild b/dev-db/mysql-community/mysql-community-5.1.14_beta.ebuild
new file mode 100644
index 000000000000..f0e435aa6331
--- /dev/null
+++ b/dev-db/mysql-community/mysql-community-5.1.14_beta.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-community/mysql-community-5.1.14_beta.ebuild,v 1.1 2006/12/10 00:34:04 vivo Exp $
+
+# Leave this empty
+MYSQL_VERSION_ID=""
+MYSQL_RERELEASE=""
+# Set the patchset revision to use, must be either empty or a decimal number
+MYSQL_PATCHSET_REV=""
+BASE_URI="mirror://mysql/Downloads/MySQL-${PV%.*}"
+
+inherit mysql
+
+#REMEMBER!!!: update also eclass/mysql*.eclass prior to commit
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+src_test() {
+ cd "${S}"
+ einfo ">>> Test phase [check]: ${CATEGORY}/${PF}"
+ make check || die "make check failed"
+ if ! useq "minimal" ; then
+ einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ local retstatus
+ addpredict /this-dir-does-not-exist/t9.MYI
+
+ cd mysql-test
+ sed -i -e "s|PORT=3306|PORT=3307|g" mysql-test-run
+ ./mysql-test-run
+ retstatus=$?
+
+ # Just to be sure ;)
+ pkill -9 -f "${S}/ndb" 2>/dev/null
+ pkill -9 -f "${S}/sql" 2>/dev/null
+ [[ $retstatus -eq 0 ]] || die "make test failed"
+ else
+ einfo "Skipping server tests due to minimal build."
+ fi
+}