summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-02-19 21:55:11 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-02-19 21:55:11 +0000
commit211c77419e2ccdeef87830fa0edebf28de031d9d (patch)
tree626743e2ea313e3029c45d78a6078462b05a3b24 /dev-db/libodbc++
parentBug #282982: version bump. Upstream build system has lots of bugs however, so... (diff)
downloadgentoo-2-211c77419e2ccdeef87830fa0edebf28de031d9d.tar.gz
gentoo-2-211c77419e2ccdeef87830fa0edebf28de031d9d.tar.bz2
gentoo-2-211c77419e2ccdeef87830fa0edebf28de031d9d.zip
Fix up bug 297146 for documentation location. And add new revision for the pending qt3 removal. 0.2.5-r0 has fully specified qt3 support that works for the moment, but is to be pmasked when qt3 mask comes. 0.2.5-r1 has qt3 support disabled.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/libodbc++')
-rw-r--r--dev-db/libodbc++/ChangeLog11
-rw-r--r--dev-db/libodbc++/libodbc++-0.2.5-r1.ebuild103
-rw-r--r--dev-db/libodbc++/libodbc++-0.2.5.ebuild12
3 files changed, 120 insertions, 6 deletions
diff --git a/dev-db/libodbc++/ChangeLog b/dev-db/libodbc++/ChangeLog
index 09a71a2122a0..55a82825a7bf 100644
--- a/dev-db/libodbc++/ChangeLog
+++ b/dev-db/libodbc++/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-db/libodbc++
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libodbc++/ChangeLog,v 1.19 2010/02/19 21:41:22 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libodbc++/ChangeLog,v 1.20 2010/02/19 21:55:11 robbat2 Exp $
+
+*libodbc++-0.2.5-r1 (19 Feb 2010)
+
+ 19 Feb 2010; Robin H. Johnson <robbat2@gentoo.org> libodbc++-0.2.5.ebuild,
+ +libodbc++-0.2.5-r1.ebuild:
+ Fix up bug 297146 for documentation location. And add new revision for the
+ pending qt3 removal. 0.2.5-r0 has fully specified qt3 support that works
+ for the moment, but is to be pmasked when qt3 mask comes. 0.2.5-r1 has qt3
+ support disabled.
*libodbc++-0.2.5 (19 Feb 2010)
diff --git a/dev-db/libodbc++/libodbc++-0.2.5-r1.ebuild b/dev-db/libodbc++/libodbc++-0.2.5-r1.ebuild
new file mode 100644
index 000000000000..3781fe7369d2
--- /dev/null
+++ b/dev-db/libodbc++/libodbc++-0.2.5-r1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libodbc++/libodbc++-0.2.5-r1.ebuild,v 1.1 2010/02/19 21:55:11 robbat2 Exp $
+
+EAPI=2
+inherit eutils flag-o-matic
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~x86"
+
+DESCRIPTION="Libodbc++ is a c++ class library that provides a subset of the well-known JDBC 2.0(tm) and runs on top of ODBC."
+SRC_URI="mirror://sourceforge/libodbcxx/${P}.tar.bz2"
+HOMEPAGE="http://libodbcxx.sourceforge.net/"
+LICENSE="LGPL-2.1"
+SLOT=0
+IUSE=""
+
+DEPEND="dev-db/unixODBC
+ sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+SB="${S}-build"
+SB_MT="${S}-build-mt"
+# QT3 is no longer supported in Gentoo.
+#SB_QT="${S}-build_qt"
+#SB_QT_MT="${S}-build_qt-mt"
+
+src_prepare() {
+ #epatch "${FILESDIR}"/${PN}-0.2.3-std-streamsize.patch
+ epatch "${FILESDIR}"/${PN}-0.2.3-doxygen.patch
+ epatch "${FILESDIR}"/${PN}-0.2.3-gcc41.patch
+ #epatch "${FILESDIR}"/${PN}-0.2.3-gcc43.patch
+ #epatch "${FILESDIR}"/${PN}-0.2.3-typecast.patch
+ epatch "${FILESDIR}"/${PN}-0.2.3-gcc44.patch
+
+ # Fix configure to use ncurses instead of termcap (bug #103105)
+ sed -i -e 's~termcap~ncurses~g' configure
+}
+
+src_configure() {
+ local commonconf buildlist
+ commonconf="--with-odbc=/usr --without-tests"
+ commonconf="${commonconf} --enable-static --enable-shared"
+ # " --enable-threads"
+
+ export ECONF_SOURCE="${S}"
+ append-flags -DODBCXX_DISABLE_READLINE_HACK
+
+ buildlist="${SB} ${SB_MT}"
+ #use qt3 && buildlist="${buildlist} $SB_QT $SB_QT_MT"
+
+ for sd in ${buildlist}; do
+ einfo "Doing configure pass for $sd"
+ mkdir -p "${sd}"
+ cd "${sd}"
+ commonconf2=''
+ LIBS=''
+ [ "${sd}" == "${SB_MT}" -o "${sd}" == "${SB_QT_MT}" ] && commonconf2="${commonconf2} --enable-threads"
+ [ "${sd}" == "${SB_QT}" -o "${sd}" == "${SB_QT_MT}" ] && commonconf2="${commonconf2} --with-qt"
+ # isql++ tool fails to compile:
+ #libodbc++-0.2.5/isql++/isql++.cpp: In constructor 'Isql::Isql(odbc::Connection*)':
+ #libodbc++-0.2.5/isql++/isql++.cpp:275: error: invalid cast to function type 'char** ()()'
+ #[ "${sd}" == "${SB}" ] && commonconf2="${commonconf2} --with-isqlxx"
+ # Upstream configure is broken as well, passing --without or
+ # --with-isqlxx=no will turn it ON instead of forcing it off.
+ #commonconf2="${commonconf2} _-without-isqlxx"
+ [ "${sd}" == "${SB_QT}" ] && commonconf2="${commonconf2} --with-qtsqlxx"
+ export LIBS
+ # using without-qt breaks the build
+ #--without-qt \
+ econf \
+ ${commonconf} \
+ ${commonconf2} \
+ || die "econf failed"
+ done
+}
+
+src_compile() {
+ local buildlist failures
+ buildlist="${SB} ${SB_MT}"
+ #use qt3 && buildlist="${buildlist} $SB_QT $SB_QT_MT"
+ for sd in ${buildlist}; do
+ einfo "Doing compile pass for $sd"
+ cd "${sd}"
+ emake LIBS='' || failures="${failures} ${sd//${S}-}"
+ done
+ [ -n "${failures}" ] && die "Failures: ${failures}"
+}
+
+src_install () {
+ dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
+
+ buildlist="${SB} ${SB_MT}"
+ #use qt3 && buildlist="${buildlist} $SB_QT $SB_QT_MT"
+ for sd in ${buildlist}; do
+ einfo "Doing install pass for $sd"
+ cd ${sd}
+ emake DESTDIR="${D}" install || die "make install failed"
+ done
+ if [[ "${P}" != "${PF}" ]]; then
+ mv "${D}"/usr/share/doc/${P}/* "${D}"/usr/share/doc/${PF}/
+ rmdir "${D}"/usr/share/doc/${P}
+ fi
+}
diff --git a/dev-db/libodbc++/libodbc++-0.2.5.ebuild b/dev-db/libodbc++/libodbc++-0.2.5.ebuild
index 1256aa8baf15..3a0b53ca3458 100644
--- a/dev-db/libodbc++/libodbc++-0.2.5.ebuild
+++ b/dev-db/libodbc++/libodbc++-0.2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libodbc++/libodbc++-0.2.5.ebuild,v 1.1 2010/02/19 21:41:22 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libodbc++/libodbc++-0.2.5.ebuild,v 1.2 2010/02/19 21:55:11 robbat2 Exp $
EAPI=2
inherit eutils flag-o-matic
@@ -15,6 +15,7 @@ SLOT=0
IUSE="qt3"
DEPEND="dev-db/unixODBC
+ qt3? ( dev-db/unixODBC[qt3] )
sys-libs/ncurses"
RDEPEND="${DEPEND}"
@@ -24,9 +25,7 @@ SB_MT="${S}-build-mt"
#SB_QT="${S}-build_qt"
SB_QT_MT="${S}-build_qt-mt"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
#epatch "${FILESDIR}"/${PN}-0.2.3-std-streamsize.patch
epatch "${FILESDIR}"/${PN}-0.2.3-doxygen.patch
epatch "${FILESDIR}"/${PN}-0.2.3-gcc41.patch
@@ -89,7 +88,6 @@ src_compile() {
}
src_install () {
- cd "${S}"
dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
buildlist="${SB} ${SB_MT}"
@@ -99,4 +97,8 @@ src_install () {
cd ${sd}
emake DESTDIR="${D}" install || die "make install failed"
done
+ if [[ "${P}" != "${PF}" ]]; then
+ mv "${D}"/usr/share/doc/${P}/* "${D}"/usr/share/doc/${PF}/
+ rmdir "${D}"/usr/share/doc/${P}
+ fi
}