summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2006-10-14 20:46:31 +0000
committerPeter Volkov <pva@gentoo.org>2006-10-14 20:46:31 +0000
commitabc6be4cdd92cf60ddf7aa04a9a6ceb306c520ea (patch)
tree089e87b3269ed640acac5ea93a0845af98b2d163 /dev-db/gigabase
parentRemove unused files (diff)
downloadgentoo-2-abc6be4cdd92cf60ddf7aa04a9a6ceb306c520ea.tar.gz
gentoo-2-abc6be4cdd92cf60ddf7aa04a9a6ceb306c520ea.tar.bz2
gentoo-2-abc6be4cdd92cf60ddf7aa04a9a6ceb306c520ea.zip
Version bump.
(Portage version: 2.1.1)
Diffstat (limited to 'dev-db/gigabase')
-rw-r--r--dev-db/gigabase/ChangeLog7
-rw-r--r--dev-db/gigabase/files/digest-gigabase-3.523
-rw-r--r--dev-db/gigabase/gigabase-3.52.ebuild44
3 files changed, 53 insertions, 1 deletions
diff --git a/dev-db/gigabase/ChangeLog b/dev-db/gigabase/ChangeLog
index 36ede7a1c698..f0cf49b341f3 100644
--- a/dev-db/gigabase/ChangeLog
+++ b/dev-db/gigabase/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/gigabase
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/gigabase/ChangeLog,v 1.14 2006/09/08 04:48:16 tsunam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/gigabase/ChangeLog,v 1.15 2006/10/14 20:46:31 pva Exp $
+
+*gigabase-3.52 (14 Oct 2006)
+
+ 14 Oct 2006; Peter Volkov <pva@gentoo.org> +gigabase-3.52.ebuild:
+ Version bump.
08 Sep 2006; Joshua Jackson <tsunam@gentoo.org> gigabase-3.51.ebuild:
Stable x86; bug #145549
diff --git a/dev-db/gigabase/files/digest-gigabase-3.52 b/dev-db/gigabase/files/digest-gigabase-3.52
new file mode 100644
index 000000000000..f5129d31a17a
--- /dev/null
+++ b/dev-db/gigabase/files/digest-gigabase-3.52
@@ -0,0 +1,3 @@
+MD5 3a1e3a274f9c17d73997371d8c3176af gigabase-3.52.tar.gz 1419145
+RMD160 927aafb61a04e8658853dc1fbe583e87c9c9d80d gigabase-3.52.tar.gz 1419145
+SHA256 b29dd0625e62b4dde62a5f4b290b70df50aeacac9cd9031cf2265ab056d0ad99 gigabase-3.52.tar.gz 1419145
diff --git a/dev-db/gigabase/gigabase-3.52.ebuild b/dev-db/gigabase/gigabase-3.52.ebuild
new file mode 100644
index 000000000000..8d5573483828
--- /dev/null
+++ b/dev-db/gigabase/gigabase-3.52.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/gigabase/gigabase-3.52.ebuild,v 1.1 2006/10/14 20:46:31 pva Exp $
+
+inherit multilib
+
+DESCRIPTION="OO-DBMS with interfaces for C/C++/Java/PHP/Perl"
+HOMEPAGE="http://www.garret.ru/~knizhnik/gigabase.html"
+SRC_URI="mirror://sourceforge/gigabase/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~s390 ~x86"
+IUSE="doc"
+DEPEND=""
+
+S="${WORKDIR}"/gigabase
+
+src_compile() {
+ mf="${S}/Makefile"
+
+ econf || die "econf failed"
+
+ sed -r -i -e 's/subsql([^\.]|$)/subsql-gdb\1/' ${mf}
+
+ emake || die "compilation failed"
+}
+
+src_install() {
+ einstall || die "make install failed"
+
+ dodoc CHANGES
+ use doc && dohtml GigaBASE.htm
+ use doc && dohtml -r docs/html/*
+}
+
+pkg_postinst() {
+ elog "The subsql binary has been renamed to subsql-gdb,"
+ elog "to avoid a name clash with the FastDB version of subsql"
+ echo
+ ewarn "Content of indices created by old (<=3.42) version of GigaBASE with"
+ ewarn "USE_LOCALE_SETTINGS enabled and using non-standard locale will be"
+ ewarn "different with format used by version 3.43 and higher. So you will"
+ ewarn "have to recreate indices in this case."
+}