summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-06-27 18:50:48 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-06-27 18:50:48 +0000
commite29442d490aecc76bfd367566b312ebaeed75cb5 (patch)
treec52279280e88a4e9319e0e551913d51660eead7e /dev-cpp
parentremove libmikmod and alsaequal with abi_x86_32 and depend on their multilib m... (diff)
downloadgentoo-2-e29442d490aecc76bfd367566b312ebaeed75cb5.tar.gz
gentoo-2-e29442d490aecc76bfd367566b312ebaeed75cb5.tar.bz2
gentoo-2-e29442d490aecc76bfd367566b312ebaeed75cb5.zip
fix build with dev-util/boost-build-1.49.0 wrt #475014
(Portage version: 2.2.0_alpha185/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/luabind/ChangeLog5
-rw-r--r--dev-cpp/luabind/luabind-0.9.1.ebuild13
2 files changed, 14 insertions, 4 deletions
diff --git a/dev-cpp/luabind/ChangeLog b/dev-cpp/luabind/ChangeLog
index 0df1271a11bc..2347605512ec 100644
--- a/dev-cpp/luabind/ChangeLog
+++ b/dev-cpp/luabind/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-cpp/luabind
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/luabind/ChangeLog,v 1.2 2013/05/04 10:37:19 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/luabind/ChangeLog,v 1.3 2013/06/27 18:50:48 hasufell Exp $
+
+ 27 Jun 2013; Julian Ospald <hasufell@gentoo.org> luabind-0.9.1.ebuild:
+ fix build with dev-util/boost-build-1.49.0 wrt #475014
04 May 2013; Julian Ospald <hasufell@gentoo.org> luabind-0.9.1.ebuild:
remove libdir hack and use config switch instead
diff --git a/dev-cpp/luabind/luabind-0.9.1.ebuild b/dev-cpp/luabind/luabind-0.9.1.ebuild
index 7e5b1e9a1809..cbfa2f5b6732 100644
--- a/dev-cpp/luabind/luabind-0.9.1.ebuild
+++ b/dev-cpp/luabind/luabind-0.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/luabind/luabind-0.9.1.ebuild,v 1.3 2013/05/04 10:38:34 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/luabind/luabind-0.9.1.ebuild,v 1.4 2013/06/27 18:50:48 hasufell Exp $
# NOTE: cross compiling is probably broken
@@ -24,11 +24,18 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-boost.patch
+
+ # backwardscomapt with old boost-build-1.49.0
+ if [[ -e $(which bjam-1_49 2>/dev/null) ]] ; then
+ my_bjam_bin=bjam-1_49
+ else
+ my_bjam_bin=bjam
+ fi
}
src_compile() {
# linkflags get appended, so they actually do nothing
- bjam release \
+ ${my_bjam_bin} release \
-d+2 \
--prefix="${D}/usr/" \
--libdir="${D}/usr/$(get_libdir)" \
@@ -38,7 +45,7 @@ src_compile() {
}
src_install() {
- bjam release \
+ ${my_bjam_bin} release \
-d+2 \
--prefix="${D}/usr/" \
--libdir="${D}/usr/$(get_libdir)" \