summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2003-08-31 07:32:59 +0000
committerTim Yamin <plasmaroo@gentoo.org>2003-08-31 07:32:59 +0000
commit130857282a6fe6794b175f0080cde59cf8617f7f (patch)
treee4a8cdadee77e1236ac4f00f9a99b53edd517e35 /dev-cpp
parentInitial Import [bug #23652] (diff)
downloadgentoo-2-130857282a6fe6794b175f0080cde59cf8617f7f.tar.gz
gentoo-2-130857282a6fe6794b175f0080cde59cf8617f7f.tar.bz2
gentoo-2-130857282a6fe6794b175f0080cde59cf8617f7f.zip
Initial Import [bug #23652]
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/prc-tools/ChangeLog10
-rw-r--r--dev-cpp/prc-tools/Manifest5
-rw-r--r--dev-cpp/prc-tools/files/digest-prc-tools-2.25
-rw-r--r--dev-cpp/prc-tools/files/prc-tools-2.2-compilefix.patch224
-rw-r--r--dev-cpp/prc-tools/prc-tools-2.2.ebuild116
5 files changed, 358 insertions, 2 deletions
diff --git a/dev-cpp/prc-tools/ChangeLog b/dev-cpp/prc-tools/ChangeLog
new file mode 100644
index 000000000000..f58dde3d885e
--- /dev/null
+++ b/dev-cpp/prc-tools/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-cpp/prc-tools
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/prc-tools/ChangeLog,v 1.1 2003/08/31 07:32:50 plasmaroo Exp $
+
+*prc-tools-2.2 (31 Aug 2003)
+
+ 31 Aug 2003; <plasmaroo@gentoo.org> prc-tools-2.2.ebuild,
+ files/prc-tools-2.2-compilefix.patch:
+ Initial Import
+
diff --git a/dev-cpp/prc-tools/Manifest b/dev-cpp/prc-tools/Manifest
index 090ae4e45187..7ed181fdd24e 100644
--- a/dev-cpp/prc-tools/Manifest
+++ b/dev-cpp/prc-tools/Manifest
@@ -1,3 +1,4 @@
-MD5 a12f3041cbf115837383f82cb7d144ca prc-tools-2.2.ebuild 3004
-MD5 fcc20c7b30e20c7bc95f2accdfe8f569 files/prc-tools-2.2-compilefix.patch 6620
+MD5 4a23529292615a360028ad097f442726 ChangeLog 367
+MD5 af0724dee1caa187acbe966a3d0e139d prc-tools-2.2.ebuild 3094
MD5 4c73bc92caa33aa26b5c07c25bea44a3 files/digest-prc-tools-2.2 330
+MD5 fcc20c7b30e20c7bc95f2accdfe8f569 files/prc-tools-2.2-compilefix.patch 6620
diff --git a/dev-cpp/prc-tools/files/digest-prc-tools-2.2 b/dev-cpp/prc-tools/files/digest-prc-tools-2.2
new file mode 100644
index 000000000000..97bd4bfba923
--- /dev/null
+++ b/dev-cpp/prc-tools/files/digest-prc-tools-2.2
@@ -0,0 +1,5 @@
+MD5 91a9a04d2042fcf673ff212a3ffd7ab9 prc-tools-2.2.tar.gz 319626
+MD5 eeef1c5c1e19de859783aaadbb57a75f prc-tools-20030213.tar.gz 314451
+MD5 f67fe2e8065c5683bc34782de131f5d3 binutils-2.12.1.tar.bz2 9543675
+MD5 70e4ade69a2dff2c7b9af9a4ef44798f gdb-5.3.tar.bz2 11198721
+MD5 87ee083a830683e2aaa57463940a0c3c gcc-2.95.3.tar.bz2 9848842
diff --git a/dev-cpp/prc-tools/files/prc-tools-2.2-compilefix.patch b/dev-cpp/prc-tools/files/prc-tools-2.2-compilefix.patch
new file mode 100644
index 000000000000..10bb44ef2c46
--- /dev/null
+++ b/dev-cpp/prc-tools/files/prc-tools-2.2-compilefix.patch
@@ -0,0 +1,224 @@
+--- prc-tools-2.2/binutils/configure.in 2002-05-15 00:47:22.000000000 +0100
++++ prc-tools-2.2/binutils/configure.in 2003-07-01 22:02:49.000000000 +0100
+@@ -508,35 +508,38 @@
+ fi
+
+ # Handle ${copy_dirs}
+-set fnord ${copy_dirs}
+-shift
+-while [ $# != 0 ]; do
+- if [ -f $2/COPIED ] && [ x"`cat $2/COPIED`" = x"$1" ]; then
+- :
+- else
+- echo Copying $1 to $2
+-
+- # Use the install script to create the directory and all required
+- # parent directories.
+- if [ -d $2 ]; then
+- :
+- else
+- echo >config.temp
+- ${srcdir}/install-sh -c -m 644 config.temp $2/COPIED
+- fi
+-
+- # Copy the directory, assuming we have tar.
+- # FIXME: Should we use B in the second tar? Not all systems support it.
+- (cd $1; tar -cf - .) | (cd $2; tar -xpf -)
+-
+- # It is the responsibility of the user to correctly adjust all
+- # symlinks. If somebody can figure out how to handle them correctly
+- # here, feel free to add the code.
+-
+- echo $1 > $2/COPIED
+- fi
+- shift; shift
+-done
++### DISABLED ---> plasmaroo@plasmaroo.squirrelserver.co.uk
++### prc-tools compile fix to prevent sandbox
++### errors
++# set fnord ${copy_dirs}
++# shift
++# while [ $# != 0 ]; do
++# if [ -f $2/COPIED ] && [ x"`cat $2/COPIED`" = x"$1" ]; then
++# :
++# else
++# echo Copying $1 to $2
++#
++# # Use the install script to create the directory and all required
++# # parent directories.
++# if [ -d $2 ]; then
++# :
++# else
++# echo >config.temp
++# ${srcdir}/install-sh -c -m 644 config.temp $2/COPIED
++# fi
++#
++# # Copy the directory, assuming we have tar.
++# # FIXME: Should we use B in the second tar? Not all systems support it.
++# (cd $1; tar -cf - .) | (cd $2; tar -xpf -)
++#
++# # It is the responsibility of the user to correctly adjust all
++# # symlinks. If somebody can figure out how to handle them correctly
++# # here, feel free to add the code.
++#
++# echo $1 > $2/COPIED
++# fi
++# shift; shift
++#done
+
+ # Configure extra directories which are host specific
+
+--- prc-tools-2.2/gcc/configure.in 2002-05-15 00:47:22.000000000 +0100
++++ prc-tools-2.2/gcc/configure.in 2003-07-01 22:02:49.000000000 +0100
+@@ -470,36 +470,39 @@
+ esac
+ fi
+
+ # Handle ${copy_dirs}
+-set fnord ${copy_dirs}
+-shift
+-while [ $# != 0 ]; do
+- if [ -f $2/COPIED ] && [ x"`cat $2/COPIED`" = x"$1" ]; then
+- :
+- else
+- echo Copying $1 to $2
+-
+- # Use the install script to create the directory and all required
+- # parent directories.
+- if [ -d $2 ]; then
+- :
+- else
+- echo >config.temp
+- ${srcdir}/install-sh -c -m 644 config.temp $2/COPIED
+- fi
+-
+- # Copy the directory, assuming we have tar.
+- # FIXME: Should we use B in the second tar? Not all systems support it.
+- (cd $1; tar -cf - .) | (cd $2; tar -xpf -)
+-
+- # It is the responsibility of the user to correctly adjust all
+- # symlinks. If somebody can figure out how to handle them correctly
+- # here, feel free to add the code.
+-
+- echo $1 > $2/COPIED
+- fi
+- shift; shift
+-done
++### DISABLED ---> plasmaroo@plasmaroo.squirrelserver.co.uk
++### prc-tools compile fix to prevent sandbox
++### errors
++#set fnord ${copy_dirs}
++#shift
++#while [ $# != 0 ]; do
++# if [ -f $2/COPIED ] && [ x"`cat $2/COPIED`" = x"$1" ]; then
++# :
++# else
++# echo Copying $1 to $2
++#
++# # Use the install script to create the directory and all required
++# # parent directories.
++# if [ -d $2 ]; then
++# :
++# else
++# echo >config.temp
++# ${srcdir}/install-sh -c -m 644 config.temp $2/COPIED
++# fi
++#
++# # Copy the directory, assuming we have tar.
++# # FIXME: Should we use B in the second tar? Not all systems support it.
++# (cd $1; tar -cf - .) | (cd $2; tar -xpf -)
++#
++# # It is the responsibility of the user to correctly adjust all
++# # symlinks. If somebody can figure out how to handle them correctly
++# # here, feel free to add the code.
++#
++# echo $1 > $2/COPIED
++# fi
++# shift; shift
++#done
+
+ # Configure extra directories which are host specific
+
+--- prc-tools-2.2/doc/Makefile.in 2002-08-03 01:02:16.000000000 +0100
++++ prc-tools-2.2/doc/Makefile.in 2003-07-02 12:59:41.000000000 +0100
+@@ -16,7 +16,8 @@
+ exec_prefix = @exec_prefix@
+ palmdev_prefix = @palmdev_prefix@
+ infodir = @infodir@
+-htmldir = @htmldocs_prefix@
++htmldir = ${D}/@htmldocs_prefix@
++ # Portage fix - install to ${D} instead...
+
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+
+--- prc-tools-2.2/gdb/configure.in 2002-12-10 21:34:10.000000000 +0000
++++ prc-tools-2.2/gdb/configure.in 2003-07-03 17:49:38.000000000 +0100
+@@ -909,35 +909,38 @@
+ fi
+
+ # Handle ${copy_dirs}
+-set fnord ${copy_dirs}
+-shift
+-while test $# != 0 ; do
+- if test -f $2/COPIED && test x"`cat $2/COPIED`" = x"$1" ; then
+- :
+- else
+- echo Copying $1 to $2
+-
+- # Use the install script to create the directory and all required
+- # parent directories.
+- if test -d $2 ; then
+- :
+- else
+- echo >config.temp
+- ${srcdir}/install-sh -c -m 644 config.temp $2/COPIED
+- fi
+-
+- # Copy the directory, assuming we have tar.
+- # FIXME: Should we use B in the second tar? Not all systems support it.
+- (cd $1; tar -cf - .) | (cd $2; tar -xpf -)
+-
+- # It is the responsibility of the user to correctly adjust all
+- # symlinks. If somebody can figure out how to handle them correctly
+- # here, feel free to add the code.
+-
+- echo $1 > $2/COPIED
+- fi
+- shift; shift
+-done
++### DISABLED ---> plasmaroo@plasmaroo.squirrelserver.co.uk
++### prc-tools compile fix to prevent sandbox
++### errors
++# set fnord ${copy_dirs}
++# shift
++# while test $# != 0 ; do
++# if test -f $2/COPIED && test x"`cat $2/COPIED`" = x"$1" ; then
++# :
++# else
++# echo Copying $1 to $2
++#
++# # Use the install script to create the directory and all required
++# # parent directories.
++# if test -d $2 ; then
++# :
++# else
++# echo >config.temp
++# ${srcdir}/install-sh -c -m 644 config.temp $2/COPIED
++# fi
++#
++# # Copy the directory, assuming we have tar.
++# # FIXME: Should we use B in the second tar? Not all systems support it.
++# (cd $1; tar -cf - .) | (cd $2; tar -xpf -)
++#
++# # It is the responsibility of the user to correctly adjust all
++# # symlinks. If somebody can figure out how to handle them correctly
++# # here, feel free to add the code.
++#
++# echo $1 > $2/COPIED
++# fi
++# shift; shift
++#done
+
+ # Work in distributions that contain no compiler tools, like Autoconf.
+ tentative_cc=""
diff --git a/dev-cpp/prc-tools/prc-tools-2.2.ebuild b/dev-cpp/prc-tools/prc-tools-2.2.ebuild
new file mode 100644
index 000000000000..e24473bfd3ce
--- /dev/null
+++ b/dev-cpp/prc-tools/prc-tools-2.2.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc. and Tim Yamin [plasmaroo@gentoo.org]
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/prc-tools/prc-tools-2.2.ebuild,v 1.1 2003/08/31 07:32:50 plasmaroo Exp $
+
+DESCRIPTION="GNU-Based Palm C++ Development Suite"
+
+BIN_V="binutils-2.12.1"
+GDB_V="gdb-5.3"
+GCC_V="gcc-2.95.3"
+PRC_X="prc-tools-20030213"
+
+ # A working patch from a non-working CVS snapshot is needed
+ # to get GDB to compile under Gentoo 1.2.x. See #23652...
+
+SRC_URI="http://dl.sourceforge.net/sourceforge/prc-tools/${P}.tar.gz
+ http://prc-tools.sourceforge.net/misc/${PRC_X}.tar.gz
+ ftp://sources.redhat.com/pub/binutils/releases/${BIN_V}.tar.bz2
+ ftp://sources.redhat.com/pub/gdb/old-releases/${GDB_V}.tar.bz2
+ ftp://gcc.gnu.org/pub/gcc/releases/${GCC_V}/${GCC_V}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT=0
+
+HOMEPAGE="http://prc-tools.sourceforge.net"
+DEPEND=">=app-text/texi2html-1.64"
+
+S=${WORKDIR}/${P}
+
+src_unpack () {
+ cd ${WORKDIR}
+ unpack ${A} || die
+
+ cd ${P}
+ ln -s ../${BIN_V} binutils
+ ln -s ../${GDB_V} gdb
+ ln -s ../${GCC_V} gcc
+ cd ..
+
+ echo ">>> Patching sources..."
+ echo -n " "; epatch ${P}/${BIN_V}.palmos.diff || die
+ echo -n " "; epatch ${PRC_X}/${GDB_V}.palmos.diff || die
+ echo -n " "; epatch ${P}/${GCC_V}.palmos.diff || die
+ echo -n " "; epatch ${FILESDIR}/prc-tools-2.2-compilefix.patch || die
+
+ # This last patch disables dummy headers being copied.
+ # a) They're not needed
+ # b) This causes a sandboxing error
+ # +) Keeps 'palmdev-prep' pointed at the
+ # right place while making the docs install
+ # script from not install them to real root /
+
+}
+
+src_config () {
+
+ cd ..
+ mkdir build
+ cd build
+ # mkdir empty
+
+ echo ">>> Configuring..."
+ echo
+
+ # Remove any flags; because the cross-compiler (2.9.x GCC)
+ # will not understand any of these optimizations {and will
+ # fail} once the cross-compiler compiles the m68k/arm GCC suite
+
+ export ALLOWED_FLAGS="-pipe -0 -01 -02"
+ strip-flags
+
+ ../${P}/configure --enable-targets=m68k-palmos,arm-palmos \
+ --enable-languages=c,c++ \
+ --with-headers=${WORKDIR}/build/empty --enable-html-docs \
+ --with-palmdev-prefix=/opt/palmdev --prefix=/usr || die
+
+ # These have to be real; otherwise the compiler is hard-coded
+ # and tries to find libraries in ${D}/....
+
+ # palmdev-prefix also has to be real; otherwise 'palmdev-prep'
+ # defaults to virtual ${D}/..
+
+}
+
+src_compile () {
+
+ src_config
+ make || die
+
+}
+
+src_install () {
+
+ cd ..
+ cd build
+ einstall || die
+
+}
+
+pkg_postinst () {
+
+ echo
+ einfo "PRC-Tools is now compiled and installed!"
+ einfo "<HTML docs are installed in /opt/palmdev>"
+ echo
+ einfo "For a complete Palm Development Environment you will also need..."
+ echo
+ einfo "[ ] PilRC; the Palm resource compiler; emerge pilrc"
+ einfo "[ ] POSE; The Palm OS Emulator; emerge pose"
+ echo " ->> A ROM for POSE; available from Palm"
+ einfo "[ ] An SDK; available from the Palm Website"
+ echo " ->> Decompress this to /opt/palmdev and then run"
+ echo " 'palmdev-prep /opt/palmdev'"
+ echo
+
+}