summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-03-14 12:14:12 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-03-14 12:14:12 +0000
commit8eb3f71db06c6406e6624bd900ab51c708d46fd7 (patch)
tree0237eed36e95b48fe2abc759bff51e5395898685 /dev-cpp/tbb
parentVersion bump. Remove old. Fixes bugs #255755 and #261495. (diff)
downloadgentoo-2-8eb3f71db06c6406e6624bd900ab51c708d46fd7.tar.gz
gentoo-2-8eb3f71db06c6406e6624bd900ab51c708d46fd7.tar.bz2
gentoo-2-8eb3f71db06c6406e6624bd900ab51c708d46fd7.zip
Initial import. The ebuild differs much from the initial ebuild submitted by Matthew McCormick (bug #228641)
(Portage version: 2.2_rc25/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/tbb')
-rw-r--r--dev-cpp/tbb/ChangeLog11
-rw-r--r--dev-cpp/tbb/metadata.xml18
-rw-r--r--dev-cpp/tbb/tbb-2.1.015.ebuild84
3 files changed, 113 insertions, 0 deletions
diff --git a/dev-cpp/tbb/ChangeLog b/dev-cpp/tbb/ChangeLog
new file mode 100644
index 000000000000..c3a078428e1f
--- /dev/null
+++ b/dev-cpp/tbb/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-cpp/tbb
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/ChangeLog,v 1.1 2009/03/14 12:14:12 bicatali Exp $
+
+*tbb-2.1.015 (14 Mar 2009)
+
+ 14 Mar 2009; Sébastien Fabbro <bicatali@gentoo.org> +metadata.xml,
+ +tbb-2.1.015.ebuild:
+ Initial import. The ebuild differs much from the initial ebuild submitted
+ by Matthew McCormick (bug #228641)
+
diff --git a/dev-cpp/tbb/metadata.xml b/dev-cpp/tbb/metadata.xml
new file mode 100644
index 000000000000..6ecbf08f597d
--- /dev/null
+++ b/dev-cpp/tbb/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>bicatali@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+ The Intel Threading Building Blocks is a library that helps you
+ leverage multi-core processor performance without having to be a
+ threading expert. It represents a higher-level, task-based
+ parallelism that abstracts platform details and threading mechanism
+ for performance and scalability.
+ The Gentoo package installs the commercially aligned release since
+ it seemed to be more stable and with as many features as the stable
+ one.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-cpp/tbb/tbb-2.1.015.ebuild b/dev-cpp/tbb/tbb-2.1.015.ebuild
new file mode 100644
index 000000000000..fcb2f2078316
--- /dev/null
+++ b/dev-cpp/tbb/tbb-2.1.015.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/tbb-2.1.015.ebuild,v 1.1 2009/03/14 12:14:12 bicatali Exp $
+
+EAPI=2
+inherit eutils versionator toolchain-funcs
+# url number
+MYU="78/135"
+# release update
+MYR="3"
+
+PV1="$(get_version_component_range 1)"
+PV2="$(get_version_component_range 2)"
+PV3="$(get_version_component_range 3)"
+MYP="${PN}${PV1}${PV2}_${PV3}oss"
+
+DESCRIPTION="High level abstract threading library"
+HOMEPAGE="http://www.threadingbuildingblocks.org/"
+SRC_URI="http://www.threadingbuildingblocks.org/uploads/${MYU}/${PV1}.${PV2}%20update%20${MYR}/${MYP}_src.tgz"
+LICENSE="GPL-2-with-exceptions"
+SLOT="${PV1}.${PV2}"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc examples"
+
+DEPEND=""
+RDEPEND=""
+S="${WORKDIR}/${MYP}"
+
+src_prepare() {
+ sed -i \
+ -e "s/-O2/${CXXFLAGS}/g" \
+ build/*.inc \
+ || die
+}
+
+src_compile() {
+ if [[ $(tc-getCXX) == *g++ ]]; then
+ myconf="compiler=gcc"
+ elif [[ $(tc-getCXX) == *ic*c ]]; then
+ myconf="compiler=icc"
+ fi
+ # from the Makefile, split debug
+ cd src
+ emake ${myconf} tbb_release tbbmalloc_release || die "emake failed"
+ if use debug || use examples; then
+ emake ${myconf} tbb_debug tbbmalloc_debug || die "emake debug failed"
+ fi
+}
+
+src_test() {
+ cd src
+ emake ${myconf} test_release || die "emake test failed"
+ if use debug || use examples; then
+ emake ${myconf} test_debug tbbmalloc_test_debug || die "emake test debug failed"
+ fi
+
+}
+
+src_install(){
+ insinto /usr/$(get_libdir)/${PN}-${SLOT}
+ insopts -m0755
+ for l in $(find build -name lib\*.so.\*); do
+ doins ${l}
+ # to fix when we have eselect stuff
+ local bl=$(basename ${l})
+ dosym ${PN}-${SLOT}/${bl} /usr/$(get_libdir)/${bl}
+ dosym ${bl} /usr/$(get_libdir)/${bl%.*}
+ done
+ insopts -m0644
+ dodoc README CHANGES doc/Release_Notes.txt
+ insinto /usr/include/${PN}-${SLOT}
+ dosym ${PN}-${SLOT} /usr/include/${PN}
+ doins -r include/tbb/* || die
+ if use doc ; then
+ insinto /usr/share/doc/${PF}
+ doins -r doc/html || die
+ fi
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples/build
+ doins build/*.inc || die
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples || die
+ fi
+}