summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Volynets <iluxa@gentoo.org>2009-12-13 12:09:40 +0000
committerIlya Volynets <iluxa@gentoo.org>2009-12-13 12:09:40 +0000
commit9c41dc0573d5cab85f651bac3c6fd72cb6521b97 (patch)
tree38b17c831203bddca6a64d9fbc53dee59e626e7a /dev-cpp/sptk
parentInitial version of dev-haskell/hashed-storage. (diff)
downloadgentoo-2-9c41dc0573d5cab85f651bac3c6fd72cb6521b97.tar.gz
gentoo-2-9c41dc0573d5cab85f651bac3c6fd72cb6521b97.tar.bz2
gentoo-2-9c41dc0573d5cab85f651bac3c6fd72cb6521b97.zip
Fix --as-needed compilation
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/sptk')
-rw-r--r--dev-cpp/sptk/ChangeLog6
-rw-r--r--dev-cpp/sptk/files/sptk-3.5.8.14-as-needed.patch16
-rw-r--r--dev-cpp/sptk/sptk-3.5.8.14-r1.ebuild3
3 files changed, 23 insertions, 2 deletions
diff --git a/dev-cpp/sptk/ChangeLog b/dev-cpp/sptk/ChangeLog
index 1174695aece2..d5f74cf48648 100644
--- a/dev-cpp/sptk/ChangeLog
+++ b/dev-cpp/sptk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-cpp/sptk
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.65 2009/10/03 21:34:19 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.66 2009/12/13 12:09:39 iluxa Exp $
+
+ 13 Dec 2009; Ilya A. Volynets-Evenbakh <iluxa@gentoo.org>
+ sptk-3.5.8.14-r1.ebuild, +files/sptk-3.5.8.14-as-needed.patch:
+ Fix --as-needed compilation. Thanks Kacper Kowalik
03 Oct 2009; Tomáš Chvátal <scarabeus@gentoo.org>
-sptk-3.5.7.13.ebuild:
diff --git a/dev-cpp/sptk/files/sptk-3.5.8.14-as-needed.patch b/dev-cpp/sptk/files/sptk-3.5.8.14-as-needed.patch
new file mode 100644
index 000000000000..b69bd0de1338
--- /dev/null
+++ b/dev-cpp/sptk/files/sptk-3.5.8.14-as-needed.patch
@@ -0,0 +1,16 @@
+This causes -lpthread to be added to the end of link list, after
+objects, as opposed to the middle. This way --as-needed linking
+is fixed.
+Thanks Kacper Kowalik <xarthisius.kk@gmail.com>
+
+--- sptk-3.5.8.14.orig/src/CMakeLists.txt 2009-12-13 12:39:36.408351609 +0100
++++ sptk-3.5.8.14/src/CMakeLists.txt 2009-12-13 12:54:14.591539074 +0100
+@@ -23,7 +23,7 @@
+ )
+
+ IF (NOT WIN32)
+- SET_TARGET_PROPERTIES (sputil3 PROPERTIES LINK_FLAGS "-lpthread")
++ TARGET_LINK_LIBRARIES (sputil3 pthread)
+ ENDIF (NOT WIN32)
+
+ IF (NOT NO_EXCEL)
diff --git a/dev-cpp/sptk/sptk-3.5.8.14-r1.ebuild b/dev-cpp/sptk/sptk-3.5.8.14-r1.ebuild
index bb4efd232c09..d0fc3c1890c7 100644
--- a/dev-cpp/sptk/sptk-3.5.8.14-r1.ebuild
+++ b/dev-cpp/sptk/sptk-3.5.8.14-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.5.8.14-r1.ebuild,v 1.2 2009/09/22 11:00:41 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.5.8.14-r1.ebuild,v 1.3 2009/12/13 12:09:39 iluxa Exp $
EAPI=1
@@ -32,6 +32,7 @@ CMAKE_IN_SOURCE_BUILD=1
src_unpack() {
unpack ${A}
epatch "${FILESDIR}/sptk-gcc-4.4.patch"
+ epatch "${FILESDIR}/${P}-as-needed.patch"
}
src_compile() {